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FCC Compliance Statement 

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two 
conditions: 
1. This device may not cause harmful interference, and 
2. This device must accept any interference received, including interference that may cause 
undesired operation. 
 

FCC Class B Digital Device 

NOTE: This equipment has been tested and found to comply with the limits for a Class B digital 
device, pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable 
protection against harmful interference in a residential installation. This equipment generates, 
uses, and can radiate radio frequency energy and, if not installed and used in accordance with 
the instructions, may cause harmful interference to radio communications. However, there is no 
guarantee that interference will not occur in a particular installation. If this equipment does 
cause harmful interference to radio or television reception, which can be determined by turning 
the equipment off and on, the user is encouraged to try to correct the interference by one or 
more of the following measures: 
 

‐ Reorient or relocate the receiving antenna. 
‐ Increase the separation between the equipment and receiver. 
‐ Connect the equipment into an outlet on a circuit different from that to which the receiver is 
connected. 
‐ Consult the dealer or an experienced radio/TV technician for help. 
 

This Class B digital apparatus complies with Canadian ICES‐003. 
 

Changes or Modifications 

CAUTION: Changes or modifications not expressly approved by the party responsible for 
compliance could void the user's authority to operate the equipment. 
 

CAUTION: This device must not be co‐located or operating in conjunction with any other 
antenna or transmitter. 
 

Detachable Antennas 

To reduce potential radio interference to other users, the antenna type and its gain should be so 
chosen that the equivalent isotropically radiated power (e.i.r.p.) is not more than that permitted 
for successful communication. 
 

External Antennas 

This device has been designed to operate with the antenna listed below, and having a maximum 
gain of 3 dBi. Antennas not included in this list or having a gain greater than 3 dBi are strictly 
prohibited for use with this device. The required antenna impedance is 50 ohms. 
 

Approved Antenna Listing 

Ceramic Chip Antenna Part No. ANT‐916‐CHP‐x (Manufacturer: Antenna Factor, Inc.) 
(Maximum Gain = 0.5 dBi) 
 

External Dipole Antenna Part No. W1063 (Manufacturer: Pulse Antennas) 
(Maximum Gain = 3.0 dBi) 
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Quick Startup 
Starting the Mote 

1. Attach the mote to the desired machine section. 

2. Remove the magnetic strip. 

The mote is now operational. 

 

Starting the Software 
1. Connect the coordinator via USB 2.0. 

2. Run the program. 

The program window will open with a dialog box called “Select a Port”. 

 Select the USB port into which you connected the coordinator (ex.: COM1). Selecting the wrong 

one will create an exception and error. If you closed the dialog box or connected to the wrong port, 

open it back up using File > Connect or the Connect button along the bottom of the program window. 

 

The program will automatically open a live window (see Figure 1), run a mote check to see which motes 

are connected and in range, group those connected motes together in a group, and display their RSSI 

(signal strengths) at the bottom of the live window. 

 

 
Figure 1: A screenshot of the live window in live view operation 
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Setup and Recording 

 
Figure 2: Setup portion of the live window 

 

1. Sync Time 

Press the button Sync Time near the bottom of the live window. This will ensure your PC, the 

coordinator, and all motes are running on the same time. 

 

2. Set Sampling Time 

In the text fields beside each of the mote IDs, input the lapse of time (in seconds) at which you would 

like each of the motes to record data. 

 

3. Record 

Press the Record button along the bottom of the live window. 

 

4. Press Live-On 

Press Live-On to have the motes send the data they are recording to the program so you can view it in 

real time. 

 

5. Stop Recording 

Once you have finished recording, press the Stop button along the bottom of the live window. 

 

Data Processing 
6. Get Logs 

To download the data you just recorded, make sure the program is no longer recording, and press the 

Get Logs button along the bottom of the live window. This will download the log files to your Program 

Files directory in the Logs folder. 

 

7. Convert to Data 

To view the data you have collected (in the log files) in a format that is more manageable, click the Logs 

to Data button along the bottom of the live window. The log files will be converted into data files, saved 

to your Program Files directory, under the Data folder. 
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Basic Operation of the Scanimetrics Mote 
Components 

The mote system is composed of three components: 

1. The mote containing a micro-controller system, a memory unit, sensor conditioning, radio, and a 

battery unit. 

a. Microcontroller which controls the mote 

b. Firmware (control) memory, Flash (data) Memory to record sensor data and optionally 

record temperature and battery on a timed basis 

c. Internal Battery 

 

 
Figure 3: The interior functioning of a Scanimetrics Mote 

 

2. The coordinator (USB connected) manages the motes and coordinates between the computer 

and the motes. 

3. MoteScan Software, Mote Data Analysis Software 
 

 
Figure 4: The interaction of the entire Scanimetrics mote system 
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Memory Capacity and Battery Life 

The basic mote will record 16 bits of sensor data at a rate of 0.1 second for approximetly 24 hours. 

The battery under full use will last approximetly 36 hours. 

 Optional extra memory is available as well as power control firmware to enable extended 

operation in time. 

 

Starting the Mote 

3. Attach the mote to the desired machine section. 

4. Remove the magnetic strip. 

The mote is now operational. 

 

To power down a mote, simply re-attach the magnetic strip. 

 

DISCLAIMER 

The system is subject to timing and radio handshaking limits. It is a multi-node radio packet network 

which is subject to impairments of communications. The system is such that it occasionally does require 

retries. 

 

Introduction to MoteScan Software 
 

Version 0.19.1 

 

Scanimetrics’ MoteScan software is divided into three components: 

1. The control for the motes is run on a PC, but commands the motes through a coordinator. 

2. The graphics-based user interface (GUI) shows in real time the data collected. 

3. MoteConvert (included with MoteScan) converts the log files downloaded from the motes into 

final data files, performing adjustments to align and format the data for consumption. 

 

 
Figure 5: The interactions between the motes, the coordinator, and your PC 
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MoteScan Graphics-Based User Interface (GUI) 
For General Use 

 

Version 0.19.1 

 

Starting the Software and Connecting the Coordinator 
 

 
Figure 6: MoteScan 0.19.1 opening window 

 

1. Connect the coordinator via USB 2.0. 

2. Run the program. 

The program window will open with a dialog box called “Select a Port”. 

 Select the USB port into which you connected the coordinator (ex.: COM1). Selecting the wrong 

one will create an exception and error. If you closed the dialog box or connected to the wrong port, 

open it back up using the Connect button along the bottom of the program window or File > Connect. 
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Live Graphics Window 
 

Once the program is running, and the coordinator is connected, the program will automatically open the 

live window, run a check to see which motes are connected and in range, group those connected motes 

together in a group, and display their signal strengths (RSSI) at the bottom of the live window. 

 

 
Figure 7: A screenshot of the live graphics window in live view operation  
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Graphics Window Layout 
 

Signal Strength and Status 
The section in the live window near the bottom lists all connected motes in working range. 

 

 
Figure 8: A screenshot of the strength and status section of the live window 

 

Group 

Allows you to set the active mote group by checking the boxes beside the mote numbers. See Set Group 

for more information. 

 The +/- button above the check boxes will select all or deselect all motes for the mote group. 

 

Mote ID 

Displays the ID number of the mote, followed by a program-assigned colour. 

 

Name 

Displays the mote name associated with the mote ID, as set in the config file (see Adding a Mote Name). 

 

Signal 

Represents the RSSI (Received Signal Strength Indicator) or strength of the signal received by the 

coordinator. 

 Green signifies operational strength. 

 Yellow is low signal strength: there is potential for data loss. 

 Red is very low signal strength: the coordinator is having difficulty talking to the mote, but there 

is no degradation in the sensor data, nor any loss of storage. 

 Grey signifies the signal bar is not showing a present reading. If the coordinator does not receive 

a signal for more than 16 seconds, the signal status turns to inactive. 

 

Status 

Indicates the status of the mote. 

 Inactive: the coordinator has not had communication from the mote in more than 16 seconds. 

 Active: the mote is in range and ready to receive communication. 

 Live: the mote is sending data to the program. 

 Downloading: the mote is downloading its data to the computer. 

NOTE: The mote can be recording in any state except when downloading. 
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Sample Time 

Allows you to modify separately the lapse of time between sensor data picked up by each mote. See Set 

Sample Time for more information. 

 

Battery 

Displays the battery strength of each mote, using the same colour indicators as for the signal strength. 

CAUTION: When the battery strength indicator is red, the mote system voltage has dropped 

below the specified voltage for writing the on-board flash memory. We recommend replacing 

the mote when the indicator drops into the yellow region. 

 

Sync Time 

Displays the time the motes were last synchronized. See Set Sync Time if each time is not within 0.1 

seconds of the others. 

 

Data 2 Disk 

Displays the number of data samples that have been downloaded to your computer from a certain 

mote. 

 

Version 

Displays the version of software each mote is running. 

CAUTION: All motes and coordinators need to be the same version to ensure the correct 

operation of the system 
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Strain and Temperature Graphs 
The top section displays strain and temperature graphs using data sent from the motes. 
 

 
Figure 9: A screenshot of the temperature graph section of the live window 

 

The graphs are kept in synchronization with each other and will automatically resize to the dimensions 

of the data displayed. The present time is represented at the end of the graph, with the preceding 

readings shown as recording history. Default history is 30 seconds. See below for more information. 

 

Column Headings 

Mote: Displays the mote name (as set in the mote.config file) and the mote’s colour. 

Ave: Displays the average data visible in the graph. 

Min: Displays the lowest data sample that mote took. 

Max: Displays the highest data sample that mote took. 
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Basic Operation 
For more information on each operation, click the titles to see the sections in Advanced Operation. 

 
Figure 10: The buttons along the bottom of the live window 

 

1. Graph > Show 

To open the live window if you closed it. 

NOTE: This operation does not start up the live feature. This is not the same as pressing the Live 

button along the bottom of the program window. 

 

2. Set Sample Time 

In the live window, enter the sample time you would like each mote to record at. To set all motes to the 

same sample time, input a sample time into the top-most mote, and press Set All. This will set both 

Channel A and temperature to the same sample time. If you do not wish to record temperature, please 

press the Sampling button along the bottom of the live window. 

 

3. Set Sync Time 

Before recording, press the Sync Time button in the live window to sync all motes with the coordinator’s 

time. This is very important for post processing of the data to function correctly. For more information 

on the Sync Time function, see Sync Time below. 

CAUTION: It is very important to remember to sync time before recording for all data to align 

properly. Be sure to also sync time if any motes have been powered down or lost power. 

CAUTION: If you sync time after you start recording, post-processing of data will not function 

properly, since it relies on the first and last samples having the same time stamp. 

 

4. Record 

To record all data sensed by the mote group you presently have set at the settings to which you have 

programmed that group until you command the group to stop. To program different motes to different 

settings, see Set Group. 

CAUTION: Recording overwrites all data saved to a mote. If you had any data on a mote prior to 

recording, be sure to download it to your computer first. 

NOTE: Record can also be found along the bottom of the program window and in the File menu. 

 

5. Live-On Button 

To have a real-time indication of the data being recorded. Click the Live button (along the bottom of the 

live window) to start the motes sending their data to the program. You must be recording to see any live 

data. Please see Record for more information. 

NOTE: You can press the Live button even if the live window is not open. The motes will send 

their data, but you will not be able to see it. 

NOTE: If data is not being recorded, using the live feature will not show anything. You must be 

recording to see the data. 
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6. Set Time Delay 
 

 
Figure 11: The set time delay field under the strain graph in the live window 

  

To set the length of time you want to be able to see in the graphs in the live window, enter the time into 

the text field right below the strain graph in the live window in the following format: xh ym zs (ex.: 1h 

25m 43s). If you do not wish to see more than 59 seconds, do not enter any hours or minutes. Both 

graphs will automatically set to that time delay. 

 

7. Live-Off Button 

To stop the incoming data from showing on the graphs. 

NOTE: This does not stop the recording process. To stop the recording process, you must press 

the Stop button or use File > Stop. 

 

8. Stop Button 

To stop recording. 

NOTE: Stop can also be found along the bottom of the program window. 

 

9. File > Get Logs 

To download the log files from the mote to your computer. 

NOTE: Stop recording before downloading the log files. The files will not download if you have 

not stopped recording. 

NOTE: Get Logs can also be found along the bottom of the program window. 

 

Useful Menus in GUI 
Please note that if you click the stitch line (see Figure 12) on the first item on each of the menus in the 

program window, the menu will pop out as a floating menu (see Figure 13), allowing you to have the 

commands open all the time. 

 

 

 

 

 

 

 

 

 

Graph 

Show 

Data 

Convert Logs to Data  

Figure 12: The Set… menu, showing 

the stitch line 

Figure 13: The Show menu 

as a floating menu 
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Advanced Operation 

Buttons Along the Bottom of the Live Window 

Sampling 

To choose the recording settings for the active mote group. This command 

opens a dialog box (see image to the left). 

Under Sample, select Channel A, Temperature, and Battery. 

Enter the desired lapse of time between samples sent by the mote in seconds. 

Minimum time is 0.1 seconds. 

Log Capture indicates the capture to memory settings: 

 Stop on Full: Recording will stop when memory is filled. 

 Continuous: Recording will continue from the beginning of the memory 

(overwriting as it does) once it reaches the end. 

CAUTION: Presently, Channels B and C are undefined. Do not select those 

channels. Selecting those channels will result in visually garbled data in the 

GUI 

NOTE: This setting currently sets the sample time for all channels 

simultaneously. 

NOTE: This function is also located in Set > Sampling…. 

 

Record 

To record all data sensed by the mote group you presently have set at the settings to which you have 

programmed that group until you command the group to stop. To program different motes to different 

settings, see Set Group. 

 Motes will continue recording until you send the command to stop using the Stop button (of File 

> Stop), until the battery runs out, or the data reaches the memory capacity (if you set Log Capture in 

the Sampling dialog box to “Stop on Full”), regardless of whether the computer and/or coordinator are 

connected or not. 

CAUTION: Recording overwrites all data saved to a mote. If you had any data on a mote prior to 

recording, be sure to download it to your computer first. 

NOTE: Ensure all the motes are programmed with the desired settings before recording. 

NOTE: If the battery runs out on a mote before a log is finished downloading, Scanimetrics can 

extract the data from the mote. 

NOTE: This function is also located along the bottom of the program window and in File > 

Record. 

See the note below to learn about recording different mote groups at different times. 

 

  

Figure 14: The Sample Setup dialog box 
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Live-On 

To have a real-time indication of the data being recorded. Click the Live-On button (along the bottom of 

the live window) to start the motes sending their data to the program. You must be recording to see any 

live data. Please see Record for more information. 

NOTE: If data is not being recorded, using the live feature will not show anything. You must be 

recording to see the data. 

NOTE: The result of pressing the Live button in the CUI and the Live button in the GUI appear 

vastly different. In the CUI, the resulting data is displayed in a constantly-updated list, similar to 

the list in the log file. 

NOTE: This function is also located along the bottom of the program window as “Live.” 

 

Live-Off 

To stop seeing the data in real time. 

NOTE: This does not stop the recording process. To stop the recording process, you must press 

the Stop button or use File > Stop. 

NOTE: Turning off the live data will not close the live window, but will only stop the data from 

being sent to the program. 

NOTE: This function is also located along the bottom of the program window as “Off.” 

 

Stop 

To stop the motes from recording. 

 Motes will continue recording until you send the command to stop using File > Stop (the Stop 

button) or until the battery runs out, regardless of whether the computer and/or coordinator are 

connected or not. 

NOTE: This function is also located along the bottom of the program window and in File > Stop. 

 

Get Logs 

To download the log files from the mote to your computer. MoteScan will download only one log file at 

a time. The files are in the .txt format named logfile_moteID#_date (ex.: logfile_M45_2010-03-22.txt) 

and saved to your program files directory (unless you set an alternate location using Set > Log directory). 

 The final line of a correctly downloaded file will read “ELog”. If you do not see that line, try 

downloading again. 

 If for any reason you need to stop the download process, press the Halt button along the 

bottom of the window.. 

NOTE: Stop recording before downloading the log files. The files will not download if you have 

not stopped recording. 

NOTE: You can download and re-download a log file as many times as you need to. However, 

once you record again, the data will be overwritten. For more information see Record. 

NOTE: This function is also located along the bottom of the program window and in File > Get 

Logs. 
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Halt 

To stop the downloading process (for any reason) from the motes to your PC. You can re-start the 

process at any time (until you record data onto the mote again). 

CAUTION: Recording overwrites the data saved on the mote. If you have halted a download, 

remember to restart it before recording again. 

NOTE: Do not confuse with Stop (stops the recording process) or Off (turns off the Live feature). 

NOTE: This function is also located along the bottom of the program window and in File > Halt. 

 

Logs to Data 

To convert all log files to a single .csv data file. Opens the specified directory that houses your log files. 

Select all log files you want to combine and click Open. This launches a process in the background to 

process the data. 

 

 
Figure 15: Note the last button has now changed to “processing…” 

 

 Once the button is pressed, it will change to read “processing ...” and you will only be able to 

convert the next set of until the program is finished processing. 

NOTE: If you want to process more than one set of logs at a time, you can start another version 

of the program. 

NOTE: This function is also located in Data > Convert Logs to Data. 

 

The converting process converts all selected log files into two separate data files: 

 raw: containing the original time stamps from the coordinator 

 fixed_step.csv: using linear interpolation on the data to convert the data samples to even 

intervals of time stamps. 

 

The files will be saved in the Data folder in your Program Files directory. 

NOTE: This operation may slow down your system while the process is running. 

NOTE: The data files will always be saved to the program files directory. The Set > Log directory 

will not change the location of the data files. 
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Important Setting Operations 

Sync Time 

To synchronize all hardware times, so all systems are running the same time. This operation will first 

synchronize the coordinator’s time with the computer’s time, followed by synchronizing the motes’ time 

with the coordinator’s time. 

CAUTION: It is very important to remember to sync time before recording for all data to align 

properly. Be sure to also sync time if any motes have been powered down or lost power. 

CAUTION: If you sync time after you start recording, post-processing of data will not function 

properly, since it relies on the first and last samples having the same time stamp. 

 

Set Group 

To give commands to multiple motes at once. The default mote group is all connected motes. To set a 

different the active mote group, check the boxes in the live window beside the motes you want grouped 

together. This change will take effect immediately once the box is checked. 

NOTE: You can send commands to several mote groups, but only the most recent group will be 

active. 

 

Keep in mind that any commands you send to the coordinator or a mote group will remain active until 

you send an opposing command, even if you leave the program or the mote’s operating range. For 

example, the commands you send to a group will continue to operate if you change the group. Likewise, 

the commands sent to one mote group will still operate when the mote group is modified. However, 

there is only ever 1 active group. Please see the note below. 

 

Note: Different Commands to Distinct Groups 

Say you want to set motes 70 and 43 to record at 0.1 seconds sample time and motes 65 and 81 to 

record at 0.2 seconds: 

 1. Set > Group to 70 43, then Set > Sample time to 0.1. 

 2. Set > Group to 65 81, then Set > Sample time to 0.2. 

 3. Set > Group to 70 43 65 81, then Record. 

 

Say you want to start recording motes 70 and 43 at 1:51 PM and motes 65 and 81 a few seconds later: 

 1. Set > Group to 70 43, then at 1:51 PM, File > Record. Motes 70 and 43 will continue recording 

even when you change the mote group. 

 2. Set > Group to 65 81, then File > Record. 

 3. Repeat these steps to Stop the recording (pressing the Stop button instead of the Record 

button) at different times. 

 4. To stop all motes at the same time, Set > Group to 70 43 65 81, then File > Stop. 

This will not affect post-processing (as would happen if the mote and computer times were not 

synchronized. Please see notes at Sync Time). 
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Pause/Re-sync 

 
Figure 16: The Pause/Re-sync button under the temperature graph in the live window 

 

To hold the graphs at the present time to allow you to inspect the incoming data, press the Pause/Re-

sync button below the temperature graph in the live window. Pressing the button again will return the 

graph to the present position in time. 

 

Buttons Along the Bottom of the Program Window. 

 
Figure 17: The buttons along the bottom of the program window 

Connect 

To connect your coordinator to your computer. The dialog box that is subsequently opened lists all 

active USB (COM) ports (ports connected to a USB device) on your computer. Choose the correct port to 

which your coordinator is connected. 

 Once successfully connected, the button will read “Disconnect.” 

NOTE: This button will read “Disconnected” if a coordinator is already connected. See next 

entry. 

NOTE: The program will return an error if you try to connect when you are already connected. 

NOTE: This function is also located window and in File > Connect. 

 

Disconnect 

To disconnect your coordinator. 

 Displays in the program window “disconnected” when successfully disconnected. 

NOTE: This function is also located in File > Disconnect. 

 

Send… 

To send a command to the active mote group. 

NOTE: This is not the same as typing a command onto the command line in the CUI. That 

command will be sent to the coordinator. 

NOTE: In the GUI, the command will be sent, but you will not receive visual confirmation. 

 

Record, Stop, Live, Off, Get Logs, Halt 

See Record, Stop, Live-On, Live-Off, Get Logs, and Halt along the bottom of the live window. 

 

Quit 

To quit the program. The red X in the corner of the program window has the same effect. 

NOTE: If recording, this function will not stop the recording process. To stop recording, press the 

Stop button along the bottom of the live window or use File > Stop. 
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Config File 
To change the mote names and configure the calculations for strain and temperature. 

The configuration file is called mote.cfg and is located in the Config folder in the Program Files 

directory. The values in the graphs of the live window are calculated based on this file. For any changes 

made to the config file to take effect in MoteScan, restart the program. 

 

The format of mote.cfg is:  moteId, area, variable, value 

 “area” can be one of “strain,” “temperature,” and “config.” 

 If configuration for a mote is not specified, moteId is 0. 

 

CAUTION: If programming motes at several sites, the config file MoteScan refers to will be the 

mote.cfg file on the computer used at the time. If multiple users configure the motes and collect 

the data, the changes made to the config file should be consolidated into a master mote.cfg file 

shared among those users for optimal results with MoteScan. 

NOTE: The software comes with a configuration example as well as a default mote.cfg file. The 

example is also located in the Config folder. 

 

Adding a Mote Name 
To add a name to the mote ID, open the mote.cfg file and scroll to the end of the section containing 

lines that start with 0’s. 

 Begin a new line and write the mote ID, “config”, “name”, and the desired name, all separated 

by “, .” (comma space). For example, inputting “18,config,name,Bob” would name mote 18 “Bob.” 

 The name will appear in the log file as well as in the live window. 

NOTE: A similar operation can be done by inputting a mote note (see Set > Mote Note). 

However, this note will not appear in the GUI live window, although it will appear in the log file. 

If you want to quickly set a note, use Set > Mote Note. 

 

Temperature and Strain Calculations 
Please refer to the Scanimetrics Calculations reference in Appendix B for more information on the 

temperature and strain calculations used in MoteScan. 
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Sample mote.cfg: 

 

 

 

 

Default strain calculation 

(Strain calculation used for all 

motes not specified below) 
 

Default temperature calculation 

(Temperature calculation used for 

all motes not specified below) 
 

Mote names 

 

 

 

 

 

 

 

 

 

 

 

 

 
Mote-specific strain calculations 

  

 

 

 

 

Figure 18: Example of mote.cfg configuration file. 
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Debugging 
Please see the instructions under the Command-Based User Interface (CUI) for more detailed 

information for debugging purposes. 

 

If you need to see the log history for the GUI, it is located in the program files in a file called log_year-

month-day.txt (ex.: log_2010-03-10.txt). 
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MoteScan Command-Based User Interface (CUI) 
For Mote Debugging 

 

Starting the Software and Connecting the Coordinator 
Please refer to the graphic-based user interface (GUI) for more information on connecting the 

coordinator. 

 

Once the program connects, it will show the ID of the coordinator to which you are connected. 

 

Menus 
 

 
Figure 19: The Set… menu 

 

File 

Connect 

Disconnect 

-------- 

Record 

Stop 

Get Logs 

Halt 

-------- 

Quit 

Edit 

Copy 

Paste 

Copy&Paste 

Set… 

Group… 

Log Directory… 

Sampling… 

Sync Time 

Mote Note… 

Mote Type… 

Repeat Command 

Show 

Connected Mote 

Mote Group 

All RSSI 

Group RSSI 

Sample Time 

Time 

Mote Note 

Mote Type 

Version 

Help 
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Basic Operation 
For more information on each operation, click the titles to see the sections in Advanced Operation. 

 Keep in mind that any commands you send will hold until you send a different command, even if 

you leave the program or the mote’s operating range. Please see Set Group for more information. 

 

1. Show > Connected Motes 

To list the motes in working distance (around 10 m) through the wireless ZigBee network (in order of 

answer time). This step is necessary to verify that all motes are connected as expected. 

 

2. Show > All RSSI 

To list the signal the coordinator receives from all connected motes. This step verifies that all connected 

motes are working as expected. RSSI is affected by distance and battery power. 

 

3. Set > Group 

To give commands to multiple motes at once. Enter into the dialog box the ID numbers of the motes you 

want in a group, separated only by a space (no commas, periods, or other separators). The motes you 

selected will now be the active mote group. 

CAUTION: Without a mote group set, the coordinator will not send any commands to any motes. 

Be sure to set a mote group before proceeding with any further commands. 

NOTE: You can send commands to several mote groups; only the most recent group will be active. 

 

4. Set > Sampling 

To set the sample time and channels to be sampled. See Sampling in the GUI for more information. 

CAUTION: Channels B and C are undefined. Do not select those channels. 

 

5. Set > Sync Time 

To synchronize the coordinator’s and motes’ times with your computer’s time, so all systems are 

running the same time. 

CAUTION: It is very important to remember to sync time before recording for all data to align 

properly. Be sure to also sync time if any motes have been powered down or lost power. 

CAUTION: If you sync time after you start recording, post-processing of data will not function 

properly, since it relies on the first and last samples having the same time stamp. 

 

6. Live button (along the bottom) 

To have a real-time indication of the data being recorded, click the Live button (along the bottom). 

NOTE: If data is not being recorded, using the live feature will not show anything. You must be 

recording to see the data. 

 

7. Off button (along the bottom) 

To stop seeing the data in real time, click the Off button along the bottom of the program window. 

NOTE: This does not stop the recording process. To stop the recording process, you must use 

File > Stop or press the Stop button. 
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Advanced Operation 

File Menu 
See GUI for more information on the Connect, Disconnect, Record, Stop, Get Logs, Halt, and Quit 

operations. 

 

Edit Menu 

Copy 

To copy the highlighted command on the coordinator prompt line. 

 

Paste 

To paste the copied command to a new prompt line. 

 

Copy&Paste 

To copy the highlighted command and paste immediately to a new prompt line. 

NOTE: If you have no command highlighted, you will receive an error prompting you to highlight 

a command. 

  

Set… Menu 

Group… 

To give commands to multiple motes at once. Set > Group opens a dialog box: enter the ID numbers of 

the motes you want in the group, separated only by a space (no commas, periods, or other separators). 

The motes you selected will now be the active mote group. See Set Group in the GUI for more 

information on setting groups. 

 If you ever need to clear the remote group (or to send a command solely to the coordinator), 

simply enter nothing into Set > Group and press OK. 

CAUTION: Without a mote group set, the coordinator will not send any commands to any motes. 

Be sure to set a mote group before proceeding with any further commands. 

NOTE: In the GUI, the program automatically sets the mote group to include all connected 

motes. 

 

Log Directory… 

To change the directory in which you store the log files downloaded from the motes. They are stored by 

default in the Logs folder in the Program Files directory. 

NOTE: This operation will not change the location of the post-processed .csv files the GUI 

creates with the Logs to Data button. Those files will continue to be saved to the Program Files 

directory regardless. 

 

Sampling 

See Set Sampling in the GUI for more information. 
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Sync Time 

To synchronize all hardware times, so all systems are running the same time. This operation will first 

synchronize the coordinator’s time with the computer’s time, followed by synchronizing the motes’ time 

with the coordinator’s time. 

CAUTION: It is very important to remember to sync time before recording for all data to align 

properly. Be sure to also sync time if any motes have been powered down or lost power. 

CAUTION: If you sync time after you start recording, post-processing of data will not function 

properly, since it relies on the first and last samples having the same time stamp. 

 

Mote Note… 

To add information about a certain mote to the log file, such as recording where the mote is located or 

what it is measuring (ex: truck A axle; truck B horizontal). The dialog box this function opens allows you 

to first indicate to which mote you are adding the note. 

NOTE: When you click the Add button in the dialog box, it will overwrite any previous Mote note 

you had stored. 

NOTE: Unless the note is of a temporary nature, we recommend using instead the configuration 

file to name a mote. 

 

Mote Type… 

Presently this operation has no function. 

 

Repeat Command 

To repeat certain commands at certain time intervals. The dialog box that opens allows you to choose 

which operation to repeat and how often. Following is a representation of the dialog box (see image 

below): 

 

 

 

 

 

 

 

 

 

 

 

 

 

“Send commands to:” will repeatedly send to the mote and coordinator the command you enter. 

 Repeat command will continue to repeat whichever command you asked it to repeat until you 

bring up the the dialog box again and press Stop. 

Figure 20: the Repeated Operation dialog box 
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Show Menu 
Please note that the functions in the Show menu will have no effect in the GUI. 

 

Connected Mote 

Lists the motes in working distance (around 10 m) through the wireless ZigBee network. Showing 

connected motes allows you to verify that the motes you have set up are sending their signals. The list 

will be ordered only by which mote answered first. 

NOTE: MoteScan can presently connect up to 9 motes. 

 

Mote Group 

Displays a list of all the motes in the present mote group. 

NOTE: In the CUI, the active mote group is also displayed in the black bar right below the menu 

bar. See Status Bar for more details. 

 

All RSSI 

Displays a list of the signals the coordinator receives from all connected motes. Showing all RSSI allows 

you to verify that all motes are sending workable signals. 

 RSSI stands for Received Signal Strength Indicator and is the power present in the radio signal 

received by the coordinator. RSSI is affected by distance and battery power. The smaller the RSSI 

number, the farther away or lower the battery power of the mote. 

 Also displays the LQI to the right of the RSSI. LQI (Link quality indicator) is how much data is 

transmitted. The highest possible LQI is 255. 

NOTE: This step is only necessary in the CUI. The GUI automatically checks and displays the 

signals of the connected motes. 

 

Group RSSI 

Displays the signal the coordinator receives from all connected motes in the mote group. 

 RSSI is affected by distance and battery power. 

NOTE: See the explanation of RSSI and LQI above. 

 

Sample time 

Displays the sample time set for the group. See Sampling for information on setting the sample time. 

 

Time 

Displays the time held by each mote in the following format: day,hour:minute:second.millisecond (ex.: 

69,15:56:15.1 is March 10 2010, 3:56 PM and 15.1 seconds) 

 The first line displays the computer’s time, followed by the coordinator’s time. Subsequent lines 

display the computer’s time followed by the motes’ times. If the times are not within .1 seconds of each 

other, synchronize the time. 
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Mote note 

Displays the mote note you entered in the Set > Mote Note command. 

 

Mote type 

Presently this operation has no function. 

 

Version 

Displays the version of software each mote in the group and coordinator is running. 

CAUTION: If all motes and coordinators are not running the same version, we cannot guarantee 

the software’s functioning. 

 

Status Bar 
The status bar is the black bar right below the menu bar in the program window. It contains the active 

mote group and whether that mote group is recording. 

NOTE: If you quit the program, leave the mote range, or unplug the coordinator, when you 

return, the status bar resets and will not display whether or not the motes are recording. 

NOTE: In the GUI, the status bar contains only the previous command you entered (ex: if you 

just pressed Record, it will read “Mote status: Recording”) 

 

Common Commands 
Text-based commands sent to the coordinator can be entered directly into the program window and 

text-based commands sent to the motes can be entered via the Send function. Entering commands in 

this manner is for debug purposes only. For your reference, here are a few common commands: 

 

To the coordinator 

 lrs: performs the Show > All RSSI 

 list: performs the Show > Mote Group 

 words: lists all text-based commands the coordinator recognizes 

 

To the mote: 

 blt: starts the active mote group recording 

 elt: instructs the active mote group to stop recording 

 rb: reboots the motes in the active mote group 

 

Common Errors 
Beep! 

 This error will be returned if you backspace too far in the command line. Simply retype your 

command. 

eh? 

 This error is returned when the command you enter is unknown to the program. 
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Appendix A: Cautions and Notes 
 

Re: General Use 

Re: Getting Started 

Re: Sync Time 

Re: Mote Groups 

Re: Signal 

Re: Sampling 

Re: Recording 

Re: Live 

Re: Downloading Log Files and Converting to Data 

RE: Stop, Halt, Off, and Quit 

Re: Config File and Mote Notes 

Re: Commands 

Re: Copying and Pasting 

Re: Status 

 

Re: General Use 

CAUTION: The system is subject to timing and radio handshaking limits. It is a multi-node radio 

packet network which is subject to impairments of communications. The system is such that it 

occasionally does require retries. 

CAUTION: All motes and coordinators need to be the same version to ensure the correct 

operation of the system 

NOTE: MoteScan can presently connect up to 9 motes. 

 

Re: Getting Started 

NOTE: The program will return an error if you try to connect when you are already connected. 

 

Re: Sync Time 

CAUTION: It is very important to remember to sync time before recording for all data to align 

properly. Be sure to also sync time if any motes have been powered down or lost power. 

CAUTION: If you sync time after you start recording, post-processing of data will not function 

properly, since it relies on the first and last samples having the same time stamp. 

 

Re: Mote Groups 

CAUTION: Without a mote group set, the coordinator will not send any commands to any 

motes. Be sure to set a mote group before proceeding with any further commands. 

NOTE: You can send commands to several mote groups, but only the most recent group will be active. 

NOTE: In the GUI, the program automatically sets the mote group to include all connected motes. 

NOTE: In the CUI, the active mote group is also displayed in the black bar right below the menu bar. 

 

Re: Signal 

NOTE: Showing all RSSI is only necessary in the CUI. The GUI automatically checks and displays the 

signals of the connected motes. 
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Re: Sampling 

CAUTION: Presently, Channels B and C are undefined. Do not select those channels. Selecting 

those channels will result in visually garbled data in the GUI 

NOTE: This setting currently sets the sample time for all channels simultaneously. 

 

Re: Recording 

CAUTION: Recording overwrites all data saved to a mote. If you had any data on a mote prior to 

recording, be sure to download it to your computer first. If you have halted a download, 

remember to restart it before recording again. 

CAUTION: When the battery strength indicator is red, the mote system voltage has drop below 

the specified voltage for writing the on-board flash memory. We recommend replacing the mote 

when the indicator drops into the yellow region. 

NOTE: The mote can be recording in any state (i.e.: Live, Active, Recording) except when downloading. 

NOTE: Ensure all the motes are programmed with the desired settings before recording. 

 

Re: Live 

NOTE: If data is not being recorded, using the live feature will not show anything. You must be recording 

to see the data. 

NOTE: The result of pressing the Live button in the CUI and the Live button in the GUI appear vastly 

different. In the CUI, the resulting data is displayed in a constantly-updated list, similar to the list in the 

log file. In the GUI, Live will display the incoming data as graphs. 

NOTE: In the GUI, turning off the live data will not close the live window, but will only stop the data from 

being sent to the program. 

NOTE: Graph > Show does not start up the live feature. This is not the same as pressing the Live button 

along the bottom of the program window. 

NOTE: You can press the Live button even if the live window is not open. The motes will send their data, 

but you will not be able to see it. 

 

Re: Downloading Log Files and Converting to Data 

NOTE: Stop recording before downloading the log files. The files will not download if you have not 

stopped recording. 

NOTE: If the battery runs out on a mote before a log is finished downloading, Scanimetrics can extract 

the data from the mote. 

NOTE: You can download and re-download a log file as many times as you need to. However, once you 

record again, the data will be overwritten. 

NOTE: Set > Log Directory will not change the location of the post-processed .csv files the GUI creates 

with the Logs to Data button. Those files will continue to be saved to the Program Files directory 

regardless. 

NOTE: Converting log files to data files may slow down your system while the process is running. 

NOTE: If you want to process more than one set of logs at a time, you can start another version of the 

program.  
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RE: Stop, Halt, Off, and Quit 

NOTE: Stop stops the recording process; Off turns off the Live feature, Halt stops the downloading 

process, and Quit quits the program. 

NOTE: If recording Off, Halt, or Quit will not stop the recording process. To stop recording, use the Stop 

button along the bottom of the live and program windows or File > Stop. 

 

Re: Config File and Mote Notes 

CAUTION: If programming motes at several sites, the config file MoteScan refers to will be the 

mote.cfg file on the computer used at the time. If multiple users configure the motes and collect 

the data, the changes made to the config file should be consolidated into a master mote.cfg file 

shared among those users for optimal results with MoteScan. 

NOTE: The software comes with a configuration example as well as a default mote.cfg file. The example 

is also located in the Config folder. 

NOTE: Unless the note is of a temporary nature, we recommend using instead the configuration file to 

name a mote. A mote note will not appear in the GUI live window, although it will appear in the log file. 

NOTE: When you click the Add button in the Mote Note dialog box, the new note will overwrite any 

previous note you had stored. 

 

Re: Sending Commands 

NOTE: Typing a command onto the command line will be sent to the coordinator. Typing a command 

into the Send button dialog box will send the command directly to the active mote group. 

NOTE: In the GUI, a command typed into the Send button dialog box will be sent, but you will not 

receive visual confirmation. 

 

Re: Copying and Pasting 

NOTE: If you have no command highlighted when you use the File > Copy or File > Copy&Paste feature, 

you will receive an error prompting you to highlight a command. 

 

Re: Status Bar 

NOTE: In the GUI, the status bar contains only the previous command you entered (ex: if you just 

pressed Record, it will read “Mote status: Recording”). 

NOTE: If you quit the program, leave the mote range, or unplug the coordinator, when you return, the 

status bar resets and will not display whether or not the motes are recording. 
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Appendix B: Strain and Temperature Calculations 
 

Strain Calculation 

data = gain_multiplier * ((sample_scaling * raw_data) - abs_offset) + rel_offset 

 

Temperature Calculation 

data = gain_multiplier * (raw_data - abs_offset) + rel_offset 

 

Abbreviations 

abs_offset: Absolute Offset 

rel_offset: Relative Offset 

gain_multiplier: Gain Multiplier 

sample_scaling: Sample Scaling 

 




