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5.2 BLE Module Board

5.2.1 PSoC 4 BLE or PRoC BLE

The PRoC BLE or PSoC 4 BLE is the main component on the BLE Module. It provides the RF
interface and analog and digital capability. The PRoC BLE or PSoC 4 BLE pins are mapped to the
Bluetooth module headers (see Figure 5-20). For more information, refer to the BLE web page.

Figure 5-20.  Schematics and Board Highlight of Bluetooth Module Headers for BLE Pins 
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5.2.2 Bluetooth Module Headers (20-Pin and 24-Pin Headers)

The PSoC 4 BLE and PRoC BLE Modules connect to the Pioneer board using the two (20-pin and
24-pin) Bluetooth module headers (Figure 5-21). All GPIOs and power domains are brought out to
these headers. These headers are the counterparts of the connectors in section 5.1.4.

Figure 5-21.  Schematics and Board Highlight of Headers
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5.2.3 Wiggle Antenna

Both the modules use the wiggle antenna. Refer to the Antenna Design Guide (AN91445) for details.

Figure 5-22.  Board Highlight of Wiggle Antenna

http://www.cypress.com/go/AN91445
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5.2.4 Antenna Matching Network

An Antenna Matching Network is required between the BLE device and the antenna to achieve opti-
mum performance (Figure 5-23). The matching network has four main tasks:

■ Transform the balanced output of the radio to an unbalanced connection to the antenna (balun). 

■ Transform the output impedance of the radio to a 50-ohm antenna. 

■ Suppress harmonics to a level below the regulations level in TX mode. 

■ Suppress the local oscillator (LO) leakage in RX mode.

Figure 5-23.  Schematics and Board Highlight of Antenna Matching Network and Antenna
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5.2.5 BLE Passives

Module boards include a 24-MHz crystal and a 32-kHz crystal, the CMOD and shield (CTANK) circuit
for CapSense, a SAR bypass capacitor, and adequate decoupling capacitors for all the power
domains, as shown in Figure 5-24.

Figure 5-24.  Schematics and Board Highlight of External Crystal, CMOD, CTANK, Decaps, Jumpers 
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5.2.6 Test Points

All power domains are brought out as test points for easy probing. 

5.3 BLE Dongle Board

See PSoC 4 BLE or PRoC BLE on page 106.

See Wiggle Antenna on page 108.

See Antenna Matching Network on page 109.

See Pioneer Board LEDs on page 101.

See Push Buttons on page 102.

Figure 5-25.  Board Highlight 
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5.3.1 Power System

The board is powered directly using 5 V from the USB port, as shown in Figure 5-26.

Figure 5-26.  Power Supply Block Diagram With Protection Circuits
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5.3.2 USB Type A Plug

The PSoC 5LP connects to the USB port of a PC through a USB type A plug (Figure 5-27). This plug
can also be used to power the board. A resettable polyfuse is used to protect the computer's USB
ports from shorts and overcurrent. If more than 500 mA is applied to the USB port, the fuse will auto-
matically break the connection until the short or overload is removed. The VBUS, D+, and D– lines
from the USB connector are also protected against ESD events using TVS diodes.

Figure 5-27.  Schematics and Board Highlight of USB Type A Plug
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5.3.3 User LED

A user LED is provided to indicate status from the PRoC BLE device (Figure 5-28). It is also used to
show the bind status.

Figure 5-28.  Schematics and Board Highlight of User LED
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6. Advanced Topics

This chapter describes advanced features of the BLE Pioneer kit as well as the corresponding
projects. It can be used as reference to exploit these features for other applications, according to
project requirements.

6.1 Using PSoC 5LP as USB-UART Bridge

The PSoC 5LP serves as a USB-UART bridge, which can communicate with the COM terminal
software. This section explains how to create a PSoC 4 BLE code example to communicate with the
COM terminal software.

Users who have a Windows operating system that does not have HyperTerminal can use an
alternative terminal software such as PuTTY.

1. Create a new PSoC 4 BLE project in PSoC Creator, as shown in Figure 6-1. Select an
appropriate location for your project and rename the project as required.

Figure 6-1.  Create New Project in PSoC Creator 

http://www.putty.org/
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2. Drag and drop a UART (SCB) component (Figure 6-2) to the TopDesign. 

Figure 6-2.  UART Component in Component Catalog 

3. To configure the UART, double-click or right-click the UART component and select Configure, as
shown in Figure 6-3.

Figure 6-3.  Open UART Configuration Window
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4. Change the instance name to UART. Configure the UART as shown in Figure 6-4, Figure 6-5,
and Figure 6-6. Click OK.

Figure 6-4.  UART Configuration Tab Window

Figure 6-5.  UART Basic Tab Window 
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Figure 6-6.  UART Advanced Tab Window 

5. Select P1[4] for UART RX and P1[5] for UART TX in the Pins tab of <Project_Name>.cydwr, as
shown in Figure 6-7. 

Figure 6-7.  Pin Selection 



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 119

Advanced Topics

6. Place the following code in your main.c project file. The code will echo any UART data received. 

int main()
{   
    uint8 ch;

    /* Start SCB UART TX+RX operation */    
    UART_Start(); 
    
/* Transmit String through UART TX Line */
UART_UartPutString("CY8CKIT-042-BLE USB-UART");

    for(;;)
    {
        /* Get received character or zero if nothing has been received yet 
*/
        ch = UART_UartGetChar(); 

        if(0u != ch)
        {
 /* Send the data through UART. This function is blocking and waits until 
there is an entry into the TX FIFO. */
            UART_UartPutChar(ch);
        }
    }
}
7. Build the project by clicking Build > Build {Project Name} or [Shift][F6]. After the project is built

without errors and warnings, program (by choosing Debug > Program) the project to PSoC 4
BLE/PRoC BLE through the PSoC 5LP USB programmer or MiniProg3.

Note: UART RX and UART TX can be routed to any digital pin on PSoC 4 BLE/PRoC BLE based
on the configuration of the UART component. An SCB implementation of UART will route the RX
and TX pins to one of the following subsets: (P0[0], P0[1] or P0[4], P0[5] or P1[4], P1[5] or P3[0],
P3[1] or P3[4], P3[5] or P5[0], P5[1]).
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To communicate with the PSoC 4 from the terminal software, follow this procedure:

1. Connect USB mini-B to J13. The kit enumerates as a KitProg USB-UART and is available in the
Device Manager, Ports (COM & LPT). A communication port is assigned to the 
KitProg USB-UART, as shown in Figure 6-8.

Figure 6-8.  KitProg USB-UART in Device Manager 
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2. Open HyperTerminal and choose File > New Connection and enter a name for the new
connection and click OK, as shown in Figure 6-9. For PuTTY, double-click the PuTTY icon and
select Serial under Connection.

Figure 6-9.  Open New Connection

HyperTerminal

PuTTY
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3. A new window opens, where the communication port can be selected.

In HyperTerminal, select COMx (or the specific communication port that is assigned to the Kit-
Prog USB-UART) in Connect using and click OK, as shown in Figure 6-10. In PuTTY enter the
COMx in Serial line to connect to. This code example uses COM12.

Figure 6-10.  Select Communication Port 
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PuTTY



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 123

Advanced Topics

4. In HyperTerminal, select Bits per second, Data bits, Parity, Stop bits, and Flow control under
Port Settings and click OK, as shown in Figure 6-11. Make sure that the settings are identical to
the UART settings configured for the BLE device.

In PuTTY select Speed (baud), Data bits, Stop bits, Parity and Flow control under Configure
the serial line. Click Session and select Serial under Connection type. Serial line shows the
communication port (COM12) and Speed shows the baud rate selected. Click Open to start the
communication.

Figure 6-11.  Configure the Communication Port

HyperTerminal

PuTTY



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 124

Advanced Topics

5. Enable Echo typed characters locally in File > Properties > Settings > ASCII Setup, to
display the typed characters on HyperTerminal, as shown in Figure 6-12. In PuTTY, select Force
on in Terminal > Line discipline options to display the typed characters on PuTTY, as shown in
Figure 6-13.

Figure 6-12.  Enable Echo of Typed Characters in HyperTerminal

Figure 6-13.  Enabling Echo of Typed Characters in PuTTY
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6. The COM terminal software displays both the typed data and the echoed data from the PSoC 4
BLE or PRoC BLE UART, as shown in Figure 6-14 and Figure 6-15.

Figure 6-14.  Data Displayed on HyperTerminal 

Figure 6-15.  Data Displayed on PuTTY 
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6.2 Using PSoC 5LP as USB-I2C Bridge

The PSoC 5LP serves as a USB-I2C bridge that can be used to communicate with the USB-I2C
software running on the PC. The following steps describe how to use the USB-I2C bridge, which can
communicate between the BCP and the PSoC 4 BLE/PRoC BLE.

1. Create a new project targeting the PSoC 4 BLE/PRoC BLE device in PSoC Creator, as shown in
Figure 6-16.

Figure 6-16.  Create New Project in PSoC Creator 



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 127

Advanced Topics

2. Drag and drop an I2C component (Figure 6-17) to the TopDesign.

Figure 6-17.  I2C Component in Component Catalog

3. To configure the I2C component, double-click or right-click the I2C component and select Config-
ure, as shown in Figure 6-18.

Figure 6-18.  Open I2C Configuration Window
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4. Change the instance name to I2C. Configure the I2C component according to the settings in
Figure 6-19 and Figure 6-20 and click OK.

Figure 6-19.  Configuration Tab

Figure 6-20.  I2C Basic and Advanced Tabs
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5. Select pin P3[5] for the I2C SCL and pin P3[4] for the I2C SDA in the Pins tab of
<Project_Name>.cydwr, as shown in Figure 6-21.

Figure 6-21.  Pin Selection_USBI2C 

6. Place the following code in your main.c project file. The code will enable the PSoC 4 BLE/PRoC

BLE device to transmit and receive I2C data to and from the BCP application.

int main()
{

uint8 wrBuf[10];  /* I2C write buffer */

uint8 rdBuf[10];  /* I2C read buffer */
uint8 indexCntr;
uint32 byteCnt;

/* Enable the Global Interrupt */
CyGlobalIntEnable;

/* Start I2C Slave operation */
I2C_Start();

/* Initialize write buffer */
I2C_I2CSlaveInitWriteBuf((uint8 *) wrBuf, 10);

/* Initialize read buffer */
I2C_I2CSlaveInitReadBuf((uint8 *) rdBuf, 10);

for(;;) /* Loop forever */
{

/* Wait for I2C master to complete a write */
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if(0u != (I2C_I2CSlaveStatus() & I2C_I2C_SSTAT_WR_CMPLT))
{

/* Read the number of bytes transferred */
byteCnt = I2C_I2CSlaveGetWriteBufSize();

/* Clear the write status bits*/
I2C_I2CSlaveClearWriteStatus();

/* Move the data written by the master to the read buffer so that the 
master can read back the data */
for(indexCntr = 0; indexCntr < byteCnt; indexCntr++)
{

rdBuf [indexCntr] = wrBuf[indexCntr]; /* Loop back the data to the read 
buffer */

}

/* Clear the write buffer pointer so that the next write operation will 
start from index 0 */
I2C_I2CSlaveClearWriteBuf();

/* Clear the read buffer pointer so that the next read operations starts 
from index 0 */
I2C_I2CSlaveClearReadBuf();

}
/* If the master has read the data , reset the read buffer pointer to 0 
and clear the read status */
if(0u != (I2C_I2CSlaveStatus() & I2C_I2C_SSTAT_RD_CMPLT))
{
/* Clear the read buffer pointer so that the next read operations starts 
from index 0 */

I2C_I2CSlaveClearReadBuf();

/* Clear the read status bits */
I2C_I2CSlaveClearReadStatus();

}
}

}

7. Build the project by choosing Build > Build Project or [Shift] [F6]. After the project is built
without errors and warnings, program ([Ctrl] [F5]) this code onto the PSoC 4 BLE/PRoC BLE
through the PSoC 5LP programmer or MiniProg3.

8. Open the BCP from Start > All Programs > Cypress > Bridge Control Panel <version
number>.

9. Connect to KitProg/ under Connected I2C/SPI/RX8 Ports, as shown in Figure 6-22.
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Figure 6-22.  Connecting to KitProg/ in BCP
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10.Open Protocol Configuration from the Tools menu and select the appropriate I2C Speed, as
shown in Figure 6-23. Make sure the I2C speed is the same as the one configured in the I2C
component. Click OK to close the window.

Figure 6-23.  Opening Protocol Configuration Window in BCP

11.From the BCP, transfer five bytes of data to the I2C device with slave address 0x08. Type the
command shown in Figure 6-24 and press [Enter] or click the Send button in the BCP. The log
shows whether the transaction was successful. A '+' indication after each byte indicates that the
transaction was successful and a '–' indicates that the transaction was a failure.

Figure 6-24.  Entering Commands in BCP 
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12.From the BCP, read five bytes of data from the I2C slave device with slave address 0x08. The log
shows whether the transaction was successful, as shown in Figure 6-25.

Figure 6-25.  Read Data Bytes from BCP

Note: Refer to Help Contents under Help in BCP or press [F1] for details of I2C commands.
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6.3 Developing Applications for PSoC 5LP

The BLE Pioneer kit has an onboard PSoC 5LP whose primary function is that of a programmer and
a bridge. You can build either a normal project or a bootloadable project using the PSoC 5LP.

The PSoC 5LP connections in the Pioneer board are summarized in Figure 6-26. J8 is the I/O
connector. The USB (J13) is connected and used as the PC interface. However, you can still use this
USB connection to create customized USB designs. 

Figure 6-26.  PSoC 5LP Connections on BLE Pioneer Kit

The programming header (J7) is meant for standalone programming. This header needs to be
populated. See the 'No Load Components' section in Bill of Materials (BOM) on page 184.

6.3.1 Building a Bootloadable Project for PSoC 5LP

All bootloadable applications developed for the PSoC 5LP should be based on the bootloader hex
file, which is programmed onto the kit.

The hex files are included in the following kit installer directory: 
<Install_Directory>\CY8CKIT-042-BLE Kit\<version>\Firmware\Programmer\ 
KitProg_Bootloader

Figure 6-27.  KitProg Bootloader Hex File Location
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To build a bootloadable application for the PSoC 5LP, follow this procedure:

1. In PSoC Creator, choose New > Project > PSoC 5LP, click the expand button adjacent to
Advanced, select Launch Device Selector to bring up the Select Device Window and select
the Device as CY8C5868LTI-LP039, as shown in Figure 6-28. Select the Application Type as
Bootloadable from the drop-down list and click OK.

Figure 6-28.  Create New Project in PSoC Creator_PSoC 5LP 
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Figure 6-29.  Select Device in PSoC Creator 

2. Navigate to the Schematic view and drag and drop a Bootloadable component (Figure 6-30) on
the TopDesign.

Figure 6-30.  Bootloadable Component in Component Catalog 
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To configure the Bootloadable, double-click or right-click the Bootloadable component and select
Configure. In the General tab, enable the check box for Manual application image placement and
set the Placement address to ‘0x00002800’.

Figure 6-31.  Configuration Window of Bootloadable Component in “General” Tab Setting 

Set the dependency of the Bootloadable component by selecting the Dependencies tab in the
configuration window and clicking the Browse button, as shown in Figure 6-32. Select the
KitProg_Bootloader.hex (Figure 6-33) and KitProg_Bootloader.elf files (Figure 6-34); click Open.

Figure 6-32.  Configuration Window of Bootloadable Component in the Dependencies Tab 
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Figure 6-33.  Select KitProg Bootloader Hex File 

Figure 6-34.  Select KitProg Bootloader Elf File

3. Develop your custom project. 
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4. Make sure that the NVL setting of the Bootloadable project and the KitProg_Bootloader project is
the same. Figure 6-35 shows the KitProg_Bootloader.cydwr system settings. 

Figure 6-35.  KitProg Bootloader System Settings 

5. Build the project in PSoC Creator by choosing Build > Build Project or [Shift] [F6].

6. To download the project onto the PSoC 5LP device, open the Bootloader Host tool, which is
available in PSoC Creator. Choose Tools > Bootloader Host, as shown in Figure 6-36.

Figure 6-36.  Open Bootloader Host Tool in PSoC Creator 
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7. In the Bootloader Host tool, click Filters and add a filter to identify the USB device. Ensure that
the check box for Show USB Devices is enabled. Set VID as 0x04B4, PID as 0xF13B, and click
OK, as shown in Figure 6-37.

Figure 6-37.  Port Filters Tab in Bootloader Host Tool 



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 141

Advanced Topics

8. In the Bootloader Host tool, click the Open File button (Figure 6-38) to browse to the location of
the bootloadable file (*.cyacd), as shown in Figure 6-38.

Figure 6-38.  Open Bootloadable File in Bootloader Host Tool 

Figure 6-39.  Select Bootloadable .cyacd File in Bootloader Host

9. Keep the reset switch (SW1) pressed and plug in the USB mini-B connector. If the switch is
pressed for more than 100 ms, the PSoC 5LP enters into bootloader. Click the Program button
(Figure 6-38) in the Bootloader Host tool to program the device. 
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10.If bootload is successful, the log of the tool displays “Programming Finished Successfully”;
otherwise, it displays “Failed” and a reason for the failure.

Notes:

■ The PSoC 5LP pins are brought to the PSoC 5LP GPIO header (J8). These pins are selected to
support high-performance analog and digital projects. See PSoC 5LP GPIO Header (J8) on
page 97 for pin information.

■ Take care when allocating the PSoC 5LP pins for custom applications. For example, P2[0]–P2[4]
are dedicated for programming the PSoC 4 BLE/PRoC BLE. See Schematics on page 168
before allocating the pins.

■ When a custom project is programmed onto the PSoC 5LP, the initial capability of the PSoC 5LP
to act as a programmer, USB-UART bridge, or USB-I2C bridge in not available.

■ The status LED does not function unless used by the custom project.

For additional information on bootloaders, refer to Cypress application note, AN73503 - USB HID
Bootloader for PSoC 3 and PSoC 5LP.

http://www.cypress.com/?rID=57561
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6.3.2 Building a Normal Project for PSoC 5LP

A normal project is a completely new project created for the PSoC 5LP device on the CY8CKIT-042.
Here the entire flash of the PSoC 5LP is programmed, overwriting all bootloader and programming
code. To recover the programmer, reprogram the PSoC 5LP device with the factory-set KitProg.hex
file, which is shipped with the kit installer.

The KitProg.hex file is available at the following location: 
<Install_Directory>\CY8CKIT-042-BLE Kit\<version>\Firmware\
Programmer\KitProg

This advanced functionality requires a MiniProg3 programmer, which is not included with this kit. The
MiniProg3 can be purchased from www.cypress.com/go/CY8CKIT-002.

To build a normal project for the PSoC 5LP, follow these steps:

1. In PSoC Creator, choose New > Project > PSoC 5LP, click the expand button adjacent to
Advanced, select Device as CY8C5868LTI-LP039, and select Application Type as Normal
from the drop-down list, as shown in Figure 6-40.

Figure 6-40.  Create New Project in PSoC Creator_PSoC 5LP 

2. Develop your custom project.

3. Build the project in PSoC Creator by choosing Build > Build Project or pressing [Shift] [F6].

www.cypress.com/go/CY8CKit-002
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4. Connect the 10-pin connector of MiniProg3 to the onboard 10-pin SWD debug and programming
header J7 (which needs to be populated).

5. To program the PSoC 5LP with PSoC Creator, choose Debug > Program or press [Ctrl] [F5]. If
the Programming window appears and shows MiniProg3 and the selected device in the project
under it (CY8C5868LTI-LP039); click on the device and click Connect to program.

Notes:

■ The 10-pin SWD debug and programming header (J7) is not populated. See the 'No Load
Components' section of A.3 Bill of Materials (BOM) for details.

■ The PSoC 5LP pins are brought to the PSoC 5LP GPIO header (J8). These pins are selected to
support high-performance analog and digital projects. See PSoC 5LP GPIO Header (J8) on
page 97 for pin information.

■ Take care when allocating the PSoC 5LP pins for custom applications. For example, P2[0]–P2[4]
are dedicated for programming the PSoC 4. Refer to A.1 Schematics before allocating the pins.

■ When a normal project is programmed onto the PSoC 5LP, the initial capability of the PSoC 5LP
to act as a programmer, USB-UART bridge, or USB-I2C bridge is not available.

■ The status LED does not function unless it is used by the custom project.

6.4 PSoC 5LP Factory Program Restore Instructions

The BLE Pioneer Kit features a PSoC 5LP device that comes factory-programmed as the onboard
programmer and debugger for the PSoC 4 BLE/PRoC BLE device.

In addition to creating applications for the BLE device, you can also create custom applications for
the PSoC 5LP device on this kit. For details, see section Developing Applications for PSoC 5LP on
page 134. Reprogramming or bootloading the PSoC 5LP device with a new flash image will
overwrite the factory program and forfeit the ability to use the PSoC 5LP device as a programmer/
debugger for the BLE device. Follow the instructions to restore the factory program on the PSoC
5LP and enable the programmer/debugger functionality.

6.4.1 PSoC 5LP is Programmed with a Bootloadable Application

If the PSoC 5LP is programmed with a bootloadable application, restore the factory program by
using one of the following two methods.

6.4.1.1 Restore PSoC 5LP Factory Program Using PSoC Programmer

1. Launch PSoC Programmer 3.21.1 or later from Start > Cypress > PSoC Programmer.

2. Configure the BLE Pioneer Kit in service mode. To do this, while holding down the reset button
(SW1 Reset), plug in the BLE Pioneer Kit to the computer using the included USB cable (USB A
to mini-B). This puts the PSoC 5LP into service mode, which is indicated by the blinking green
status LED.
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3. The following message appears in the PSoC Programmer Results window, as shown in
Figure 6-41: “KitProg Bootloader device is detected”.

Figure 6-41.  PSoC Programmer Results Window
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4. Switch to the Utilities tab in PSoC Programmer and press the Upgrade Firmware button, as
shown in Figure 6-42. Unplug all other PSoC programmers (such as MiniProg3 and DVKProg)
from the PC before pressing the Upgrade Firmware button.

Figure 6-42.  Upgrade Firmware
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5. After programming has completed, the following message appears, as shown in Figure 6-43:
“Firmware Update Finished at <time>”. 

Figure 6-43.  Firmware Update Completed

6. The factory program is now successfully restored on the PSoC 5LP. It can be used as the
programmer/debugger for the PSoC 4 BLE or PRoC BLE device.
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6.4.1.2 Restore PSoC 5LP Factory Program Using Bootloader Host Tool

1. Launch the Bootloader Host tool from Start > Cypress > PSoC Creator.

2. Using the File > Open menu, load the KitProg.cyacd file, which is installed with the kit software,
as shown in Figure 6-44. The default location for this file is: <Install_Directory>\
CY8CKIT-042-BLE Kit\<version>\Firmware\Programmer\KitProg\KitProg.cyacd

Figure 6-44.  Load KitProg.cyacd File
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3. Configure the Pioneer Kit in service mode. To do this, while holding down the reset button (SW1
Reset), plug in the BLE Pioneer Kit to the computer using the included USB cable (USB A to
mini-B). This puts the PSoC 5LP into service mode, which is indicated by the blinking green
status LED.

4. In the Bootloader Host tool, set the filters for the USB devices with VID: 04B4 and PID: F13B.
The USB Human Interface Device port appears in the Ports list. Click that port to select it, as
shown in Figure 6-45.

Figure 6-45.  Select USB Human Interface Device

5. Click the Program button (or choose Actions > Program) to restore the factory-program by
bootloading it onto the PSoC 5LP.
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6. After programming has completed, the following message appears, as shown in Figure 6-46:
“Programming Finished Successfully”.

Figure 6-46.  Programming Finished Successfully

7. The factory program is now successfully restored on the PSoC 5LP. It can be used as the
programmer/debugger for the PSoC 4 BLE/PRoC BLE device.

6.5 Using FM24V10 F-RAM

The BLE Pioneer board has an onboard ferroelectric RAM chip that can hold up to 1 Mb of data. The
chip provides an I2C communication interface for data access. It is hardwired to the I2C lines (P3_4
and P3_5); the same lines are also routed to the PSoC 5LP I2C lines. Because the F-RAM device is
an I2C slave, it can be accessed or shared among various I2C masters on the same line. For more
details on the F-RAM device, refer to the device datasheet.

http://www.cypress.com/?rID=73495
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6.5.1 Address Selection

The slave address of the F-RAM device consists of three parts, as shown in Figure 6-47: slave ID,
device select, and page select. Slave ID is an F-RAM family-specific ID located in the datasheet of
the particular F-RAM device. For the device used in BLE Pioneer board (FM24V10), the slave ID is
1010b. Device select bits are set using the two physical pins A2 and A1 in the device. The setting of
these two pins on the BLE Pioneer board is controlled by resistors R32/R36 (A1) and R33/R37 (A2).
Because the memory location in F-RAM is divided into two pages of 64 KB each, the page select bit
is used to refer to one of the two pages in which the read or write operations will take place.

Figure 6-47.  F-RAM I2C Address Byte Structure

6.5.2 Write/Read Operation

The device's datasheet includes details on how to perform a write/read operation with the F-RAM.
Figure 6-48 and Figure 6-49 provide a snapshot of the write/read packet structure as a quick
reference.

Figure 6-48.  F-RAM Single-Byte and Multiple-Byte Write Packet Structure
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Figure 6-49.  F-RAM Single-Byte and Multiple-Byte Read Packet Structure

As shown in the figures, all operations start with the slave address followed by the memory address.
For write operations, the bus master sends each byte of data to the memory, and the memory
generates an acknowledgement condition. For read operations, after receiving the complete slave
address and memory address, the memory begins shifting data from the current address on the next
clock. 

6.6 CySmart iOS/Android Application

The CySmart mobile application is a powerful tool that allows the mobile device (iOS/Android) with
BLE capability to connect to a BLE peripheral device and communicate with it. It supports various
standard BLE services along with two custom services for CapSense and LED control. It also
provides a common support for all profiles, standard or custom.

This app is free. You can download and install it for Apple iOS devices from the App Store and for
Android Devices from Play Store. Make sure that the mobile device being used supports BLE.

To verify the example project using the CySmart mobile app, follow these steps.

1. Plug the BLE Pioneer Kit into the PC for power, using the J13 USB connector.

2. Program the kit with the desired BLE example project.

3. Open the app on the mobile device.

https://itunes.apple.com/WebObjects/MZStore.woa/wa/viewSoftware?id=928939093&mt=8
https://play.google.com/store/apps/details?id=com.cypress.cysmart&hl=en
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4. If Bluetooth is not enabled on the device, the app will ask to enable it, as shown in Figure 6-50.

Figure 6-50.  Turn on Bluetooth on Device

5. After Bluetooth is enabled, the app will automatically search for available BLE peripherals and list
them, as shown in Figure 6-51. Select the BLE Pioneer Kit peripheral in the list. The name
displayed in the list will be the same as that set in the BLE Component.

Figure 6-51.  Peripheral Connections Page
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6. When connected, the app will list the supported profiles by the peripherals, as shown in
Figure 6-52. Tap on the desired profile.

Figure 6-52.  Profiles Page

7. Depending on the type of profile chosen, the app will display options for the profile. Figure 6-53
shows an example for the CapSense slider custom profile, where swiping a finger on the
CapSense slider of the BLE Pioneer Kit is reflected in the app. See Pioneer Baseboard on
page 88.

Figure 6-53.  CapSense Slider GUI

8. To go to a different service, go back to the service page in the GUI.
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9. To connect to a new BLE peripheral, go back to home page and swipe the screen below to scan
for devices.

10.To transfer data/notifications through any other profile that is not listed on the Profiles page after
connecting to the peripheral, go to the GATT DB option on the Profiles page. The GATT DB
allows you to access the services and characteristics of a profile directly, as shown in
Figure 6-54, and to modify or receive values through BLE.

Figure 6-54.  GATT DB GUI for Characteristics

The Data Logger option provides a textual form of all the events that has happened with a particular
BLE peripheral device, including scanning and connection.

Figure 6-55.  Data Logger
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Two custom profiles are created for demonstrating the BLE Pioneer Kit features: the CapSense
profile and the RGB LED profile. Both these profiles are integrated into the CySmart mobile app, as
easy-to-use GUI.

The CapSense profile GUI supports three CapSense functionalities.

■ CapSense Buttons: After connecting to the BLE peripheral, the CapSense Buttons service page
displays the number of CapSense buttons supported by the peripheral, as shown in Figure 6-56.
Any touch on one of the CapSense buttons on the peripheral is reflected in the CySmart GUI.

Figure 6-56.  CapSense Buttons GUI Page



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 157

Advanced Topics

■ CapSense Slider: After connecting to the BLE peripheral, the CapSense Slider service page
displays the CapSense slider as supported by the peripheral, as shown in Figure 6-57. Swiping a
finger on the CapSense slider on the peripheral is reflected in the CySmart GUI.

For example, the CapSense_Slider_LED project (CapSense Slider and LED on page 47) will 
show this utility on the app.

Figure 6-57.  CapSense Slider GUI Page



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 158

Advanced Topics

■ CapSense Proximity: After connecting to the BLE peripheral, the CapSense Proximity service
page displays the CapSense proximity supported by the peripheral, as shown in Figure 6-58. A
change in proximity on the proximity sensor (such as a wire) on the peripheral is reflected in the
CySmart GUI.

For example, the CapSense_Proximity project (CapSense Proximity on page 62) will show this 
utility on the app.

Figure 6-58.  CapSense Proximity GUI Page
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The RGB LED profile allows you to control the color and intensity of the BLE Pioneer Kit onboard
RGB LED, as shown in Figure 6-59. Pressing any part of the color gamut on the GUI is reflected on
the BLE peripheral device with the onboard RGB LED.

Note: The onboard RGB LED color range depends on the LED being used. It is possible that the
complete color gamut is not reflected on the onboard RGB LED due to limitations on the LED itself.

For example, the CapSense_Slider_LED project (CapSense Slider and LED on page 47) will show
this utility on the app.

Figure 6-59.  RGB LED Profile
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6.7 CySmart PC Tool

The CySmart PC tool is a BLE Central host emulation tool that, along with the dongle, allows you to
connect to a BLE peripheral device and transfer data over BLE services. Also, it displays all the
packets that are involved during the connection, which can be analyzed for details.

The CySmart PC tool is installed as part of the BLE Pioneer Kit installer. To launch the software,
choose Start > All Programs > Cypress > CySmart <version> > CySmart <version>.

Follow these steps to connect to a BLE peripheral device using the dongle and CySmart PC tool and
to transfer data.

1. Connect the dongle to one of the USB ports on the PC.

Figure 6-60.  Connect Dongle to USB Port
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2. Start the CySmart PC tool on the PC. You will see a list of dongles connected to it. Select the
dongle you want to use and click Connect, as shown in Figure 6-61. 

Figure 6-61.  Selecting Dongle in CySmart PC Tool

3. The CySmart PC tool can be used to connect to any BLE peripheral device, including the BLE
Pioneer kit. To connect to the BLE Pioneer kit, power the kit through the J13 USB connector and
program the appropriate BLE peripheral project to it. Follow the steps according to the project
description to start advertising.
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4. When the dongle is selected and connected to, the main window shown in Figure 6-62 opens up.

Figure 6-62.  CySmart PC Tool Main Window

The important parts of this window are as follows:

■ Menu bar: This contains options to exit or find help about the CySmart PC tool.

■ Dongle settings: These settings comprise of Select Dongle, Configure Master Settings, and
Manage PSMs. Select the dongle allows to connect to a dongle that is listed by the system. If a
different dongle needs to be connected, then this option can be used. Configure Master Settings
option allows to modify the various settings that the dongle requires to act as a BLE Central
device such as connection parameters, scan parameters, or security parameters. Manage PSMs
allows to register for PSM or modify them.

■ Discovered devices options: The Master tab provides three options by default: Start Scan,
Connect, and Add to Whitelist. The Start Scan button allows the tool to start scanning for
available BLE peripheral devices and list them in the Discovered Devices window. This option
also allows to stop an ongoing scan. The Connect option allows to connect to a particular BLE
peripheral device that is listed in the Discovered Device window. Add to Whitelist allows to add a
selected device address to the whitelist.

■ Advertisement Data/Scan response data tabs: These tabs provide the description of the data
received in the advertisement packet and scan response packet from the selected device.

■ Discovered Devices window: This window lists all the peripheral devices found after starting a
scan. Selecting any device populates the information on advertisement data and scan response
data on the right side window.

■ Whitelist window: This window lists the devices that have been added as whitelist and provides
options to add, remove, or clear devices from the whitelist.

■ Raw Data window: This window displays the raw data (in hexadecimal) of the field selected.

■ Log window: This window displays all the activities that occur on the dongle and the data
communicated. This feature is also useful for debugging. 
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1. Click Start Scan to see the list of available BLE peripheral devices, as shown in Figure 6-63.

Figure 6-63.  Scanned Devices Listed in CySmart PC Tool

2. After the available devices are listed, choose the desired peripheral and double-click Connect,
as shown in Figure 6-64. 

Figure 6-64.  Start Connection with Selected Device
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3. If the connection is successful, you will see another tab opening besides the Master tab. This tab
provides options with respect to the connected BLE device, as shown in Figure 6-65.

Figure 6-65.  Connected Device Tab

4. On the device tab, click Discover All Attributes to find the supported attributes by the connected
BLE device. This action populates the list of services and characteristics in the Attribute window
along with their values, if any, as shown in Figure 6-66.

Figure 6-66.  Discover All Attributes
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5. You can read the characteristics individually or you can use the Read All Characteristics option
to update the values for all readable characteristics, as shown in Figure 6-67.

Figure 6-67.  Read All Characteristics

6. To modify the value of a characteristic individually, select the particular characteristic from the
attribute list. The Attribute Details window on the right will display the properties of the selected
characteristics as well as the options to modify or read the values, as shown in Figure 6-68.

Figure 6-68.  Modify a Characteristic

7. Similarly, notifications or indications can be enabled on the characteristics that support those
properties.
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8. The list of attributes of the connected BLE device can also be saved in .csv format for later use.
For this, click the Export button on the device tab and select the location where you want the file
to be saved, as shown in Figure 6-69.

Figure 6-69.  Save Attribute List to a File

9. The tool also allows sending specific commands to the BLE peripheral device. These commands
are present in the Send Commands tab on the device window. Select the command to be sent
from the list and click Send, as shown in Figure 6-70.

Figure 6-70.  Send Commands
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10.To disconnect from the device, go to the Master tab, select the connected device, and click 
Disconnect, as shown in Figure 6-71.

Figure 6-71.  Disconnect BLE Device

Note: Refer to the CySmart PC tool user guide for more information. To access the user guide from
the tool, go to Help > Help Topics.
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A. Appendix

A.1 Schematics
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V
D

D
D

59

V
S

S
D

58

V
C

C
D

57

P
0_

7
56

P
0_

6
55

P
0_

5
54

P
0_

4
53

V
D

D
IO

2
67

P
2_

5
68

E
P

A
D

69

0
6
0
3 R

16
22

E

0402

C10
0.1 uF

0603

C7
1.0 uF

0402

C18
0.1 uF

0402

C9
0.1 uF

0603

C16
1.0 uF

0402

C19
0.1 uF

0402

C14
0.1 uF

R14 ZERO

PSoC 4 / External PSoC Program/Debug HeaderPSoC 5LP Program/Debug Header

NO LOAD NO LOAD

P5LP12_2
P5LP12_3

P5LP12_4

P5LP_SWO

P5LP_XRES

P5LP_SWDCLK

P5LP_TDI

P5LP_SWDIO

VTARGP5LP_VDD

RESET

SWDCLK
SWDIO

0402

C5

0.1 uF

T
V

S
2

5V
 3

50
W

T
V

S
1

5V
 3

50
W

J7

50MIL KEYED SMD

1
3
5
7
9

2
4
6
8

10

J6

50MIL KEYED SMD

1
3
5
7
9

2
4
6
8

10

0402

C12

0.1 uF



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 169

PSoC 5LP GPIO Expansion Header

USB-Serial Bridge Connections

P5LP12_6 ------------- UART RX
P5LP12_7 ------------- UART TX
P5LP12_0 ------------- SPI SCLK / I2C SCL
P5LP12_1 ------------- SPI MISO / I2C SDA 
P5LP12_5 ------------- SPI MOSI 
P5LP2_5  ------------- SPI SSEL

P5LP12_7P5LP12_6
P5LP3_6 P5LP3_7

P5LP0_0
P5LP1_2

P5LP3_5P5LP3_4

P5LP3_0

P5LP0_1

P5LP12_1
P5LP12_5P5LP12_0

P5LP2_5

VDD

SPI_MOSI
SPI_SSEL

UART TXUART RX

J8

8x2 RECPT

1
1

2
2

3
3

4
4

5
5

6
6

7
7

8
8

10
10

9
9

12
12

11
11

14
14

13
13

16
16

15
15

I2C Connection

Status LED

P5LP3_1

SCL

SDA

P5LP12_0

P5LP12_1

P5LP2_7

P5LP2_6

VDD

SPI_MISO / I2C_SDA

SPI_SCLK / I2C_SCL

U4
NTZD3152P

6

2 1

3
45

R23
2.2K

R27 ZERO

R11

820 ohm

R26 ZERO

0805

LED2

Status LED Green

2 1

R22
2.2K

USB MiniB 

NO LOAD

NO LOAD

CR2032 Coin Cell
Battery Holder

DP
DM

VDD

VBUS

VIN

P5LP_DM
P5LP_DP

J13

USB MINI B

VBUS
1

DM
2

DP
3

GND
5ID
4

S
1

6
S

2
7

F1

PTC Resettable Fuse

1
2

C4
100uF

0
6
0
3

D
6

SOD123

D10

0402

R6100K

0
6
0
3

D
8

04
02

C3 0.01 uF

J9

2 PIN HDR

1
1

2
2

+
-

BT1

1
3 2

TP2 RED

0
6
0
3

D
7
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NO LOAD

Protection Circuit

NO LOAD

VDDV3.3

VFRAMVDD

R9
10K

R59 ZERO

Q2

PMOS( NTR4171PT1G) 

R8
15K

D11

V
z=

2.
7V

(M
M

S
Z

46
82

T
1G

)

Q5

PMOS( PMV48XP,215)

D9

V
z=

3.
9V

(B
Z

T
52

C
3V

9-
7-

F
)

R7 ZERO

R20
10K

Q6

PMOS( NTR4171PT1G) 

R58
15K

Q4

P
M

O
S

( N
T

R
4171P

T
1G

)

Q3

PMOS(PMV48XP,215)

Q1

P
M

O
S

( D
M

P
3098L-7)

NO LOAD NO LOAD

1

2

3

4

5

6

CTL

VCC

N.C.

OUT

C

GND

Output Voltage ON / OFF control

Power supply voltage input

Unconnected terminal

Voltage output

Output voltage regulation terminal

Ground

Pin No Symbol Function.

TABLE: LDO PIN FUNCTIONS

GND Test Points

TABLE: VOLTAGE SELECTION JUMPER SETTINGS  

JUMPER SETTING O/P VOLTAGE

SHORT 2 & 3

SHORT 1 & 2

REMOVE JUMPER

3.3V

5V

1.9V

VADJ VDD

VCC

EN_CTRL

EN_CTRL

VBUS

VIN

VCC

EN_CTRL

TP5
BLACK

U1

BA00BC0WFP-E2

VCC
2

CTL
1

NC
3

OUT
4

C
5

GND
6

SOD123

D1

R1
11K
1%

R10
10K

+3216 C2
4.7uF

R4
10K 1%

SOD123

D4

R3
14.7K 1%

R5
4.3K 1%

TP6
BLACK

SOD123

D2

J16
3 PIN HDR

1 3
2

TP4
BLACK

+3216 C1
1 uFd

SOD123

D3
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NO LOAD

NO LOAD

Current Measurement Jumper

VADJ

VDD BLE_VDD

VTARG

R2

560 ohm

J15
HDR212

R44 ZERO

R45 ZERO

TP1 RED

0805

LED1

Power LED

2 1

(J1- J4) Arduino Connectors

J12 Arduino ICSP compatible header
for SPI Interface

NO LOAD

GND

/XRES

/XRES

P1_4

P1_5

P1_6

P1_7

P1_3

P1_2

P1_1

P1_0

P3_5

P3_4

P3_3

P3_2

P3_1

P3_0

P0_5

P0_4

P0_2

P0_0

P0_1

P0_3

VREF

P0_1
P0_3 P0_0

P2_0

P2_1

P2_2

P2_3

P2_4

P2_5

P3_5

P3_4

BLE_VDD

VIN

V3.3

VBUS

J2

CON6X2

A0
1

A1
3

A2
5

A3
7

A4
9

A5
11

P2.0
2

P2.1
4

P2.2
6

P2.3
8

P2.4
10

P2.5
12

J4

CON8

D0
1

D1
2

D2
3

D3
4

D4
5

D5
6

D6
7

D7
8

J3

CON10

D8
1

D9
2

D10
3

D11
4

D12
5

D13
6

GND
7

AREF
8

SDA
9

SCL
10

J12

3x2 RECPT

1 2
3 4
5 6

SOD123

D5

J1

CON8

VIN
1

GND
2

GND
3

V5.0
4

V3.3
5

Reset
6

IORef
7

NC
8

PSoC 4 BLE/PRoC BLE I/O Headers

NO LOAD

Analog PinsDigital Pins

VDDA
P3_7P3_6
P3_5P3_4
P3_3P3_2
P3_1P3_0
P5_1P4_0
P5_0P4_1
P2_7P2_6
P2_5P2_4
P2_3P2_2
P2_1P2_0
GNDVDDR

GND

VDDD
P1_7
P1_5
P1_3

P0_5
P0_3
P0_1

P0_4
P0_2
P0_0

P1_6

/XRES

P1_0
P1_1 P1_2
P1_4

P0_7
P0_6

VREF

GND

VDDR

VDDD

VDDA
BLE_VDD

L1

330 OHM @ 100MHz

J11

HEADER 10x2

1 2
3 4
5 6
7 8
9 10

11 12
13 14
15 16
17 18
19 20

TP3
RED

J10

HEADER 12x2

1 2
3 4
5 6
7 8
9 10

11 12
13 14
15 16
17 18
19 20
21 22
23 24

0402

C28
0.1 uF

0402

C26
0.1 uF

L2

330 OHM @ 100MHz

0402

C27
0.1 uF

L3

330 OHM @ 100MHz
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Shield Setting

RESET

NO LOAD

USER SWITCH

SHIELD

GND

P1_6

P3_6

P3_7

P2_6

P2_7

P2_1

P2_2

P2_3

P2_4

P2_5

/XRES

BLE_VDD

/XRES

R39 560 ohm

R42 560 ohm

CSS1

CapSense Slider 5 Seg 

5

4

3

2

1

R30 1.5K

R13 ZERO

0402

C25
0.1 uF

R12 ZERO

R43 560 ohm

R41 560 ohm

SW2

EVQ-PE105K

1 2

R40 560 ohm

R28 2.2K R29 1.5K

R G

B

LED3

RGB LED

1

2 3

4

SW1

EVQ-PE105K

1 2

F-RAM

NO LOAD NO LOAD NO LOAD

A1
A2

A1

P5_0
P5_1

WP

A2 WP

VFRAM

VFRAM

VFRAM VFRAM

VFRAM

VFRAM

R32
ZERO

R37
ZERO

U3

FM24V10

A1
2

VSS
4 SCL

6

VDD
8

NC
1

A2
3

SDA
5

WP
7C29

33uF

R36
ZERO

R35
2.2K

0402

C23

0.1 uF

R33
ZERO

R34
ZERO

R38
ZERO

R31
2.2K

Proximity Header

PMOD Connector
NO LOAD

P0_2

P0_0

P0_1

P0_3
P2_0

V
D

D

J14

1x1 RECP

J5

CON6

SS
1

MOSI
2

MISO
3

SCK
4

GND
5

VCC
6

R19 ZERO

NO LOAD

USB-I2C

USB-SPI

USB-UART

USB-SWD

PSoC 5LP and PSoC 4 BLE/PRoC BLE Connections

NO LOAD

NO LOAD

NO LOAD
P0_3

P0_1

P0_2

P0_0

P3_5

P3_4

/XRES

P0_7

P0_6

P1_5

P1_4

SPI_MOSI

SPI_SSEL

SPI_MISO / I2C_SDA

SPI_SCLK / I2C_SCL

RESET

SWDIO

SWDCLK

UART TX

UART RX R52 ZERO

R53 ZERO

R54 ZERO
R49 ZERO

R50 ZERO

R56 ZERO

R46 ZERO

R55 ZERO

R48 ZERO

R51 ZERO

R47 ZERO
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A.1.2 BLE Module

SAR bypass

CMODShunt 
Resistor C_Tank

KHz Crystal

MHz Crystal

TX
RX

Analog Pins

Serial Interface

No Load

No Load

No Load

No Load

No Load

Digital Pins

No Load

PCA: 121-60159-01
PCB: 600-60195-01
FAB DRW: 610-60187-01
ASSY DRW: 620-60195-01

No Load

No Load

No Load
No Load

No Load P4.0 P4.1

P6.0

P6.1

XTAL24O

XTAL24I

P6.0
P6.1
/XRES
P4.0
P4.1
P5.0
P5.1

X
TA

L2
4I

X
TA

L2
4O

P
2.

6
P

2.
7

P
3.

0
P

3.
1

P
3.

2
P

3.
3

P
3.

4
P

3.
5

P
3.

6
P

3.
7

P1.5
P1.4

/XRES

P1.6
P1.5
P1.4
P1.3
P1.2
P1.1

P2.4
P2.3
P2.2
P2.1
P2.0

P1.7

P2.5

P3.7P3.6
P3.5P3.4
P3.3P3.2
P3.1P3.0
P5.1P4.0
P5.0P4.1
P2.7P2.6
P2.5P2.4
P2.3P2.2
P2.1P2.0

P1.7
P1.5
P1.3

P0.5
P0.3
P0.1

P0.4
P0.2
P0.0

P1.6

/XRES

P1.0
P1.1 P1.2
P1.4

P0.7
P0.6

P
0.

0
P

0.
1

P
0.

2
P

0.
3

P
0.

4
P

0.
5

P
0.

6
P

0.
7

P
1.

0

VDDD

VDDA

VDDR

VCCD

VDDD

VREF

VDDR

VDDA VREF

VDDR VDDDVDDA

VDDD

VCCD VDDD

VDDA

VDDA

VDDR

VDDD

VREF

VDDD

Title

Size Document Number Rev

CYPRESS SEMICONDUCTOR  © 2014

CY8CKIT-142 PSoC 4 BLE Module
Title

Size Document Number Rev

CYPRESS SEMICONDUCTOR  © 2014

CY8CKIT-142 PSoC 4 BLE Module
Title

Size Document Number Rev

CYPRESS SEMICONDUCTOR  © 2014

CY8CKIT-142 PSoC 4 BLE Module

0603

C10

1.0 uF0402

C9

0.1 uF

C13

1.2 pF

0603

C20
1.0 uF

J2

HEADER 10x2

1 2
3 4
5 6
7 8
9 10

11 12
13 14
15 16
17 18
19 20

0603

C2

1.0 uF

L4

33
0 

O
H

M
 @

 1
00

M
H

z

0402

C1

0.1 uF

TP2
RED

C23
36 pF

C22
10000 pF

0603

C4

1.0 uF

0603

C25

100 pF

0603

C17

1.0 uF

0603

C6

1.0 uF0402

C3

0.1 uF

0402

C16

0.1 uF

0402

C5

0.1 uF

C21
2200 pF

L3

33
0 

O
H

M
 @

 1
00

M
H

z

TP1
RED

0603

C8

1.0 uF

0603

C19

1.0 uF

R1

Zero Ohm
0402

C18

0.1 uF

0603

C15

1.0 uFJ3

4 HEADER

1
2
3
4

R2
Zero Ohm

L1
6.8nH

0603

C12

1.0 uF

C24
18 pF

TP3
RED

0402

C11

0.1 uF

Y1
32.768KHz

1
2

TP5
BLACK

CY8C4247LQI-BL483

U1

VDDD
1

XTAL32O/P6.0
2

XTAL32I/P6.1
3

XRES
4

P4.0
5

P4.1
6

P5.0
7

P5.1
8

VSSD
9

VDDR
10

GANT1
11

ANT
12

GANT2
13

VDDR
14

P2.5
42

P2.4
41

P2.3
40

P2.2
39

P2.1
38

P2.0
37

VDDA
36

P1.7
35

P1.6
34

P1.5
33

P1.4
32

P1.3
31

P1.2
30

P1.1
29

E
P

A
D

57

V
C

C
D

56

V
S

S
A

55

P
3.

7
54
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6
53
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3.

5
52

P
3.
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3.
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3.
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49
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48

P
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0
47

V
D
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A

46

V
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45

P
2.

7
44

P
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6
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V
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D
R

15

X
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L2
4I

16

X
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4O

17

V
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D
R

18

P
1.

0
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P
0.

0
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P
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1
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R3
4.7K

L2

33
0 

O
H

M
 @

 1
00

M
H

z

J1

HEADER 12x2
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50 Ohm Wiggle Antenna
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C14
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C7
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A.1.3 Dongle

NO LOAD

NO LOAD

I2C Connection

Power and Status LED

USB A PLUG

NO LOAD

USB Connection

PSoC 5LP Programmer / Debugger

NO LOAD NO LOADNO LOAD

PCA: 121-60161-01
PCB: 600-60197-01
FAB DRW: 610-60189-01
ASSY DRW: 620-60197-01

SAR Bypass
Capacitor

P5LP0_4 to P5LP0_7,
P5LP3_2, P5LP3_3 are 
reserved for HW REV ID

NO LOAD

SAR Bypass
Capacitor

Del Sig Bypass
Capacitor

PRoC Program/Debug Header

NO LOAD NO LOAD NO LOAD

PSoC 5LP and PRoC BLE Connections

P5LP12_0

P5LP12_1

P5LP_XRES

P5LP2_7

P5LP2_6

SCL

SDA

DM
DP

P
5L

P
_S

W
D

IO

P
5L

P
_S

W
D

C
LK

P5LP3_1

P5LP_POWER

P
5L

P
_X

R
E

S

P
5L

P
0_

4

V
S

S
D

P5LP_SWDCLK
P5LP_SWDIO

P5LP_SWO

P5LP12_5

P5LP_XRES

P
5L

P
_D

P
P

5L
P

_D
M

D
M

_P

P5LP0_3

D
P

_P

P5LP0_0
P5LP0_1

P5LP12_0

P
5L

P
12

_6
P5LP12_1

VSSD

VSSD

P
5L

P
12

_7

P5LP2_6
P5LP2_7

P5LP12_4

P5LP3_7
P5LP3_6

P5LP0_2

V
S

S
D

P
5L

P
3_

0

P5LP12_3

P
5L

P
3_

4
P

5L
P

3_
5

P
5L

P
1_

7

P5LP1_6

P
5L

P
3_

1

P
5L

P
_V

C
C

D

P5LP_POWER

P
5L

P
_V

C
C

D

P
5L

P
2_

5

P
5L

P
0_

5

P
5L

P
15

_4

P5LP1_2

P5LP12_2

P5LP12_2
P5LP12_3

P5LP12_4

SWDIO

SWDCLK

/XRES

P5LP12_5
P5LP12_1
P5LP2_5
P5LP12_0

P5LP12_7
P5LP12_6

V
B

U
S

P
5L

P
15

_4

P5LP_VDD

P5LP_VDD VBUS

VTARG

VBUS

VTARG VBUS

P5LP_VDD
P5LP_VDD

P5LP_VDD
P5LP_VDD

P5LP_VDD

P5LP_VDD

P5LP_VDD

VTARGVBUS

VTARG

SDA

SCL

P5LP_DM
P5LP_DP

P
5L

P
_D

P
P

5L
P

_D
M

E
X

TR
A

/XRES

SWDCLK

SWDIO

P5LP12_5
P5LP12_1
P5LP2_5
P5LP12_0

P5LP12_6
P5LP12_7

Title

Size Document Number Rev

CYPRESS SEMICONDUCTOR  © 2014

630-60193-01 03

BLE Dongle

B

Title

Size Document Number Rev

CYPRESS SEMICONDUCTOR  © 2014

630-60193-01 03

BLE Dongle

B

Title

Size Document Number Rev

CYPRESS SEMICONDUCTOR  © 2014

630-60193-01 03

BLE Dongle

B

0603

C40
1.0 uF

0603

C24
1.0 uF

U3

CY8C5868LTI-LP039 QFN68

P2_6
1

P2_7
2

P12_4 I2C0_SCL, SIO
3

P12_5 I2C0_SDA, SIO
4

VSSB
5

IND
6

VBOOST
7

VBAT
8

VSSD
9

XRES
10

P1_0
11

P1_1
12

P1_2
13
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VDDIO1
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D
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24
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S

S
D

25

V
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D

26

P
15
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27

P
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_1
28

P
3_

0
29

P
3_

1
30

P
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2
31

P
3_

3
32

P
3_

4
33

P
3_

5
34

VDDIO3
35

V
D

D
IO

0
52

P0_3
51

P0_2
50

P0_1
49

P0_0
48

SIO_P12_3
47

SIO_P12_2
46

VSSD
45

VDDA
44

VSSA
43

VCCA
42

P15_3
41

P15_2
40

SIO, I2C1_SDA P12_1
39

SIO, I2C1_SCL P12_0
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A.2 Board Layout

A.2.1 BLE Pioneer Board

Figure A-1.  Primary Side of BLE Pioneer Board 

Figure A-2.  Ground Layer of BLE Pioneer Board

Figure A-3.  Power Layer of BLE Pioneer Board
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Figure A-4.  Secondary Side of BLE Pioneer Board

Figure A-5.  Primary Silkscreen of BLE Pioneer Board 

Figure A-6.  Secondary Silkscreen of BLE Pioneer Board 



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 178

A.2.2 PRoC BLE Module

Figure A-7.  Primary Side of PRoC BLE Module

Figure A-8.  Ground Layer of PRoC BLE Module

Figure A-9.  VCC Layer of PRoC BLE Module
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Figure A-10.  Secondary Side of PRoC BLE Module

Figure A-11.  Primary Silkscreen of PRoC BLE Module

Figure A-12.  Secondary Silkscreen of PRoC BLE Module
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A.2.3 PSoC 4 BLE Module

Figure A-13.  Primary Side of PSoC 4 BLE Module

Figure A-14.  Ground Layer of PSoC 4 BLE Module

Figure A-15.  VCC Layer of PSoC 4 BLE Module
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Figure A-16.  Secondary Side of PSoC 4 BLE Module

Figure A-17.  Primary Silkscreen of PSoC 4 BLE Module

Figure A-18.  Secondary Silkscreen of PSoC 4 BLE Module
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A.2.4 Dongle

Figure A-19.  Primary Side of Dongle

Figure A-20.  Ground Layer of Dongle

Figure A-21.  Power Layer of Dongle
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Figure A-22.  Secondary Side of Dongle

Figure A-23.  Primary Silkscreen of Dongle

Figure A-24.  Secondary Silkscreen of Dongle
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A.3 Bill of Materials (BOM)

A.3.1 BLE Pioneer Board

Item Qty Reference Value Description Manufacturer Mfr Part Number

1 -

PCB, 106.22 mm x 53.34 
mm, High Tg, ENIG finish, 
4 layer, Color = RED, Silk = 
WHITE.

Cypress

2 1 BT1
CR2032 Bat-
tery Holder

HOLDER COIN CELL 
CR2032 EJECT

MPD BA2032

3 1 C1 1.0 uF
CAP TANT 1UF 35V 10% 
1210

AVX Corporation TAJB105K035RNJ

4 1 C2 4.7 uF
CAP TANT 4.7UF 20V 
10% 1210

AVX Corporation TAJB475K020RNJ

5 1 C3 0.01 uFd
CAP 10000PF 16V 
CERAMIC 0402 SMD

TDK Corporation C1005X7R1C103K050BA

6 1 C4 100 uFd
CAP CER 100UF 6.3V 
20% X5R 1210

TDK Corporation C3225X5R0J107M250AC

7 15

C5,C8,C9,C10,C1
2,C14,C17,C18,C
19,C21,C23,C25,
C26,C27,C28

0.1 uFd
CAP .1UF 16V CERAMIC 
X5R 0402

TDK Corporation C1005X5R1A104K050BA

8 7
C6,C7,C11,C13,C
15,C16,C20

1.0 uFd
CAP CERAMIC 1.0UF 25V 
X5R 0603 10%

Taiyo Yuden TMK107BJ105KA-T

9 1 C29 33 uF
CAP CER 33UF 6.3V 20% 
X5R 0805

TDK Corporation C2012X5R0J336M125AC

10 6
D1,D2,D3,D4,D5,
D10

MBR0520L
DIODE SCHOTTKY 0.5A 
20V SOD-123

Fairchild Semicon-
ductor

MBR0520L

11 3 D6,D7,D8 ESD diode
SUPPRESSOR ESD 
5VDC 0603 SMD

Bourns Inc. CG0603MLC-05LE

12 1 D9 3.9V Zener
DIODE ZENER 3.9V 
500MW SOD12

Diodes Inc BZT52C3V9-7-F

13 1 D11 2.7V Zener
DIODE ZENER 2.7V 
500MW SOD123

ON Semiconductor MMSZ4682T1G

14 1 F1 FUSE
PTC RESETTABLE .50A 
15V 1812

Bourns MF-MSMF050-2

15 2 J1, J4 8x1 RECP 
CONN HEADER FEMALE 
8POS .1" GOLD

Protectron Electro-
mech

P9401-08-21

16 1 J2 6x2 RECP
CONN HEADER FMAL 
12PS.1" DL GOLD

Protectron Electro-
mech

P9403-12-21

17 1 J3 10x1 RECP
CONN HEADER FMALE 
10POS .1" GOLD

Protectron Electro-
mech

P9401-10-21

18 1 J8 8X2 RECP
CONN HEADER FMAL 
16PS.1" DL GOLD

Protectron Electro-
mech

P9403-16-21

19 1 J10 12X2 RECP
CONN HEADER 2.54MM 
24POS GOLD

Sullins Connector 
Solutions

SBH11-PBPC-D12-ST-BK

20 1 J11 10X2 RECP
CONN HEADER 2.54MM 
20POS GOLD

Sullins Connector 
Solutions

SBH11-PBPC-D10-ST-BK

21 1 J13 USB MINI B MINI USB RCPT R/A DIP TE Connectivity 1734510-1
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22 1 J14 1X1 RECP
CONN RCPT 1POS .100" 
SNGL HORZ

Samtec Inc BCS-101-L-S-HE

23 1 J15 2p_jumper
CONN HEADR BRKWAY 
.100 2POS STR

Protectron Electro-
mech

P9101-02-12-1

24 1 J16 3p_jumper
CONN HEADR BRKWAY 
.100 3POS STR

Protectron Electro-
mech

P9101-03-12-1

25 1 LED1
Power LED 
Amber

LED 595NM AMB DIFF 
0805 SMD

Avago Technolo-
gies 

HSMA-C170

26 1 LED2
Status LED 
Green

LED GREEN CLEAR 0805 
SMD

Chicago Miniature CMD17-21VGC/TR8

27 1 LED3 RGB LED
LED RED/GREEN/BLUE 
PLCC4 SMD

Cree, Inc.
CLV1A-FKB-
CJ1M1F1BB7R4S3

28 3 L1,L2,L3
330 OHM @ 
100MHz

FERRITE CHIP 330 OHM 
0805

Murata BLM21PG331SN1D

29 3 Q2,Q4,Q6 PMOS
MOSFET P-CH 30V 2.2A 
SOT23

ON Semiconductor NTR4171PT1G

30 1 Q1, PMOS
MOSFET P-CH 30V 3.8A 
SOT23-3

Diodes Inc DMP3098L-7

31 2 Q3,Q5 PMOS
MOSFET P-CH 20V 3.5A 
SOT23

NXP Semiconduc-
tors

PMV48XP,215

32 1 R1 11K 1%
RES 11K OHM 1/10W 1% 
0603 SMD

Panasonic - ECG ERJ-3EKF1102V

33 1 R2 560 ohm
RES 560 OHM 1/8W 5% 
0805 SMD

Panasonic - ECG ERJ-6GEYJ561V

34 1 R3 14.7K 1%
RES 14.7K OHM 1/10W 
1% 0603 SMD

Panasonic - ECG ERJ-3EKF1472V

35 1 R4 10K 1%
RES 10K OHM 1/10W 1% 
0603 SMD

Panasonic - ECG ERJ-3EKF1002V

36 1 R5 4.3K 1%
RES 4.3K OHM 1/10W 1% 
0603 SMD

Panasonic - ECG ERJ-3EKF4301V

37 1 R6 100K
RES 100K OHM 1/10W 5% 
0402 SMD

Panasonic - ECG ERJ-2GEJ104X

38 14

R19,R26,R27,R3
6,R37,R38,R45,R
46,R47,R52,R53,
R54,R55,R56

ZERO
RES 0.0 OHM 1/10W 0603 
SMD

Panasonic - ECG ERJ-3GEY0R00V

39 2 R8,R58 15K
RES 15K OHM 1/10W 1% 
0603 SMD

Panasonic - ECG ERJ-3EKF1502V

40 2 R9,R20 10K 1%
RES 10K OHM 1/8W 1% 
0805 SMD

Stackpole Electron-
ics Inc

RMCF0805FT10K0 

41 1 R10 10K
RES 10K OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ103V

42 1 R11 820 ohm
RES 820 OHM 1/8W 5% 
0805 SMD

Panasonic - ECG ERJ-6GEYJ821V

43 2 R13,R14 ZERO
RES 0.0 OHM 1/8W 0805 
SMD

Panasonic-ECG ERJ-6GEY0R00V

44 2 R15,R16 22E
RES 22 OHM 1/10W 1% 
0603 SMD

Panasonic - ECG ERJ-3EKF22R0V

45 2 R17,R18 15K
RES 15K OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ153V

Item Qty Reference Value Description Manufacturer Mfr Part Number
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46 5
R22,R23,R28,R3
1,R35 

2.2K
RES 2.2K OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ222V

47 2 R24,R25 30K
RES 30K OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ303V

48 2 R29,R30 1.5K
RES 1.5K OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ152V

49 5
R39,R40,R41,R4
2,R43

560 ohm
RES 560 OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ561V

50 2 SW1,SW2
SW PUSH-
BUTTON

SWITCH TACTILE SPST-
NO 0.05A 12V

Panasonic - ECG EVQ-PE105K

51 1 TP5 BLACK
TEST POINT PC MINI 
.040"D Black

Keystone Electron-
ics

5001

52 2 TVS1,TVS2 5V 350W
TVS UNIDIR 350W 5V 
SOD-323

Dioded Inc. SD05-7

53 1 U1 LDO
IC REG LDO ADJ 1A 
TO252-5

Rohm Semiconduc-
tor

BA00BC0WFP-E2

54 1 U2 PSoC 5LP 
68QFN PSoC 5LP chip for 
USB debug channel and 
USB-Serial interface

Cypress Semicon-
ductor

CY8C5868LTI-LP039

55 1 U3 F-RAM
F-RAM 1-Mbit (128K X 8) 
I2C interface

Cypress Semicon-
ductor

FM24V10-G

56 1 U4 DUAL PMOS
MOSFET 2P-CH 20V 
430MA SOT-563

ON Semiconductor NTZD3152PT1G

Install on Bottom of PCB As per the Silk Screen in the Corners

57 4 N/A N/A
BUMPER CYLIN 0.375" 
DIA BLK

3M SJ61A4

Special Jumper Installation Instructions

58 2 J15,J16
Install jumper 
across pins 1 
and 2 

Rectangular Connectors 
MINI JUMPER GF  6.0MM 
CLOSE TYPE BLACK

Kobiconn 151-8010-E

Label

59 1 N/A N/A

LBL, PCA Label, Vendor 
Code, Datecode, Serial 
Number 121-60158-01 Rev 
04 (YYWWVVXXXXX)

Cypress Semicon-
ductor

60 1 N/A N/A
LBL, QR code, 12mm X 
12mm

Cypress Semicon-
ductor

No load components

61 1 C22 0.1 uFd
CAP .1UF 16V CERAMIC 
Y5V 0402

TDK Corporation C1005X5R1A104K050BA

62 1 C24 1.0 uFd
CAP CERAMIC 1.0UF 25V 
X5R 0603 10%

Taiyo Yuden TMK107BJ105KA-T

63 9
R7,R59,R32,R33,
R34,R48,R49,R5
0,R51

Zero Ohm
RES 0.0 OHM 1/10W 
JUMP 0603

TE Connectivity 1623094-1

64 1 R21 4.7K
RES 4.7K OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ472V

65 2 J7,J6
50MIL KEYED 
SMD

CONN HEADER 10 PIN 
50MIL KEYED SMD

Samtec FTSH-105-01-L-DV-K

Item Qty Reference Value Description Manufacturer Mfr Part Number
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66 1 J9 2 PIN HDR
CONN HEADER FEMALE 
2POS .1" GOLD

Sullins Connector 
Solutions

PPPC021LFBN-RC

67 2 TP4,TP5 BLACK
TEST POINT 43 HOLE 65 
PLATED BLACK

Keystone Electron-
ics

5001

68 3 TP1,TP2,TP3 RED
TEST POINT 43 HOLE 65 
PLATED RED

Keystone Electron-
ics

5000

69 2 R44,R12 ZERO
RES 0.0 OHM 1/8W 0805 
SMD

Panasonic-ECG ERJ-6GEY0R00V

70 1 J12 3x2 RECPT
CONN HEADER FMAL 
6PS .1" DL GOLD

Sullins Connector 
Solutions

PPPC032LFBN-RC

71 1 J5 6X1 RECP RA
CONN FEMALE 6POS 
.100" R/A GOLD

Sullins Connector 
Solutions

PPPC061LGBN-RC

Item Qty Reference Value Description Manufacturer Mfr Part Number
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A.3.2 BLE Module

A.3.2.1 CY5671 PRoC BLE Module

Item Qty Reference Value Description Manufacturer Mfr Part Number

1 1 600-60196-01 -
PRoC BLE Module printed 
circuit board 

Cypress qualified ven-
dor 

600-60196-01 Rev03

2 8
C1,C3,C5,C7,C9,C
11,C16,C18

0.1 uF
CAP .1UF 16V CERAMIC 
Y5V 0402

Samsung Electro-
Mechanics America, 
Inc

CL05F104ZO5NNNC

3 10
C2,C4,C6,C8,C10,
C12,C15,C17,C19,
C20

1.0 uF
CAP CERAMIC 1.0UF 
25V X5R 0603 10%

TDK Corporation C1608X5R1E105K080AC

4 1 C21 2200 pF
CAP CER 2200PF 50V 
5% NP0 0805

Murata Electronics GRM2165C1H222JA01D

5 1 C22
10000 
pF

CAP CER 10000PF 50V 
5% NP0 0805

Murata Electronics GRM2195C1H103JA01D

6 1 C23 36 pF
CAP CER 36PF 50V 5% 
NP0 0402

Murata Electronics GRM1555C1H360JA01D

7 1 C24 18 pF
CAP CER 18PF 50V 1% 
NP0 0402

Murata Electronics GRM1555C1H180FA01D

8 1 C14 1.5 pF
CAP CER 1.5PF 50V NP0 
0402

Johanson Technology 
Inc

500R07S1R5BV4T

9 1 J1
HEADE
R 24

CONN HEADR FMALE 
24POS .1" DL AU

Sullins Connector SFH11-PBPC-D12-ST-BK

10 1 J2
HEADE
R 20

CONN HEADR FMALE 
20POS .1" DL AU

Sullins Connector SFH11-PBPC-D10-ST-BK

11 1 L1 6.8nH
CER INDUCTOR 6.8NH 
0402

Johanson Technology 
Inc

L-07C6N8JV6T

12 3 L2,L3,L4
330 Ohm 
@100 
MHz

FERRITE CHIP 330 OHM 
0805

Murata Electronics BLM21PG331SN1D

13 1 U1
PRoC 
BLE

56 QFN PRoC BLE 
Cypress Semiconduc-
tor

CYBL10563-56LQXI

14 1 Y1
32.768K
Hz

CRYSTAL 32.768KHZ 
12.5PF SMD

ECS Inc ECS-.327-12.5-34B

15 1 Y2 24MHz
CRYSTAL 24.000 MHZ 
8PF SMD

ECS Inc ECS-240-8-36CKM

16 1 LBL -

LBL, PCA Label, Vendor 
Code, Datecode, Serial 
Number 121-60160-01 
Rev 04 (YYWWV-
VXXXXX)

Cypress qualified ven-
dor 

-

No Load components

17 1 C13 1.2 pF
CAP CER 1.2PF 50V NP0 
0402

Johanson Technology 
Inc

500R07S1R2BV4T

18 1 C25 100pF
CAP CER 100PF 50V 
10% X7R 0603

Kemet C0603C101K5RACTU
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19 1 R1
Zero 
Ohm

RES 0.0 OHM 1/8W 0605 
SMD

TE Connectivity 1623094-1

20 1 R2 Rbleed No Load - -

21 1 R3 4.7K
RES 4.7K OHM 1/10W 
5% 0603 SMD

Panasonic - ECG ERJ-3GEYJ472V

22 1 J3
4 
HEADE
R

CONN HEADER 4POS 
.100 R/A 15AU

FCI 68016-204HLF

23 4 TP1,TP2,TP3,TP4 RED
TEST POINT 43 HOLE 65 
PLATED RED

Keystone Electronics 5000

24 1 TP5 BLACK
TEST POINT 43 HOLE 65 
PLATED BLACK

Keystone Electronics 5001

Item Qty Reference Value Description Manufacturer Mfr Part Number
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A.3.2.2 CY8CKIT-142 PSoC 4 BLE Module

Item Qty Reference Value Description Manufacturer Mfr Part Number

1 1 600-60195-01 -
PSoC 4 BLE Module 
printed circuit board 

Cypress qualified 
vendor 

600-60195-01 Rev03

2 8
C1,C3,C5,C7,C9,
C11,C16,C18

0.1 uF
CAP .1UF 16V CERAMIC 
Y5V 0402

Samsung Electro-
Mechanics Amer-
ica, Inc

CL05F104ZO5NNNC

3 10
C2,C4,C6,C8,C10
,C12,C15,C17,C1
9,C20

1.0 uF
CAP CERAMIC 1.0UF 25V 
X5R 0603 10%

TDK Corporation C1608X5R1E105K080AC

4 1 C21 2200 pF
CAP CER 2200PF 50V 5% 
NP0 0805

Murata Electronics GRM2165C1H222JA01D

5 1 C22 10000 pF
CAP CER 10000PF 50V 
5% NP0 0805

Murata Electronics GRM2195C1H103JA01D

6 1 C23 36 pF
CAP CER 36PF 50V 5% 
NP0 0402

Murata Electronics GRM1555C1H360JA01D

7 1 C24 18 pF
CAP CER 18PF 50V 1% 
NP0 0402

Murata Electronics GRM1555C1H180FA01D

8 1 C14 1.5 pF
CAP CER 1.5PF 50V NP0 
0402

Johanson Technol-
ogy Inc

500R07S1R5BV4T

9 1 J1
HEADER 
24

CONN HEADR FMALE 
24POS .1" DL AU

Sullins Connector SFH11-PBPC-D12-ST-BK

10 1 J2
HEADER 
20

CONN HEADR FMALE 
20POS .1" DL AU

Sullins Connector SFH11-PBPC-D10-ST-BK

11 1 L1 6.8nH
CER INDUCTOR 6.8NH 
0402

Johanson Technol-
ogy Inc

L-07C6N8JV6T

12 3 L2,L3,L4
330 Ohm 
@100 
MHz

FERRITE CHIP 330 OHM 
0805

Murata Electronics BLM21PG331SN1D

13 1 U1
PSoC 
4BLE

56 QFN PSoC 4 BLE 
Cypress Semicon-
ductor

CY8C4247LQI-BL483

14 1 Y1
32.768K
Hz

CRYSTAL 32.768KHZ 
12.5PF SMD

ECS Inc ECS-.327-12.5-34B

15 1 Y2 24MHz
CRYSTAL 24.000 MHZ 
8PF SMD

ECS Inc ECS-240-8-36CKM

16 1 LBL -

LBL, PCA Label, Vendor 
Code, Datecode, Serial 
Number 121-60159-01 Rev 
04 (YYWWVVXXXXX)

Cypress qualified 
vendor 

-

No Load components

17 1 C13 1.2 pF
CAP CER 1.2PF 50V NP0 
0402

Johanson Technol-
ogy Inc

500R07S1R2BV4T

18 1 C25 100pF
CAP CER 100PF 50V 10% 
X7R 0603

Kemet C0603C101K5RACTU

19 1 R1
Zero 
Ohm

RES 0.0 OHM 1/10W 
JUMP 0603

TE Connectivity 1623094-1

20 1 R2 Rbleed No Load - -
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21 1 R3 4.7K
RES 4.7K OHM 1/10W 5% 
0603 SMD

Panasonic - ECG ERJ-3GEYJ472V

22 1 J3
4 
HEADER

CONN HEADER 4POS 
.100 R/A 15AU

FCI 68016-204HLF

23 4 TP1,TP2,TP3,TP4 RED
TEST POINT 43 HOLE 65 
PLATED RED

Keystone Electron-
ics

5000

24 1 TP5 BLACK
TEST POINT 43 HOLE 65 
PLATED BLACK

Keystone Electron-
ics

5001

Item Qty Reference Value Description Manufacturer Mfr Part Number



CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit Guide, Doc. # 001-93731 Rev. *A 192

A.3.3 Dongle

Item Qty Reference Value Description Manufacturer Mfr Part Number

1 1 600-60197-01 -

PCB, 60 mm x 30 mm, 
High Tg, ENIG finish, 2 
layer, Color = BLACK, 
Silk = WHITE.

Cypress qualified 
vendor 

600-60197-01 Rev02

2 17

C1,C4,C6,C7,C9,C11
,C14,C16,C25,C28,C
29,C32,C35,C36,C38
,C41,C42

0.1 uFd
CAP .1UF 16V 
CERAMIC Y5V 0402

TDK Corporation C1005X5R1A104K050BA

3 17

C2,C3,C5,C8,C10,C
12,C13,C15,C17,C18
,C24,C26,C30,C31,C
33,C34,C40

1.0 uFd
CAP CERAMIC 1.0UF 
25V X5R 0603 10%

Taiyo Yuden TMK107BJ105KA-T

4 1 C19 1.2 pFd
CAP CER 1.2PF 50V 
NP0 0402

Johanson Technol-
ogy Inc

500R07S1R2BV4T

5 1 C22 36 pF
CAP CER 36PF 50V 5% 
NP0 0402

Murata Electronics GRM1555C1H360JA01D

6 1 C23 18 pF
CAP CER 18PF 50V 1% 
NP0 0402

Murata Electronics GRM1555C1H180FA01D

7 1 C39 0.01 uFd
CAP 10000PF 16V 
CERAMIC 0402 SMD

TDK Corporation C1005X7R1C103K050BA

8 3 D1,D2,D3
ESD 
diode

SUPPRESSOR ESD 
5VDC 0603 SMD

Bourns Inc. CG0603MLC-05LE

9 1 F1 FUSE
PTC RESETTABLE 
.50A 15V 1812

Bourns MF-MSMF050-2

10 1 J1
USB A 
PLUG

CONN PLUG USB 
4POS RT ANG PCB

Molex Inc 480370001

11 1 J2
50MIL 
KEYED 
SMD

CONN HEADER 10POS 
DUAL SHRD SMD

FCI 20021521-00010T1LF

12 1 LED1
Status 
LED Blue

LED BLUE CLEAR 
THIN 0805 SMD

LiteOn Inc LTST-C171TBKT

13 1 LED2
Status 
LED 
Green

LED GREEN CLEAR 
0805 SMD

Chicago Miniature CMD17-21VGC/TR8

14 1 LED3
Power 
LED Red

LED SUPER RED 
CLEAR 0805 SMD

LiteOn Inc LTST-C170KRKT

15 1 L1 5.1 nH
CER INDUCTOR 5.1NH 
0402

Johanson Technol-
ogy Inc

L-07C5N1SV6T

16 2 R8,R11
Zero 
Ohm

RES 0.0 OHM 1/8W 
0805 SMD

Panasonic-ECG ERJ-6GEY0R00V

17 1 R7 820 ohm
RES 820 OHM 1/10W 
5% 0603 SMD

Panasonic - ECG ERJ-3GEYJ821V

18 2 R22,R25 820 ohm
RES 820 OHM 1/8W 5% 
0805 SMD

Panasonic - ECG ERJ-6GEYJ821V

19 2 R9,R10 2.2K
RES 2.2K OHM 1/10W 
5% 0603 SMD

Panasonic - ECG ERJ-3GEYJ222V
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20 9
R1,R2,R3,R4,R12,R
13,R14,R15,R26

ZERO
RES 0.0 OHM 1/10W 
0603 SMD

Panasonic - ECG ERJ-3GEY0R00V

21 2 R17,R18 22E
RES 22 OHM 1/10W 1% 
0603 SMD

Panasonic - ECG ERJ-3EKF22R0V

22 1 R21 100K
RES 100K OHM 1/10W 
5% 0402 SMD

Panasonic - ECG ERJ-2GEJ104X

23 2 R19,R20 15K
RES 15K OHM 1/10W 
5% 0603 SMD

Panasonic - ECG ERJ-3GEYJ153V

24 2 R23,R24 30K
RES 30K OHM 1/10W 
5% 0603 SMD

Panasonic - ECG ERJ-3GEYJ303V

25 2 SW1,SW2
SW RA 
PUSH

SWITCH TACTILE 
SPST-NO 0.05A 12V

Panasonic - ECG EVQ-P3401P

26 1 TVS1 5V 350W
TVS UNIDIR 350W 5V 
SOD-323

Diodes Inc. SD05-7

27 1 U1
PRoC 
BLE

PRoC BLE, Programma-
ble Radio on Chip, 
56QFN

Cypress Semiconduc-
tor

CYBL10162-56LQXI

28 1 U2
DUAL 
PMOS

MOSFET 2P-CH 20V 
430MA SOT-563

ON Semiconductor NTZD3152PT1G

29 1 U3
PSoC 
5LP 

PSoC 5LP Programma-
ble System on Chip, 
68QFN

Cypress Semiconduc-
tor

CY8C5868LTI-LP039

30 1 Y1
32.768K
Hz

CRYSTAL 32.768KHZ 
12.5PF SMD

ECS Inc ECS-.327-12.5-34B

31 1 Y2 24MHz
CRYSTAL 24.000 MHZ 
8PF SMD

ECS Inc ECS-240-8-36CKM

32 1 N/A N/A

LBL, PCA Label, Ven-
dor Code, Datecode, 
Serial Number 121-
60161-01 Rev 03 (YYW-
WVVXXXXX); Only bar-
code

Cypress qualified 
vendor 

-

No load components

33 1 C20 1.2 pF
CAP CER 1.2PF 50V 
NP0 0402

Johanson Technol-
ogy Inc

500R07S1R2BV4T

34 1 C21 100pF
CAP CER 100PF 50V 
10% X7R 0603

Kemet C0603C101K5RACTU

35 1 C37 0.1 uFd
CAP .1UF 16V 
CERAMIC Y5V 0402

TDK Corporation C1005X5R1A104K050BA

36 1 C27 1.0 uFd
CAP CERAMIC 1.0UF 
25V X5R 0603 10%

Taiyo Yuden TMK107BJ105KA-T

37 1 R5
Zero 
Ohm

RES 0.0 OHM 1/10W 
JUMP 0603

TE Connectivity 1623094-1

38 2 R6,R16 4.7K
RES 4.7K OHM 1/10W 
5% 0603 SMD

Panasonic - ECG ERJ-3GEYJ472V

39 15

TP1,TP2,TP3,TP4,T
P5,TP6,TP7,TP8,TP
9,TP10,TP11,TP12,T
P13,TP14,TP15

No load No load - -

Item Qty Reference Value Description Manufacturer Mfr Part Number
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A.4 KitProg Status LED States

User Indication Scenario Action Required by user

1
LED blinks fast:

Time period = 0.25 s
LED starts blinking at power up, 
if bootloadable file is corrupt.

Bootload the KitProg.cyacd file: in PSoC Programmer, con-
nect to the kit, open the Utilities tab and press Upgrade 
Firmware button.

2
LED blinks slow:

Time period = 1.50 s

Entered Bootloader mode by 
holding the PSoC 4 Reset button 
during kit power-up.

Release the Reset button and re-plug power if you entered 
this mode by mistake. If the mode entry was intentional, 
bootload the new.cyacd file using the Bootloader Host tool 
shipped with PSoC Creator.

3
LED blinks very fast:

Time period = 0.67 s

SWD operation is in progress.

Any I2C traffic.

Kit's COM port connect/discon-
nect event (one blink).

In PSoC Programmer, watch the log window for status mes-
sages for SWD operations. In the Bridge Control Panel, the 
LED blinks on I2C command requests. In BCP or any other 
serial port terminal program, distinguish the kit's COM port 
number by the blinking LED when the port is connected or 
disconnected.

4 LED is ON.
USB enumeration successful. 

Kit is in the idle state waiting for 
commands.

The kit functions can be used by PSoC Creator, PSoC Pro-
grammer, Bridge Control Panel, and any serial port terminal 
program.

5 LED is OFF. Power LED is ON.

This means that the USB enumeration was unsuccessful. 
This can happen if the kit is not powered from the USB host 
or the kit is not connected to the USB host through the USB 
cable. Verify the USB cable and check if PSoC Programmer 
is installed on the PC.
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A.5 Adding BLE module compatible headers on your own baseboard

The baseboard should have two headers, one 20-pin and another 24-pin. Dimension of these
connects are detailed below. 

You can get these at Digikey. 

# Description Manufacturer Mfr Part Number Digikey part #

1 CONN HEADER 2.54MM 

24POS GOLD

Sullins Connector 

Solutions

SBH11‐PBPC‐D12‐ST‐BK SBH11‐PBPC‐D12‐ST‐BK‐ND

2 CONN HEADER 2.54MM 

20POS GOLD

Sullins Connector 

Solutions

SBH11‐PBPC‐D10‐ST‐BK S9172‐ND

940 mils

740 mils

Pin 1

Pin 1

20 pin header 

24 pin header 

http://www.digikey.com/product-search/en?x=12&y=21&lang=en&site=us&keywords=SBH11-PBPC-D12-ST-BK
http://www.digikey.com/product-search/en?KeyWords=SBH11-PBPC-D10-ST-BK&WT.z_header=search_go
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