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Build and Debug Environment Setup — IAR

This document illustrates how to build Realtek low power Wi-Fi software under IAR SDK
environmen t.
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1. Introduction

This document illustrates how to build Realtek low power Wi-Fi software under IAR SDK
environment.

2.How to get IAR

IAR provides an IDE environment for code building, downloading, and debugging. Please check
“IAR Embedded Workbench” on http://www.iar.com/, and trail version is available. It requires IAR
version greater than v7.20 which supports CMSIS-DAP.

3.Debugger Setting

This board supports both CMSIS-DAP debugger and J-Link.

3.2 CMSIS-DAP

Ameba Device Board 2V0 supports CMSIS-DAP debugger. It requires installing “serial to USB driver”
at first. Serial to USB driver can be found in tools\serial_to_usb\mbedWinSerial_16466.

)

Connect board to the PC with micro-USB cable.
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After installation, connect the board to PC, and then there should be mbed Serial Port shown in
Device Manager.

3.2J)-Link/JTAG

The board is configured as CMSIS-DAP mode. To use J-Link debugger, please follow the next
procedures.

Hardware Configuration
Weld JTAG and log UART connectors to HDK board and connect with pitch 2.54mm 2x5pins
connector. It is recommended to weld the connector on the bottom side.

20141230 cc_ken
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2.54mm 2x5pins connector (or use Dupont Line)

IAR Setting
Change setting of IAR project from CMSIS-DAP to J-Link/J-Trace in

Project—>Options—>Debugger—>Setup-> Driver, and Selecting OK to finish and enjoy JTAG
debugging.
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Power On
Holding button (red-circled) then plugging power to disable CMSIS-DAP function. Release the

button after power on.

O

Note: To reset main chip, it is recommended to press Reset button (green-circled) instead of
re-plugged in the power cable.

2015-07-21



S:2f REALTEK UMO023

4.How to build and download code

Step 1: Open IAR Workbench
Step 2: To open project, click File > Open = Workspace
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Step 3: Select Project.eww in project\project_name_xxxx\EWARM-RELEASE
Step 4: To build project, click Project = Rebuild All
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Step 5: To download code, Click Project > Download = Download active application.
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After firmware download, click reset button to reboot the system
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How to debug
Set Break point. To debug or trace code step by step, click Project > Download and Debug.
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5.How to use sample code

There are several peripheral example code under folder “project\project_name_xxxx\
example_sources \”, you can copy & paste the example’s “inc” and “src” to project folder.

Ex. To use i2c example code, you can copy “src” and “inc” from
“project\project_name_xxxx\example_sources\i2c\”.
| project
) realtek_amebal_.al_evemp'e_cap

, EWARM-RELEASE

. example_sources
. gpio
| gpio_irg
| i2c
| pwm
| sp COPY
J uart

, uart_irg

 wlan

m

Ameba API follows mbed API. User can check mbed website for peripheral API.
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6. Warning

6.1 Federal Communication Commission Interference Statement

This equipment has been tested and found to comply with the limits for a Class B digital
device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable
protection against harmful interference in a residential installation. This equipment generates,
uses and can radiate radio frequency energy and, if not installed and used in accordance with the
instructions, may cause harmful interference to radio communications. However, there is no
guarantee that interference will not occur in a particular installation. If this equipment does
cause harmful interference to radio or television reception, which can be determined by turning
the equipment off and on, the user is encouraged to try to correct the interference by one of the
following measures:

- Reorient or relocate the receiving antenna.

- Increase the separation between the equipment and receiver.

- Connect the equipment into an outlet on a circuit different from that
to which the receiver is connected.

- Consult the dealer or an experienced radio/TV technician for help.

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two
conditions: (1) This device may not cause harmful interference, and (2) this device must accept any
interference received, including interference that may cause undesired operation.

FCC Caution: Any changes or modifications not expressly approved by the party responsible for
compliance could void the user's authority to operate this equipment.

IMPORTANT NOTE:

FCC Radiation Exposure Statement:

This equipment complies with FCC radiation exposure limits set forth for an uncontrolled
environment. This equipment should be installed and operated with minimum distance 20cm
between the radiator & your body.

IEEE 802.11b or 802.11g operation of this product in the U.S.A. is firmware-limited to channels 1
through 13.

This device and its antenna(s) must not be co-located with any other transmitters except in
accordance with FCC multi-transmitter product procedures.

Refering to the multi-transmitter policy, multiple-transmitter(s) and module(s) can be operated
simultaneously without C2PC.

This module is intended for OEM integrator. The OEM integrator is responsible for the compliance
to all the rules that apply to the product into which this certified RF module is integrated.

Additional testing and certification may be necessary when multiple modules are used.

USERS MANUAL OF THE END PRODUCT:
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In the users manual of the end product, the end user has to be informed to keep at least 20cm
separation with the antenna while this end product is installed and operated. The end user has to
be informed that the FCC radio-frequency exposure guidelines for an uncontrolled environment
can be satisfied. The end user has to also be informed that any changes or modifications not
expressly approved by the manufacturer could void the user's authority to operate this equipment.
If the size of the end product is smaller than 8x10cm, then additional FCC part 15.19 statement is
required to be available in the users manual: This device complies with Part 15 of FCC rules.
Operation is subject to the following two conditions: (1) this device may not cause harmful
interference and (2) this device must accept any interference received, including interference that
may cause undesired operation.

LABEL OF THE END PRODUCT:

The final end product must be labeled in a visible area with the following " Contains TX FCC ID:
TX2-RTL8711AM ". If the size of the end product is larger than 8x10cm, then the following FCC part
15.19 statement has to also be available on the label: This device complies with Part 15 of FCC
rules. Operation is subject to the following two conditions: (1) this device may not cause harmful
interference and (2) this device must accept any interference received, including interference that
may cause undesired operation.

6.2 Industry Canada Statement

This device complies with Industry Canada license-exempt RSS standard(s). Operation is
subject to the following two conditions:
1) this device may not cause interference and
2) this device must accept any interference, including interference that may cause undesired
operation of the device

French translation:

Ce dispositif est conforme aux CNR d'IndustrieCanada applicable aux appareils radio exempts de
licence. Son fonctionnement est sujet aux deux conditions suivantes: (1) le dispositif ne doit pas
produire de brouillage préjudiciable, et (2) ce dispositif doit accepter tout brouillage recu, y
compris un brouillage susceptible de provoquer un fonctionnement indésirable.

This device has been designed to operate with an antenna having a maximum gain of 3.5dBi.
Antenna having a higher gain is strictly prohibited per regulations of Industry Canada. The
required antenna impedance is 50 ohms.
To reduce potential radio interference to other users, the antenna type and its gain should be so
chosen that the EIRP is not more than required for successful communication.
This module is intended for OEM integrator. The OEM integrator is responsible for the compliance
to all the rules that apply to the product into which this certified RF module is integrated.
Additional testing and certification may be necessary when multiple modules are used.

French translation:

Ce dispositif a été concu pour fonctionner avec une antenne ayant un gain maximum de 3.5 dBi.
Une antenne a gain plus élevé est strictement interdite par les reglements d'Industrie Canada.
L'impédance d'antenne requise est de 50 ohms.

Conformément 3 la réglementation d'Industrie Canada, le présent émetteur radio
peutfonctionner avec une antenne d'un type et d'un gain maximal (ou inférieur) approuvé
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pourl'émetteur par Industrie Canada. Dans le but de réduire les risques de brouillage
radioélectriqued l'intention des autres utilisateurs, il faut choisir le type d'antenne et son gain de
sorte que lapuissance isotrope rayonnée équivalente (p.i.r.e.) ne dépasse pas l'intensité nécessaire
al'établissement d'une communication satisfaisante.

IMPORTANT NOTE:

IC Radiation Exposure Statement:
This equipment complies with IC radiation exposure limits set forth for an uncontrolled
environment. This equipment should be installed and operated with minimum distance 20cm
between the radiator & your body.

French translation:

NOTE IMPORTANTE: (Pour I'utilisation de dispositifs mobiles)

Déclaration d'exposition aux radiations:

Cet équipement est conforme aux limites d'exposition aux rayonnements IC établies pour un
environnement non contrélé. Cet équipement doit étre installé et utilisé avec un minimum de
20 cm de distance entre la source de rayonnement et votre corps.

For product available in the Canada market, only channel 1~11 can be operated. Selection of
other channels is not possible.

French translation:

Pour les produits disponibles aux Canada du marché, seul le canal 1 a 11 peuvent étre
exploités. Sélection d'autres canaux n'est pas possible.

This device and its antenna(s) must not be co-located with any other transmitters except in
accordance with IC multi-transmitter product procedures.

Refering to the multi-transmitter policy, multiple-transmitter(s) and module(s) can be
operated simultaneously without reassessment permissive change.

Cet appareil et son antenne (s) ne doit pas étre co-localisés ou fonctionnement en association
avec une autre antenne ou transmetteur.

USERS MANUAL OF THE END PRODUCT:

In the users manual of the end product, the end user has to be informed to keep at least
20cm separation with the antenna while this end product is installed and operated. The end
user has to be informed that the IC radio-frequency exposure guidelines for an uncontrolled
environment can be satisfied. The end user has to also be informed that any changes or
modifications not expressly approved by the manufacturer could void the user's authority to
operate this equipment. Operation is subject to the following two conditions: (1) this device
may not cause harmful interference and (2) this device must accept any interference received,
including interference that may cause undesired operation.

LABEL OF THE END PRODUCT:

The final end product must be labeled in a visible area with the following " Contains TX IC :
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6317A-RTL8711AM ".

This radio transmitter (IC: 6317A-RTL8711AM) has been approved by Industry Canada to
operate with the antenna types listed below with the maximum permissible gain and required
antenna impedance for each antenna type indicated. Antenna types not included in this list,
having a gain greater than the maximum gain indicated for that type, are strictly prohibited
for use with this device.

French translation:

Le présent émetteur radio (IC: 6317A-RTL8711AM) a été approuvé par Industrie Canada pour
fonctionner avec les types d'antenne énumeérés ci-dessous et ayant un gain admissible
maximal et lI'impédance requise pour chaque type d'antenne. Les types d'antenne non inclus
dans cette liste, ou dont le gain est supérieur au gain maximal indiqué, sont strictement
interdits pour I'exploitation de I'émetteur.

The following antenna type and max. gain be used and approved for the module:
1) Dipole antenna, max. gain: 3dBi

2) PIFA antenna, max. gain: 3.5dBi

3) Printed antenna, max. gain: 2dBi
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6.4 Japan Statement

Host system must be labeled with "Contains MIC ID:xxxx“, MIC ID displayed on label
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