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General 
Information
WaferSense Teaching Wafer and Link

Changes or modifications not expressly approved by CyberOptics Semiconductor, Inc., may 
void your authority to operate the WaferSense ATS.

The radio contained in the WaferSense ATS meets all the applicable FCC requirements for RF 
Safety. While in operation, the FCC requires users and nearby persons to maintain a minimum 
separation distance of 20 cm (8 inches) or farther from the WaferSense ATS.
The WaferSense Teaching Wafer and Link have been tested and found to comply with the 
limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. These limits are 
designed to provide reasonable protection against harmful interference in a residential 
installation. This equipment generates, uses and can radiate radio frequency energy and, if not 
installed and used in accordance with the instructions, may cause harmful interference to radio 
communications. However, there is no guarantee that interference will not occur in a particular 
installation. If this equipment does cause harmful interference to radio or television reception, 
which can be determined by turning the equipment off and on, the user is encouraged to try to 
correct the interference by one or more of the following measures:

• Reorient or relocate the receiving antenna.
• Increase the separation between the equipment and receiver.
• Connect the equipment into an outlet on a circuit different from that to which the 

receiver is connected.
• Consult the dealer or an experienced radio/TV technician for help.

This device complies with part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) 
This device may not cause harmful interference, and (2) this device must accept any interference received, including 
interference that may cause undesired operation.

This ISM device complies with Canadian ICES-001.

Cet appareil ISM est conforme à la norme NMB-001 du Canada.  
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WaferSense Technical Support

Technical support is available from CyberOptics Semiconductor Monday through Friday, 
8:00 A.M. to 5:00 P.M. Pacific Time.

WaferSense, TeachView, and TeachTarget are trademarks of CyberOptics Semiconductor, Inc.

Third-party brands and names are the property of their respective owners.

Copyright © 2006 - 2007, CyberOptics Semiconductor, Inc. All rights reserved.

CyberOptics Semiconductor, Inc.
13555 S.W. Millikan Way
Beaverton, OR 97005

P/N 920-0503-01

E-mail: CSsupport@cyberoptics.com

Phone: (503) 495-2200
800-366-9131 (US and Canada only)

Fax: (503) 495-2201
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Chapter 1
Introduction
The CyberOptics Semiconductor WaferSense™ Automatic Teaching System (ATS) measures 
three-dimensional offsets to teach wafer handoff positions. Using machine vision technology, it 
“sees” targets inside semiconductor equipment. The TeachView™ software application makes 
it easy to precisely adjust equipment. The large display and wireless link let you place the 
computer at a convenient distance from the teaching wafer.

ATS consists of the following components:
• Teaching wafer. The ATS is designed with a wafer-like form factor, so it can fit in 

most wafer-handling equipment. The teaching wafer is also vacuum compatible.
• TeachView and TeachTarget™ software. The TeachView software application 

monitors the teaching wafer and displays X, Y, and Z offsets and other status 
information in real time. TeachTarget creates target configuration files needed by 
TeachView. Both applications run on most personal computers that use the 
Microsoft Windows operating system.

• Wireless link. The software communicates with the teaching wafer by using a 
Bluetooth wireless link that attaches to a USB port on a personal computer. 

• Charging clean box. The teaching wafer is powered by an internal rechargeable 
battery, which you recharge by placing the teaching wafer into the charging clean box.

• Carrying case. The carrying case makes it easy to take your complete ATS system 
with you in the plant or on the road.

The following chapter gives you instructions for installing your ATS system.
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Chapter 2
Installing Your ATS
This chapter describes the procedures you need to perform to install your ATS and get it ready 
for use. For best results, perform the procedures in the order they are presented in this chapter:

1. Installing the software
2. Installing the wireless link on the USB port
3. Checking communications between the link and the teaching wafer
4. Registering your teaching wafer
5. Running the TeachView application

Installing the Software
To run the WaferSense ATS software, your computer must have the following: 

• Windows 2000, Windows XP, or Windows Vista operating system
• One free high-power USB 1.1 or USB 2.0 port

To install the WaferSense ATS software:

1. Log on using an account with Administrator privileges.

Caution
Dropping the teaching wafer or hitting it against a hard object can bend, break, or chip
the housing; damage the internal components; or knock the teaching wafer out of
calibration. While it is not as fragile as an actual silicon wafer, handle the teaching wafer
with care, as you would any precision instrument. If the teaching wafer is damaged or in
need of calibration, see Chapter 5, “Maintaining Your ATS.”
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Chapter 2. Installing Your ATS
2. Insert the WaferSense ATS Installation Disk into the CD drive.
The InstallShield Wizard starts automatically, as shown in Figure 2.1. If the wizard doesn’t 
start automatically, use Windows Explorer to view the contents of the CD and double-
click the setup.exe program. 

Figure 2.1: The InstallShield Wizard
3. Follow the instructions provided by the wizard to install the software.
4. After you complete the instructions for all of the wizard screens, click Finish. If 

Windows notifies you that the drivers have not passed Windows logo testing, just click 
Continue Anyway to complete the installation.

By default, the Setup program installs the TeachView and TeachTarget applications in a new 
program group called WaferSense ATS. Setup also installs an online copy of this user’s guide, 
which is available from the TeachView and TeachTarget Help menus and in the WaferSense 
ATS program group in the Windows Start menu.
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Chapter 2. Installing Your ATS
Installing the Wireless Link
To install the wireless link:

1. Turn on your computer.
2. Locate an unused, high-power USB port on your computer. The ATS wireless link 

module requires a high-power USB port, such as the built-in ports on your computer and 
ports on USB hubs that have power cords. Unpowered USB hubs won’t work.

3. The USB cable provided with your ATS has a different plug on each end. Locate the end 
with the plug that matches the USB port on your computer and plug the cable into 
the port.

4. Plug the other end of the cable into the link module. 
The Windows operating system recognizes the new link module hardware and displays 
the Found New Hardware Wizard, as shown in Figure 2.2. If the wizard your system 
displays doesn’t offer to check with Windows Update, skip to step 6. 

Figure 2.2: Found New Hardware Wizard
5. Choose No, not this time and click Next.
2.3



Chapter 2. Installing Your ATS
The wizard offers to help you install software for the CyberOptics WaferSense link 
device, as shown in Figure 2.3. 

Figure 2.3: Installing the WaferLink Device
6. Choose Install the software automatically and click Next.

If you already installed the WaferSense ATS software (see “Installing the Software,” on 
page 2.1), Windows will automatically find the drivers. If not, the drivers are located in the 
Utilities folder on the installation CD-ROM.

7. After you complete the instructions for all of the wizard screens, click Finish.
The Power light on the module turns on indicating that the module is getting power from 
the USB port. Ignore the Pair Status and Connection Status lights for now.
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Chapter 2. Installing Your ATS
Checking Communications Between the Link 
and the Wafer

To complete the installation, verify that the teaching wafer and link can communicate:

1. The teaching wafer operates from an internal rechargeable battery. Before using the 
teaching wafer for the first time, charge it for two hours. For information on checking the 
charge on the battery and the procedure for recharging, see “Using the Rechargeable 
Battery,” on page 3.17.

2. Remove the teaching wafer from the charging clean box and press the ON OFF button 
to turn on the teaching wafer.
The On light on the teaching wafer turns on.

3. Verify that the Pair Status lights on both the teaching wafer and link module are on. If 
either light is not on, your teaching wafer and link might not be paired with each other. To 
reset the pairing, see “Changing the Pairing Between the Teaching Wafer and Link,” on 
page 3.19. 

4. Immediately after turning on the teaching wafer, the Connection Status lights on the 
teaching wafer and link will blink slowly. After a few seconds the teaching wafer and link 
will connect and both lights will be on and no longer blinking. If the lights continue to 
blink, see “Monitoring the Wireless Connection to the Teaching Wafer,” on page 3.18.

5. After starting the TeachView application (see “Running the TeachView Application,” on 
page 2.7), you can verify the connection to the teaching wafer by comparing the serial 
number printed on the teaching wafer to the serial number shown in the About Your ATS 
Wafer dialog, which is available in the TeachView application by choosing the Help > 
About your ATS Wafer menu item.

That completes the installation of your ATS.
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Chapter 2. Installing Your ATS
Registering Your Teaching Wafer for Calibration 
Service

To maintain optimum performance, every twelve months you should have your teaching wafer 
calibrated and the battery replaced. These services can be performed only at the factory.

To help you keep track of the next service date so you can schedule this service when it is 
convenient, register your WaferSense ATS teaching wafer with the factory. When you start the 
TeachView application (see “Running the TeachView Application,” on page 2.7), it prompts 
you to register your teaching wafer for calibration. You can also register your teaching wafer in 
any of the following ways:

• On the Internet: www.CyberopticsSemi.com/ws_register.html
• By phone: 800-366-9131 (US and Canada only)
• By faxing the WaferSense ATS Calibration Registration to: (503) 495-2201
• By sending an e-mail message containing the information specified on the WaferSense 

ATS Calibration Registration to: register@cyberoptics.com.
2.6
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Chapter 2. Installing Your ATS
Running the TeachView Application
To start the TeachView application:

1. From the Windows Start > All Programs menu, choose WaferSense ATS > 
TeachView.
The TeachView application starts, as shown in Figure 2.4. Initializing communications 
usually takes less than a second. For information on using TeachView, see Chapter 3, 
“Using Your ATS.” If you haven’t registered your teaching wafer, TeachView also displays 
the Calibration Registration dialog. To complete the registration, proceed to the next step.

Figure 2.4: Starting the TeachView Application
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Chapter 2. Installing Your ATS
2. If TeachView displays the WaferSense ATS Calibration Registration dialog, as shown in 
Figure 2.5, you haven’t registered your teaching wafer. Follow the instructions in the 
dialog to complete the registration.
 

Figure 2.5: Calibration Registration Dialog
The TeachTarget application is described in Chapter 4, “Creating Target Configuration Files.”
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Technical Support
CyberOptics Semiconductor offers free technical support to customers. If the ATS hardware or 
software appear to be malfunctioning, please contact us, and we’ll be happy to assist you.

When you contact us, please make sure that you have the following information available:
• A detailed description of the problem you are having, including the exact text of any 

error messages and a list of steps to reproduce the problem.
• Information about your computer, including manufacturer, CPU type, version of 

Windows, and memory size.
• The version of the TeachView application. The software version is available in the 

TeachView application by choosing the Help > About TeachView menu item.

Figure 2.6: The About TeachView Dialog
If you are using TeachTarget, a similar dialog is available from the Help > About 
TeachTarget menu item.

• The serial number of your teaching wafer. The serial number of the teaching wafer is 
printed on a label on the top of the teaching wafer. The serial number is also available 
in the TeachView application by choosing the Help > About your ATS Wafer menu 
item.

Figure 2.7: The About your ATS Wafer Dialog
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Chapter 2. Installing Your ATS
Technical support is available Monday through Friday, 8:00 A.M. to 5:00 P.M. Pacific Time.
• Voice: (503) 495-2200
• Toll free: 800-366-9131 (US and Canada only)
• Fax: (503) 495-2201
• E-mail: CSsupport@cyberoptics.com
• Internet: www.CyberopticsSemi.com
2.10
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Chapter 3
Using Your ATS
This chapter gives you instructions for performing the following tasks with the ATS:

• Using the ATS teaching wafer buttons and indicators
• Performing a basic target measurement
• Using the target overlay
• Using find once and continuous find
• Setting the target criteria for measurements
• Logging your readings
• Printing the TeachView window
• Monitoring the operating temperature
• Using the rechargeable battery
• Monitoring the connection between the teaching wafer and link module
• Changing the pairing between the teaching wafer and link module.
• Saving your settings
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Using the ATS Teaching Wafer Buttons and 
Status Lights

ATS teaching wafers have two buttons:
• ON OFF. Turns the teaching wafer on and off. 
• NEW PAIR. Changes the pairing between a teaching wafer and a link (see “Changing 

the Pairing Between the Teaching Wafer and Link,” on page 3.19).

ATS teaching wafers also have the following status lights:
• On. Glows red while the teaching wafer is turned on. 
• Charging. Glows red when the teaching wafer is being charged in the charging case.
• Charging Done. Glows red when the battery has reached at least 90% of full charge.
• Connection Status. Glows red when the teaching wafer has established 

communication with the link. Blinks slowly while the teaching wafer is trying to 
establish a connection with the link.

• Pair Status. Glows red when the teaching wafer is paired with a link (see “Changing 
the Pairing Between the Teaching Wafer and Link,” on page 3.19). 
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Chapter 3. Using Your ATS
Finding a Target
The camera in the teaching wafer captures live video from within the semiconductor process 
equipment. An image processor in the wafer reports the coordinates (X, Y, Z) of the teaching 
wafer in relation to a target on the equipment. When you tell ATS to find the target, the 
TeachView application displays the coordinates.

In the video image displayed in TeachView, the center of the field of view for the teaching 
wafer is indicated by red cross hairs that span the length and width of the video image 
(see Figure 3.1). A red circle is centered on the cross hairs and serves as a sight ring for aligning 
the target image. When the target is within the sight ring, the equipment is aligned within the 
specified tolerances. For more information on setting tolerances, see “Setting the Target 
Criteria,” on page 3.10. 

Figure 3.1: The TeachView Application

TargetLive video
image

Sight ring
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Chapter 3. Using Your ATS
To find a target:

1. Make sure the computer running the TeachView application is within the range of the 
link module, up to 30 ft (10 m).

2. Place the teaching wafer on the equipment you want to check. Align the teaching wafer so 
it matches the TeachView display by rotating the wafer until the WaferSense™ ATS logo 
is right-side up and level as you face the wafer, as shown in Figure 3.2.

Figure 3.2: Aligning the Teaching Wafer
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Chapter 3. Using Your ATS
3. From the Target configuration list (see Figure 3.3), choose the appropriate target 
configuration file for the equipment you are working on. If the file isn’t shown in the list, 
choose Select, which is always the last entry in the Target configuration list, or choose 
the menu item File > Select Target Configuration File to locate the file. If you don’t 
choose a target configuration file, ATS can’t search for the target, and the Find Once 
button and Continuous find box are disabled. For information on creating target 
configuration files, see “Creating Target Configuration Files,” on page 4.1.

Figure 3.3: Target Configuration List
4. Click Find Once (see Figure 3.4).

After a few seconds, the teaching wafer finds the target and sends the information to the 
TeachView application. TeachView displays the measurements in numeric readouts (see 
Figure 3.4). 

Figure 3.4: Numeric Readouts
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Chapter 3. Using Your ATS
All measurements are in millimeters. Readings outside the working range of the teaching wafer 
are displayed as ####. If the readings display None, ATS was not successful in finding the 
target. This can be caused by the following:

• Target too far off center. The farther the target is initially from the center of the 
field of view of the teaching wafer, the harder it is for ATS to find the target. Move 
the teaching wafer so that the target appears closer to the sight ring and try finding 
the target again. If you are having trouble seeing the target in the video image, you can 
adjust the image by choosing the menu item Settings > Optimize Lighting.

• Target criteria. You might not have the target criteria set correctly. For more 
information, see “Setting the Target Criteria,” on page 3.10. In particular, verify that 
the Z distance you have specified in the target criteria is within 1 mm of the Z 
distance used to create the target configuration file. The acceptable range for the Z 
distance is displayed in the Set Target Criteria dialog (see Figure 3.7 on page 3.11).

• Wafer to target distance. You might have the teaching wafer too close or too far 
from the target. The distance from the bottom of the teaching wafer to the target 
should be within 1 mm of the Z distance used to create the target configuration file. 
The acceptable range for the Z distance is displayed in the Set Target Criteria dialog 
(see Figure 3.7 on page 3.11).

• Target configuration file. You chose the wrong target configuration file or the 
target configuration file is not correct. Verify that you are using the correct file. For 
more information on target configuration files, see “Creating Target Configuration 
Files,” on page 4.1.

You can use these X, Y, and Z measurements to adjust the equipment to center the target in the 
sight ring. 
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5. Adjust the equipment and click Find Once again. Repeat this process until the target is 
centered in the sight ring, and the X and Y values are zero or close enough 
(see Figure 3.5).

Figure 3.5: Target Centered in the Sight Ring
You can resize the TeachView window to make the video image larger or smaller. The numeric 
readouts and other controls don’t change size when you change the size of the TeachView 
window.

For information on the accuracy of the readings, see “Range and Accuracy,” on page 6.1.
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Using the Target Overlay
A target overlay feature lets you verify that the ATS has correctly identified the target. 

To activate the target overlay:
• Check Display target overlay below the numeric readouts. The target overlay 

appears as a circle with cross hairs, as shown in Figure 3.6.

Figure 3.6: Target Overlay
The target overlay should be centered on the image of the target, as shown in Figure 3.6. The 
target overlay changes from yellow to green when the target is centered in the sight ring to 
within the specified tolerances and the Z target distance is within tolerance (see “Setting the 
Target Criteria,” on page 3.10). After you instruct the ATS to find the target, if the overlay is 
not centered on the target, the ATS is not correctly recognizing the target. If the target doesn't 
overlay the feature in the image, check the following:

• Video stopped. Maker sure the wafer is still sending live video. You can do this by 
moving the wafer a small amount and watching the video image. If the video isn’t 
tracking the movement, turn off the wafer and then turn it back on.

• Target too far off center. The farther the target is initially from the center of the 
field of view of the teaching wafer, the harder it is for ATS to find the target. Move 
the teaching wafer so that the target appears closer to the sight ring and try finding 
the target again. If you are having trouble seeing the target in the video image, you can 
adjust the image by choosing the menu item Settings > Optimize Lighting.

Target
overlay
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Chapter 3. Using Your ATS
• Target criteria. You might not have the target criteria set correctly. For more 
information, see “Setting the Target Criteria,” on page 3.10. In particular, verify that 
the Z distance you have specified in the target criteria is within 1 mm of the Z 
distance used to create the target configuration file. The acceptable range for the Z 
distance is displayed in the Set Target Criteria dialog (see Figure 3.7 on page 3.11).

• Wafer to target distance. You might have the teaching wafer too close or too far 
from the target. The distance from the bottom of the teaching wafer to the target 
should be within 1 mm of the Z distance used to create the target configuration file. 
The acceptable range for the Z distance is displayed in the Set Target Criteria dialog 
(see Figure 3.7 on page 3.11).

• Target configuration file. You chose the wrong target configuration file or the 
target configuration file is not correct. Verify that you are using the correct file. 

Using Find Once and Continuous Find
You can instruct the teaching wafer to take a single reading of the target position or to make 
continuous readings.

Note that whether you are taking a single reading or continuous readings, the video image is 
updated continuously.

Taking a Single Reading
As described in “Finding a Target,” on page 3.3, you can use the Find Once button to have the 
ATS make a single measurement of the target coordinates. After the measurement is completed 
and the results are displayed, you can adjust the equipment as needed. 

Taking Continuous Readings
Rather than taking a single measurement, you can have the teaching wafer take continuous 
measurements. When the ATS is in continuous find mode, it sends readings to the TeachView 
application every two to three seconds and the readouts are updated each time new readings are 
received.

To activate continuous find:
• Check the Continuous find box located just above the Find Once button.

Note
In find once mode, when you make adjustments that cause the target to move, the
coordinates displayed in the TeachView window no longer reflect the correct position of
the target. After adjusting the position of the wafer, always click Find Once again to
update the readings.
3.9



Chapter 3. Using Your ATS
While the Continuous find box is checked, the Find Once button is disabled. To cancel 
continuous find, uncheck the box.

Setting the Target Criteria
When you have successfully centered the target within the sight ring, the X and Y coordinates 
will both ideally be zero. In practice, you might not need to have them exactly zero, just close 
enough. You can specify your desired tolerances for the target measurement. As long as you 
position the target within the sight ring, you know that it is centered within your specified 
tolerances.

In addition to specifying tolerances for the X and Y measurements, you can specify a target 
value and tolerance for the Z coordinate. The specified range for Z is 6.4 mm – 45 mm (0.25" – 
1.8"). The target configuration file that TeachView uses to recognize a given target is created 
from an image of the target that was captured at a specific Z value (for more information, see 
“Creating Target Configuration Files,” on page 4.1). When you use a particular target 
configuration file, the teaching wafer will be able to recognize the target more successfully if the 
wafer is at the same Z value that was used to create the target configuration file. Specifying a 
target Z value and tolerance makes it easy to tell when the teaching wafer is at the proper 
height.

You can set separate tolerance values for the X and Y measurements, or you can specify a single 
tolerance value for both measurements.

To specify the target criteria:

1. Choose the menu item Settings > Set Target Criteria.
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The Set Target Criteria dialog is displayed, as shown in Figure 3.7.

Figure 3.7: Set Target Criteria Dialog
2. To specify one tolerance for both X and Y measurements, check the box for x and y the 

same. To specify the tolerance separately for each, uncheck the box. When you check the 
box, the dialog changes to display only one set of tolerance criteria for both X and Y.

3. Fill in the tolerances you want to specify. Tolerances must be entered as positive numbers, 
must be in millimeters, and must be 0.01 mm to 0.5 mm for X and Y, and 0.1 mm 
to1.0 mm for Z.

4. If you don’t want to set a target value for the Z measurement, check the box ignore z 
target value. Otherwise, uncheck the box and fill in your desired value for z target value. 
The value must be within two millimeters of the value specified in the target configuration 
file (the range, Z ± 1 mm, is shown at the bottom of the dialog).

5. Click OK.
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Logging Your Readings
TeachView can keep a record of your activities as you use the teaching wafer to check various 
pieces of equipment. TeachView keeps the record in a log file. You can specify the log file path 
(see “Changing the Log File,” on page 3.15). The log file contains the following information for 
each entry:

• Date and Time. The date and time of the log file entry.
• Target configuration file. Path name for the currently selected target configuration 

file (see “Finding a Target,” on page 3.3).
• X, Y, and Z readings. Measurements for the X, Y, and Z coordinates of the target.
• X, Y, and Z Tolerances. The user-specified tolerance for each coordinate 

measurement (see “Setting the Target Criteria,” on page 3.10).
• Z target value. The user-specified target value for the Z measurement, the height of 

the teaching wafer above the target (see “Setting the Target Criteria,” on page 3.10).
• Tolerance met. Whether the coordinate measurements were within tolerances.
• Z target ignored. Whether the Z value is ignored in deciding if the current readings 

are within tolerance (see “Setting the Target Criteria,” on page 3.10).
• Temperature. The current operating temperature of the teaching wafer in °C (see 

“Monitoring the Operating Temperature,” on page 3.16).
• Battery. The percentage of time remaining before the battery must be recharged (see 

“Using the Rechargeable Battery,” on page 3.17).
• Serial number. The serial number of the teaching wafer.
• Operator, Tool, Station, and Comment. Text fields you can use to record your own 

information with each log entry (see “Including User-Specified Information in the 
Log File,” on page 3.14). 

The remainder of this section tells you how to:
• Log a reading
• Include additional information in a log entry: operator, tool, station, and comment
• Change the pathname for the log file
• Display readings from a log file
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Logging a Reading
TeachView posts entries to the log file on your command.

To post an entry to the log file:
• In the main TeachView window, click Log a Reading (see Figure 3.8).

TeachView immediately writes a log entry each time you click the button.

Figure 3.8: Logging a Reading

Log a Reading button
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Including User-Specified Information in the Log File
Operator, Tool, Station, and Comment are text fields you can use to record your own 
information with each log entry. You can fill in any text information you want in these fields.

To include user-specified information for logging:

1. Choose the Settings > Set Station Information menu item.
The Set Station Information dialog is displayed, as shown in Figure 3.9. 

Figure 3.9: Set Station Information Dialog
2. Type your text into the Operator, Tool, Station, and Comment text fields.
3. Click Apply to accept the changes without closing the dialog. To accept the changes and 

close the dialog, click OK instead.
You can leave the Set Station Information dialog open while using TeachView (drag it off 
to the side, so it doesn’t cover the TeachView window). Doing so makes it easy to change 
the Comment or other fields each time you log a reading, or as needed. Be sure to click 
Apply after you finish making changes, though, or TeachView won’t use the latest 
changes for the next log entry.

You can change or delete this information at any time for future log entries. To quickly clear all 
of the fields, click Clear All.
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Changing the Log File
By default, TeachView writes log entries to the file My Documents\ATS Files\ATS 
Readings.csv. If you prefer, you can specify a different log file. The name of the current log file 
is displayed below the Log a Reading button (see Figure 3.8 on page 3.13).

To change the log file: 

1. Choose the File > Select Log File menu item.
2. In the ATS Log File dialog, specify the folder and file name for the log file, and 

click Save.

Displaying Readings from a Log File
Log files are saved in a comma-separated-values (CSV) text format. The file is read-only to 
avoid accidental data corruption. Files in CSV text format are easy to import into spreadsheet 
and word processing programs. 

Printing the TeachView Window
You can print an image of the TeachView window to have a graphical record of the session. 

To print an image of the TeachView window:

1. Choose File > Print.
2. In the Print dialog, click OK.

You can also select a printer other than the default and change the printer setup, or see a 
preview of what TeachView will print:

• To select a different printer, change the paper selection or print orientation, or set 
printer properties, choose the File > Print Setup menu item. 

• To see a preview of what TeachView will print, choose the File > Print Preview 
menu item.
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Monitoring the Operating Temperature
The operating range for the teaching wafer to achieve the specified accuracy for readings is 
20 °C to 50 °C. The teaching wafer can withstand exposure to 120 °C (5 minutes or less) if not 
in direct contact with the heating element. The Temperature monitor in the ATS wafer status 
area of the TeachView window (see Figure 3.10) shows the current operating temperature of 
the teaching wafer with a numeric readout and a bar graphic. 

Figure 3.10: Temperature Monitoring Gauge
The temperature bar changes color to indicate where the current temperature is relative to the 
accurate operating range:

• Blue. Less than 20 °C; the teaching wafer is operating below the range where it 
produces accurate readings.

• Green. 20 °C to 50 °C; the teaching wafer is operating in its optimum temperature 
range, where it produces readings meeting the specified accuracy.

• Orange. 51 °C to 60 °C; the teaching wafer is operating above the range where it 
produces the most accurate readings, but not so hot that the teaching wafer will be 
damaged.

• Red. Greater than 60 °C; the teaching wafer is operating at a temperature so high that 
it might be damaged.

Warning
51-60 °C

Danger
>60 °C

Low
< 20 °C

Optimum
20-50 °C
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Using the Rechargeable Battery
The teaching wafer operates from an internal rechargeable battery. From a full charge, the 
battery provides about two hours of continuous use. Before using your teaching wafer for the 
first time, charge it for two hours.

The battery can be recharged about 500 times before the charge life starts to degrade 
significantly. The battery is not user replaceable. For information on replacing the battery, see 
“Annual Factory Calibration and Battery Replacement,” on page 5.2.

Battery performance degrades at temperatures outside the optimum operating temperature 
range: 20 °C - 50 °C.

Monitoring the Battery Level
TeachView receives frequent updates from the teaching wafer on the state of the teaching 
wafer’s battery. The Battery indicator in the ATS wafer status area of the TeachView window 
shows the approximate percentage of operating time remaining before you must charge the 
battery. 

Figure 3.11: Battery Monitor

Charging the Battery
To charge the teaching wafer’s battery:

1. Use only the battery charger supplied with your gapping wafer. Using a different battery 
charger might damage your gapping wafer or create a safety hazard.

2. Do not charge the gapping wafer if its internal temperature is higher than 45 °C. Charging 
the gapping wafer at a temperature higher than 45 °C might damage your gapping wafer 
or create a safety hazard.

3. Place the teaching wafer in the charging clean box. Rotate the wafer until the WaferSense 
ATS logo is right side up and approximately level when the hinged edge of the box is 
away from you. Close the lid.
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4. Plug the charger line adapter into a 100 VAC to 240 VAC supply and plug the other end 
into the charging clean box.
The Charging light is on while the teaching wafer is charging. If the Charging light does 
not turn on, make sure the lid of the box is closed completely and the charging pins in the 
charging clean box are making electrical contact with the teaching wafer. 
When you first start charging the wafer, it turns on. After about 10 minutes, if TeachView 
and TeachTarget aren’t running, the wafer will turn off and continue to charge.

5. Charge the teaching wafer until the Charging Done light turns on or until you need to 
use the teaching wafer (you don’t need to wait until the teaching wafer is fully charged).
Fully charging the battery takes about two hours. Charging for one hour charges the 
battery to about 80% of its capacity. You can leave the teaching wafer in the charging case 
when not in use; the battery won’t overcharge. 

Monitoring the Wireless Connection to the 
Teaching Wafer

The TeachView application communicates with the teaching wafer by using a Bluetooth 
wireless link. The wireless link has a range of up to 30 ft (10 m). 

The Connection indicator in the ATS wafer status area of the TeachView window shows the 
quality of the wireless connection between the teaching wafer and the link module. The 
connection quality is indicated by the color of the bar and the wording below the bar (see 
Figure 3.12):

• Green - Connected. The connection between the link and teaching wafer is good. 
With a good connection, the teaching wafer is sending the maximum number of 
readings per second to the link module (about one reading every two to three 
seconds). 

• Yellow - Poor connection. There is some interference or other problem with the 
signal that is preventing the link and teaching wafer from communicating at their 
maximum rate. When the indicator is yellow, the readings are still accurate but aren’t 
being updated as frequently. 
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• Red - No connection. Indicates that there is no connection between the teaching 
wafer and link module. The values in the display do not update when the indicator is 
red. 

Figure 3.12: Wireless Connection Monitor
The Bluetooth wireless link technology used in the ATS is a low-power technology that 
operates in the 2.4 GHz radio frequency band. This unlicensed band is also used by many other 
types of devices, such as cordless phones and microwave ovens. Another 2.4 GHz device 
operating in close proximity could interfere with the ATS system. When this happens, 
separating the devices by at least 6 ft (2 m) usually solves the problem.

Other factors can also affect the wireless link, such as the distance between the teaching wafer 
and link, and obstacles between the teaching wafer and link that block the signal. If TeachView 
indicates that the connection isn’t good, try moving the wireless link module a few feet closer to 
the teaching wafer.

After turning off the teaching wafer, the Connection indicator might not change to red for a 
few seconds.

Changing the Pairing Between the Teaching 
Wafer and Link

Each teaching wafer is paired with a specific link module at the factory and will operate with 
only that particular link module. However, you can change this pairing, so that you can use your 
teaching wafer with a different link module, or vice versa.

To pair a teaching wafer and link module:

1. If you are changing the pairing of a teaching wafer that is already paired with a link 
module, first unplug the currently paired link module. You can’t pair a teaching wafer with 
a new link module while the currently paired link module is powered on.

2. Make sure the Power light is illuminated on the link module you want to pair, and make 
sure the On light is illuminated on the teaching wafer.
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3. On the teaching wafer, press and hold the NEW PAIR button until the Pair Status and 
Connection Status lights start to blink rapidly (about four times per second).

4. On the link module, press and hold the NEW PAIR button until the Pair Status and 
Connection Status lights start to blink rapidly (about four times per second).
The Pair Status and Connection Status lights will continue to blink until the teaching 
wafer and link have established a new pairing, after which the lights will be on and no 
longer blinking.

Saving Your Settings
Each time you exit the TeachView application, it saves your current settings for the log file; X, 
Y, and Z tolerances; Z target value; target overlay; and find state (continuous or find once) in 
the Windows registry. The next time you start TeachView, it restores those saved settings. You 
can also tell TeachView to save your settings to a file you specify, and you can have TeachView 
read those settings back at any time. This lets you have several different configurations for 
TeachView and be able to switch between them easily, without having to reenter the settings.

To save your settings in a file you specify:

1. Choose the File > Save Settings As menu item.
2. In the ATS Settings File dialog, specify the directory and file name and click Save.

TeachView saves your settings, and the file you specified becomes the current settings file.

To save your settings in the current settings file:
• Choose the File > Save Settings menu item.

Each time you start TeachView, the application automatically reads in the most recent settings 
from the Windows registry, including the last settings file you specified, if any. 

Loading Settings from a File
To load settings from a file:

1. Choose the File > Open Settings menu item.
2. In the ATS Settings File dialog, specify the directory and file name and click Open.

TeachView reads the settings from the specified file and applies the settings. These 
settings are also written to the Windows registry and will be loaded the next time you start 
the TeachView application.
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Chapter 4
Creating Target 
Configuration Files

ATS helps you adjust wafer handling equipment so that the equipment can pick up a wafer or 
put down a wafer in exactly the right position. To determine the correct position, ATS uses a 
target, which is a round physical feature inside the equipment that ATS can recognize and 
precisely locate. To recognize a target, ATS requires a target configuration file. A target 
configuration file must contain information that is very specific to a particular target. The two 
key pieces of information ATS needs are the diameter of the target and the distance from the 
wafer to the target. Of the two, specifying an accurate target diameter is the most critical. If two 
pieces of equipment have identical targets and wafer-to-target distances, you can use the same 
target configuration file for both; otherwise, you need to create separate target configuration 
files. The TeachTarget application is designed specifically for the task of creating target 
configuration files.

Choosing a Target
Before you can create a new target configuration file, you need to decide which feature of the 
equipment to use for the target. Look for a hole or similar round feature that is located in the 
center of the equipment. A feature with a diameter of a few millimeters up to a few centimeters 
works best. A target that fills between 1/8 to 1/3 of the view generally gives better results. The 
target must be small enough that the entire target is visible in the video image in TeachTarget.

When you use TeachTarget, if the target you choose is too small, the application will ask you to 
identify a secondary target. The secondary target must be concentric with the primary target. 
For example, if a piece of equipment has a 4-mm hole and 30-mm ring, you could specify the 
4-mm hole as the primary target; if TeachTarget requests a secondary target, you would specify 
the 30-mm ring for the secondary target. If your equipment doesn’t have a feature that could be 
used as a secondary target, TeachTarget will just do the best it can using the primary target.
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Measuring the Target
The TeachTarget application will ask for two critical target measurements:

• Target diameter. The diameter of the target in millimeters. This is the most critical 
measurement and should be accurate to 0.01 mm.

• Target distance. The distance (Z), in millimeters, from the bottom of the teaching 
wafer to the target. This measurement should be accurate to 0.5 mm.

More accurate you can make these readings give better results, so make them as accurate as you 
reasonably can. 

Running TeachTarget
To create a target configuration file:

1. Choose the feature of the equipment you will use for the target (see “Choosing a Target,” 
on page 4.1).

2. Get the target measurements (see “Measuring the Target,” on page 4.2).
3. Place the teaching wafer on the equipment. Align the teaching wafer so it matches the 

TeachTarget display by rotating the wafer until the WaferSense™ ATS logo is right-side 
up and level as you face the wafer, as shown in Figure 4.1.

Figure 4.1: Aligning the Teaching Wafer
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4. If TeachView is running on the computer, exit the application. At any given time, only 
one application can communicate with the teaching wafer.

5. From the Windows Start > All Programs menu, choose WaferSense ATS > 
TeachTarget.

6. Make sure the computer running the TeachTarget application is within the range of the 
link module, about 30 ft (10 m). 

7. Resize the TeachTarget window until the target feature in the video image is easy to see. 
Use the DARKER and LIGHTER buttons in TeachTarget to adjust the image so that 
you can distinguish the target from the background. This adjustment is only for your 
convenience; it doesn’t affect the creation of the target configuration file.

8. Step 1, Position the Wafer. Move the teaching wafer until the red cross hairs are 
centered on the target, as shown in Figure 4.2. When the cross hairs are centered, 
click Next.

Figure 4.2: Step 1. Position the Wafer
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9. Step 2, Optimize Lighting. TeachTarget performs this step all by itself. When 
Optimization complete is displayed below the indicator bar (see Figure 4.3), click Next.

Figure 4.3: Step 2. Optimize Lighting

Optimization 
complete
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10. Step 3, Acquiring Image. TeachTarget performs this step all by itself. While the image 
is being acquired, no video image is displayed. When the step is complete, the video 
image appears and TeachTarget displays Image retrieval complete below the indicator 
bar (see Figure 4.4). Note that from this point on, the image displayed in TeachTarget is 
the captured image, rather than live video. When you are ready to proceed, click Next.

Figure 4.4: Step 3. Acquiring Image

Image 
retrieval 
complete
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11. Step 4, Target Parameters. Enter the diameter of the target and the distance from the 
bottom of the teaching wafer to the target (Z distance). For more information on these 
values, see “Measuring the Target,” on page 4.2. After entering the values, click Next.

12. If the image of the target is too small for good recognition (fewer than 80 pixels in 
diameter), TeachTarget asks you to identify a possible secondary target (for more 
information on secondary targets, see “Choosing a Target,” on page 4.1). If you have a 
feature that you can use for a secondary target, fill in the diameter of the target feature in 
the Secondary target area. If the equipment doesn’t have a secondary target feature, fill 
in zero, and TeachTarget will use the primary target. After entering the secondary target 
value, click Next. 

Figure 4.5: Step 4. Secondary Target Parameter

Primary 
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13. Step 5, Overlay Alignment. For this step, you’ll find it helpful to have a very large video 
image, so resize the TeachTarget window to make the video image as large as possible. 
TeachTarget adds two concentric red overlay rings to the captured image of the target (see 
Figure 4.6). If you identified a secondary target in the previous step, TeachTarget adds the 
red rings to the secondary target, as shown in Figure 4.7 on page 4.8.

14. If the rings aren’t centered on the target, use the Ring position buttons to center them.
15. Use the GROW and SHRINK buttons to adjust the size of the rings until they just 

enclose the edge of the target feature (see Figure 4.6). For a secondary, ring-shaped target, 
choose either the target’s inner edge or outer edge to enclose with the red rings (see 
Figure 4.7 on page 4.8). 

Figure 4.6: Step 5. Overlay Alignment, Primary Target

Overlay rings 
enclosing the 
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Figure 4.7: Step 5. Overlay Alignment, Secondary Target
16. When you have the rings aligned on the target, click Next.

Overlay rings 
enclosing the 
inner edge of 
the secondary 
target
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17. Step 6, Generating Target Parameters. TeachTarget immediately begins generating the 
parameters for the target configuration file (see Figure 4.8). When the parameter 
generation is complete, click Save Target File, fill in a name for the file, and click Save. 
By default, target configuration files are saved in c:\Documents and Settings\All 
Users\Application Data\CyberOptics Semiconductor\ATS\Target Files\.

Figure 4.8: Step 6. Generating Target Parameters
18. When you have finished saving the file, click Done. TeachTarget exits.

The target configuration file you just created is ready to use. Be sure to click Done to exit 
TeachTarget, or use the menu File > Exit, before running TeachView. Only one application at 
a time can communicate with the teaching wafer.
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Maintaining Your ATS
This chapter discusses the following:

• Annual factory calibration and battery replacement
• Battery use and disposal
• Updating your ATS wafer firmware

  

Periodic calibration and battery replacement is the only regular maintenance your ATS requires:
• Annual Calibration and Battery Replacement. Once a year, you should have your 

teaching wafer calibrated and the internal rechargeable battery replaced by returning 
the teaching wafer to the CyberOptics Semiconductor factory.

• Cleaning the Teaching Wafer. If cleaning is required, wipe the outside of the 
teaching wafer with IPA (isopropyl alcohol). If the teaching wafer is used in a clean 
environment, follow proper procedures for cleaning devices for this environment. 

Warning
The edges of the ATS teaching wafer are thin. It may be possible to sustain an injury from
these edges if the teaching wafer is not handled with proper care.

Warning
Protection afforded by compliance to EN61010-1 (2001) may be impaired if the
equipment is not used as specified.

Warning
Do not immerse the teaching wafer or the link module in liquid. Do not spill liquids on
the teaching wafer or on the link module.
5.1



Chapter 5. Maintaining Your ATS
Annual Factory Calibration and Battery 
Replacement

Every twelve months, you should return your teaching wafer to the CyberOptics 
Semiconductor factory, where we will calibrate the teaching wafer and replace the internal 
rechargeable battery. You can find the date when the teaching wafer was last calibrated at the 
factory by choosing the Help > About your ATS Wafer menu item in the TeachView 
application. 

When the date for calibration approaches, the TeachView application will occasionally notify 
you by displaying the ATS Wafer Calibration Status dialog, as shown in Figure 5.1. 

Figure 5.1: ATS Wafer Calibration Status Dialog
If you drop the teaching wafer or suspect that it is no longer in calibration, contact CyberOptics 
Semiconductor technical support (see “Technical Support,” on page 2.9).

Battery Use and Disposal
Your ATS teaching wafer contains a lithium-polymer battery. To avoid damage to the teaching 
wafer, use the supplied charger only. Do not charge the teaching wafer at temperatures outside 
the specified range (0 °C to 45 °C). Do not incinerate or dispose of the teaching wafer into fire. 
Do not immerse the teaching wafer when cleaning or spill liquids on the teaching wafer.
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For proper battery disposal, please return the teaching wafer to CyberOptics Semiconductor, 
Inc.:

CyberOptics Semiconductor, Inc.
13555 S.W. Millikan Way
Beaverton, OR 97005

or contact customer support (see “Technical Support,” on page 2.9).

Updating Your ATS Wafer Firmware
Your ATS includes a software application, called ATS Firmware Updater, for updating the 
firmware that is onboard the ATS teaching wafer. The current firmware version is available by 
choosing the Help > About your ATS Wafer menu item in either TeachView or TeachTarget.

To update the firmware on your ATS teaching wafer:

1. Turn on the teaching wafer.
2. If either TeachView or TeachTarget is running on the computer, exit the application.
3. From the Windows Start > All Programs menu, choose WaferSense ATS > ATS 

Firmware Updater.
The ATS Firmware Updater application starts, as shown in Figure 5.2.
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Figure 5.2: Starting the ATS Firmware Updater Application
4. In the ATS Firmware Updater window, verify that the battery level is at least 50%. You 

can’t update the firmware if the battery level is below 50%. If necessary, recharge the 
battery before proceeding (see “Charging the Battery,” on page 3.17).

5. Click Select Firmware File.
6. In the ATS Firmware File dialog, find and select the firmware file and click Open. By 

default, the ATS Firmware Updater looks for firmware files in c:\Documents and 
Settings\All Users\Application Data\CyberOptics Semiconductor\ATS\Firmware\.

Caution
In the next step, you will start the load firmware process. Once you start the process, the
firmware is automatically uploaded to the wafer, committed, and verified. Do not
interrupt this process by turning off or cycling the power to the teaching wafer. If you do
so, the wafer might be disabled, and you will need to return it to the factory to fix the
problem.
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7. Click Load Firmware.
The firmware file is uploaded to the wafer, committed, and verified. This process takes a 
few minutes, and the ATS Firmware Updater displays progress bars and messages so you 
can follow the progress. When the firmware has been verified, you will be prompted to 
cycle the power on the teaching wafer, as shown in Figure 5.3.

Figure 5.3: Cycle Power dialog
8. Press the ON OFF button on the teaching wafer to turn off the wafer, then press it again 

to turn on the wafer. The teaching wafer doesn’t start using the new firmware until you 
cycle the power.

9. Click OK to close the dialog.
10. Choose File > Exit to exit from the ATI Firmware Updater application.
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Specifications
System Requirements

To run the WaferSense ATS software and link, your computer must have:
• Windows 2000, Windows XP, or Windows Vista operating system
• One free high-power USB 1.1 or USB 2.0 port

ATS Hardware
Environmental

Operating pressure range: ≤10-6 Torr to atmospheric.

Storage temperature range: -20 °C to 70 °C.

Charging temperature range: 0 °C to 45 °C

Operating temperature range: Optimum 20 °C to 50 °C. Can withstand exposure to 120 °C 
(5 minutes or less) if not in direct contact with heating element.

Power
Battery charger requires 100 - 240 VAC at 47 - 63 Hz input.

Battery usage on a full charge: approximately 2 hours. Battery performance degrades at 
temperatures outside the optimum operating temperature range.

Typical battery recharge cycles: approximately 500.

Range and Accuracy
X and Y accuracy: ±0.1 mm (±0.004")

Z range: 6.4 mm to 45 mm (0.25" to 1.8")

Z accuracy: ±0.5 mm (±0.02")
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