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13. Create map file for RainMap 
13.1. Required software 

・ Image software: Paint.NET, Photoshop, SAI, etc. (Require to use a layer) 
This manual is explained by using Paint.NET. 

・ Software to confirm map: RainMap.exe  
 

13.2. Web Browser 

・ Main map: OpenStreetMap  

・ Confirm a map: Use website to confirm distance from the center position by such as “Draw 
circles on the Google Map” . 
http://www.nanchatte.com/map/circleService-e.html 

 

13.3. Display 
High resolution monitor recommended (2560x1440) 
 

13.4. Overview 
1) Capture the map screen from homepage. 
2) Paste it to the image software. 
3) Slide a map of homepage to capture the best part. 
4) Paste it and to combine a map. 
5) Repeat this procedure “1” to “4” to create a size for RainMap. (Maximum radius range of 

view for RainMap is 50km, therefore it might need about 100km) 
6) Adjust color of combined images. 
7) Create bmp file. 
8) Create txt file of map copyright. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Map size for 
RainMap 

Paste several 
screen together 

http://www.openstreetmap.org/
http://www.nanchatte.com/map/circleService-e.html
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13.5. Create a map 
[Map setting] 

Center position：Radar position 

Map        ：11 

Type of map   ：Transit map 

 

13.5.1. Cut maps 
1. <OpenStreetMap> 

Open website of OpenStreetMap from browser. 
1) Click [Go] after entered Lon/Lat of radar position. 
 
 
 
 
 
 
 
 
 
 
 
 
 
2) Click the target of Lon/Lat to move a map and display. 
 

 
 
 
 
 
 
 
 
 
 
 

Click it to  
show a point 

Mark will be 
shown when to 

point a mouse to 
a search results. 

http://www.openstreetmap.org/
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2. <OpenStreetMap> 
Click [+] or [-] button or change scale number of URL directly to11. 
http://www.openstreetmap.org/#map=11/29.5624/-95.2089&layers=T ) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. <OpenStreetMap> 
Change layer to transport map. 
Click [Layer] Select [Transport Map] from windows of [Map Layers]. 
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4. <OpenStreetMap> 
Close [Search result] and [Map layer] windows to enlarge capture screen. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

5. <Paint.NET> 
Setup canvas size on Paint.NET. 

[Canvas Size] 

Width ：3500 pixel 

Height ：3000 pixel 

Cut a map about 100km from the center position. 

・Select [Canvas Size] -> [Image] from menu bar. 
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・Set a pixel size of canvas size. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. <Paint.NET> 
To indicate [Windows] -> [Layer] if windows of layer is not shown on the screen. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Caution: 
1) Activate layer is highlighting. Confirm to use active layer before copy, paste, and others. 

(Display screen is not always activating) 
2) Before activate other layer with a range selected, it must deselect range in case of other layer 

is effective to a select range of previous layer! 
*It could release a select range from [Edit] -> [Deselect] 

Check box 

Move Layer Up/Down 

Merge Layer down 

 
Delete Layer 

 
Add New Layer 

 

Activate Layer is highlighting 
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7. <OpenStreetMap>  
Press [Alt] + [PrtSc] to copy a map screen of OpenStreetMap. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. <Paint.NET>  
Click [Add New Layer] at a windows of Layers (New layer would be highlighted), then click 
[Paste] to paste a screen of Open StreetMap into a new layer. 
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9. <Paint.NET> 
Copy only a part of map from procedure “8” and Select [Tools] -> [Rectangle Select].    It 
could make a fine adjust by using [Move Selection]. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Select only a part of map and click [Copy]. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

10. <Paint.NET> 
Click [Add New Layer], it would be highlighted on new layer, then click [Paste] to paste a map 
into a new layer. (A part of map that copy at procedure “9” would be pasted) 

 
 
 
 
 
 
 
 
 

Rectangle Select 
 Move Selection 

 



S2E-17-0056_A 

57 

11. <Paint.NET> 
Move the pasted screen to the center of canvas and bring radar position to the center. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

12. <Paint.NET> 
Delete unnecessary layer of without having map (procedure “8”). Confirm the highlight before 
click [Delete] button. 

 
 
 
 
 
 
 
 
 



S2E-17-0056_A 

58 

13. <OpenStreetMap> 
Slide a map display position of OpenStreetMap. (Pile up a little with the previous copy range.) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

14. <Paint.NET> 
Copy a map screen -> Add new layer by Paint.NET -> Confirm that added layer is selected -> 
Paste a copy screen. 
Copy new layer after selected a part of map only. (Refer the procedure “7” to “10”) 

 
15. <Paint.NET> 

Delete unnecessary layer. (Refer the procedure “12”) 

Previous copy range Pile up a little with the previous copy range 
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16. <Paint.NET> 
Adjust two layers to pile up the same part of map by indicating layer of procedure “11” and 
“14”.. 
(To correct the position deviation by clicking check box of layer to turn ON/OFF and move one 
of a map a little when both map screens are nearly piled up.)  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Pile up 2 sheets of layers: 
 
 
 
 
 
 
 
 
 
 
 
 
 

Tilt to adjust the layer  

Turn ON/OFF the 
indication of layer to 

confirm and adjust it when 
maps are piled up. 
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17. <Paint.NET> 
Click [Merge layer down] button to merge the bottom layer and selected layer to joint it.  

 
 
 
 
 
 
 
 
 
 
 
 
 

18. <Paint.NET> 
Repeat procedure “13” to “17” until it becomes canvas size. 

 
19. <Paint.NET> 

Search Lon/Lat of Top-Left and Bottom-Right for cutting a whole map. 
Move a cutting position of OpenStreetMap web browser to the center.  
Click [Where am I?] and put a mouse on Lon/Lat under search results. Mark would indicate in  
the center of map. 
Click [Alt] + [PrtSc] to copy screen while mark is indicating in the map. 
Notice: Take a note of Lon/Lat Top-Left and Bottom-Right for using as a file name. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Example to merge selected Layer 3 and Layer 5. 

Put a mouse on the 
Lon/Lat under search 
result.  
*Take a note of Lon/Lat. 

Click Lon/Lat under search 
results to indicate mark. 
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20. <Paint.NET> 
1) Add layer and click [Paste] to paste a screen of OpenStreetMap including a mark. 
2) Use [Rectangle Select] to cut a part of mark. (Cut a part of map that easy to confirm a 

position.) 
 
 
 
 
 
 
 
 
 
 
 

21. <Paint.NET> 
Indicate layer of position information and map. Selected two layers with position information 
adjust to be piled up.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

22. <Paint.NET> 
Do the same way even to the mark of Bottom-Right to cut a part of map. 
(Refer the procedure 20 to 22) 

 
 
 
 
 
 
 
 

Choose a map with easy 
to confirm a position to 
pile up. (Terrain features) 

Mark 



S2E-17-0056_A 

62 

23. <Paint.NET> 
Indicate a layer of mark and map layer. 
1) Choose a layer map and range of Top-Left to Bottom-Right. 
2) Click [Copy] to copy this image (Choose a position of layer with a mark). 
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24. <Paint.NET> 
1) Click [File] menu Select [New] for making a new image. 
2) Canvas size: Width 800 x Length 600 pixel (It should be smaller than image to paste) 
3) Paste a data that copied at procedure “23”.  
4) Select [Expand canvas] 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Complete color map: 
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13.5.2. Change color of map 
Change the color of map to gray for RainMap because OpenStreetMap is having lots of 
colors. (The reason of changing a color to gray is because of the view range on 
RainMap is using white) 
[Map color] 
Land: RGB255 
Sea : RGB232 

 

1) Click [More] button to open RGB input screen from [Windows] -> [Colors] if color windows is 
not indicated. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Click [More] 

This part will be 
expanded 
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2) Delete all unnecessary color on land and sea. (e.g. Sea line/dotted line, green mountain)   
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2-1) Erase indication of sea line/dotted line: 
1) Click [Tool] -> [Color Picker] to get a value of sea color (except line/dotted line).  

[Colors] R:173 G:222 B:255 
2) Use the same sea color value to fill line/dotted line. 

Tool: Paint Bucket 
Flood Mode: Global 
Tolerance: 30% (A low setting dictates that pixels must be a close match to the click point 

pixel in order to be filled. A high setting allows a wider variance of pixels to be 
included in the fill operation)  

[Tool] -> [Paint Bucket], click line/dotted line to fill color. 
 
 
 
 
 
 
 

Sea 
dotted line 

Green 
mountain 

Sea line 

Left: 0% / Right: 100% 
Use scroll bar to set a value. 
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Sea line and Sea dotted line are erased: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2-2) Erase indication of green mountain: 
1) Click [Tool] -> [Color Picker] to get a value of land color. 

[Colors] R:247 G:247 B:247 
2) Use the same land color value to fill green mountains. 

Tool: Paint Bucket 
Flood Mode: Global 
Tolerance: 20%  
[Tool] -> [Paint Bucket], click green parts to fill color. 
Green mountains are erased. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Sea 
dotted line 

Sea line 

Green 
Mountain 
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3)  Change colors to Black and White. [Adjustments] -> [Black and White] 
 
 
 
 
 
 
 
 
 
 

After changed colors to Black and White: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4) Adjust levels. [Adjustments] -> [Levels] 
Input Histogram (Black): 150 
Output Histogram (White): 225 
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After adjusted levels: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5) Change colors of sea and land. [Tool] -> [Paint Bucket] 
Sea   : R:232 G:232 B:232 (Gray) 
Land  : R:255 G:255 B:255 (White) 
Flood Mode: Global  
Tolerance  : 0% 
Complete a map 
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6)  Save image after deleted all unnecessary layers and to remain a layer of map image. 
6-1) [File] -> [Save as] 
6-2) Select “Save as type” to “BMP (*bmp)”. 
6-3) Save “File name” as “Top-Left Lon/Lat Bottom-Right Lon/Lat (decimal number)” 

e.g. [Degrees Minutes Seconds] -> [Decimal Number]  
36deg 17 min 12.26sec -> 36.286738 
3 digit Integral, 5 digit fraction of Lon/Lat. 

e.g. N04004440W07734380N03771860W07435550.bmp 
6-4) Click [Save] 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6-5) [Save Configuration] windows would indicate after clicked [Save] at [Save as] 
windows. 
Put a check on [8-bit] or [24-bit] instead of [Auto-detect] if file size is big. 

6-6) Click [OK] to save image file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

File size 
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13.5.3. Confirm a created map 
Confirm positions and distance of created map by RainMap view. 

 
1) Confirm distance. 

Compare a map by RainMap view and website map to confirm distance. 
1-1) Startup RainMap.exe.  
1-2) Click [Menu] -> [Setting] -> [Display]  
1-3) Click [Apply] after entered a range to 50km. (Range: 10 to 50km) 

 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 

1-4) Click [Radar Site Location] 
1-5) Click [Apply] after setup “Latitude [deg]”, “Longitude [deg]”, and “Map data path”. 

Enter radar position on “Latitude [deg]” and “Longitude [deg]” with decimal number. 
Open a folder to set a map image file on “Map data path”. 
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1-6) Indicate radar view range (white) and map. 
Confirm with website map that RainMap indicates the correct position. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

RainMap screen 
 

From [Draw circles on the Google Map] 
http://www.nanchatte.com/map/circleService-e.html 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Website map 
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2) Confirm by RainMap screen. 
2-1) Confirm map by changing windows size of RainMap. Map must be fit into a screen. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Bad example) Bottom part of map is missing. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Change windows size 

This map is fail because of bottom 

part of map is missing. 
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2-2) Confirm by RainPlay screen. 
Choose a map file at [Disp] -> [Map] to confirm a map. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

13.5.4. Create a map license. 
Copyright of OpenStreetMap URL: http://www.openstreetmap.org/copyright 
Create a text file with the same name of map file. 
File name: “Top-left Lon/Lat, Bottom-Right Lon/Lat.txt” 
It would readout text file by RainMap.exe / RainPlay.exe and prints on the Bottom-Right 
screen. 
File detail: “OpenStreetMap Contributors” 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

http://www.openstreetmap.org/copyright
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APPENDIX  
1. Outline drawing 

1) Antenna Unit 
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2) Junction Unit (connection box) 
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2. System diagram 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 
 
 
 

 
  

 
 

 
 

 
 
 
 
 
 
 

Notice: All cables and protective tube between DPU side and JCU should be 
prepared at local. 
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