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Introduction
This user’s guide provides setup and usage instructions for the Car Access Reference System (CARS) featuring
Remote Keyless Entry (RKE), Passive Entry/Passive Start (PEPS) and vehicle Immobilization (IMMO) functionality,
based on the Microchip’s GEN2 communication protocols. It offers a complete car access system for various car
access products and its evaluation. The reference designs are both scalable and configurable through either the PC
application or source code modifications, enabling adaptation of the basic hardware and software building blocks to
meet the most recent requirements for specialized systems.

Features
• Full Car Access System Capability:

– Vehicle IMMO
– Multichannel RF RKE
– LF PEPS

• Open System Software:
– Open Immobilizer Protocol (AOIP) immobilizer stack using AES-128
– RKE RF rolling code using AES-128
– PEPS protocol with a high-precision 3D localization using AES-128
– Scalable and configurable
– PC Graphical User Interface (GUI) for system visualization and viewing data communication

• Body Computer Emulation using the SAMC21J18A XplainedPro (XPRO) Evaluation Board
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1. Quick References

1.1 Reference Documentation
For further details, refer to the following:

• ATAN0088 Open Source Immobilizer Protocol Stack Application Note
• ATAN0073 Short Form Description of the Atmel PEPS System Application Note
• ATAN0014 RF System Architecture Considerations Application Note
• AVR411: Secure Rolling Code Algorithm for Wireless Link Application Note
• ATAN0218-ATAK51005-V1 Quick Start Guide

1.2 Hardware Prerequisites
• Vehicle-side boards

– One ATSAMC21-XPRO microcontroller board
– One ATA5291-XPRO LF coil driver with built-in immobilizer base station board
– One ATA5831-XPRO RF transceiver board
– One ATAB-LFTX-V4.0 LF antenna module (can be configured as an inductive load needed for the

immobilizer
• Fob and transponder

– One ATAB5702A RF transmitter with 3D LF PEPS and 3D LF immobilizer transponder board
• Other accessories

– One UHF SMA whip antenna (included with ATA5831-XPRO board)
– One USB cable
– One DC plug to banana plugs adapter cable (included with the ATA5291-XPRO board)

Note:  The fob (ATAB5702A-V2.3B) requires a CR2032 lithium battery for operation, which is not provided.
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2. Kit Overview
This section describes the different blocks supported by the CARS.
Figure 2-1. CARS System Block Diagram

(SAMC21)

(ATA5291)

(ATA5831)

2.1 Immobilizer Block
The immobilizer is considered the system foundation because it must always work, even if the fob battery is dead,
and secures a vehicle against unauthorized engine starts. It consists of a base station, placed in the vehicle, that
provides the LF (125 kHz) magnetic field enabling a wireless link with the transponder in the fob to be established.
This LF immobilizer link is used to exchange the power supply and digital data between the vehicle and the passive
transponder.

The implemented immobilizer system supports Microchip’s AOIP, which consists of an open/unlicensed protocol stack
based on AES-128 encryption. First, the ReadUID command is sent to the fob. The fob has to decode the ReadUID
command and respond with its unique ID (UID) value. If the received UID value is correct (matches the stored UID),
the start authentication command is issued and challenge data is sent to the fob based on the authentication type
(unilateral or bilateral). The fob receives the challenge, performs the encryption and sends a ciphered response back.
This response is received by the base station and verified to complete the authentication process.

Notes: 
1. The fob is a receive-only device; therefore, the ciphered response back to the base station is accomplished by

loading/unloading the magnetic field to encode the data.
2. For more details on the AOIP protocol, refer to the ATAN0088 Open Source Immobilizer Protocol Stack

Application Note.

2.2 RKE Block
RKE functionality provides the means to lock or unlock and even start the vehicle from a long distance with a fob
carried by the user. The system consists of an RF receiver in the vehicle and an RF transmitter in the fob. Unlike the
immobilizer operation, the RKE operation requires a battery (CR2032 or equivalent) to be inserted in the fob.

The implemented RKE system supports Microchip messaging protocol (AVR411), which consists of a unidirectional
UHF link that is secured based on an AES-128 rolling code algorithm. The message contains information that is used
to verify the identity and authenticity of the user and the intended action (command code).
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Note:  RF and UHF are used interchangeably in this document. For more details on the RKE protocol, refer to the
AVR411: Secure Rolling Code Algorithm for Wireless Link Application Note.

2.3 PEPS Block
The PEPS functionality provides the user with a means to lock/unlock and start a vehicle just by having the electronic
fob with them, without the need to actively interact with it. It consists of an LF coil driver placed in the vehicle, which
generates a strong magnetic field on multiple (optional) LF PEPS antennas.

The passive fob implemented in the PEPS system can wake up on this LF field and receive the incoming data via the
unidirectional LF link. The fob also measures the strength of the magnetic field, which is used to determine the
position of the fob relative to the vehicle (outside or inside). Then, it encrypts the received challenge data (using AES)
and returns the correct cipher response, together with the positioning information, to the vehicle via the unidirectional
UHF link.

Note:  For more details on the PEPS protocol, refer to the ATAN0073 Short Form Description of the Atmel PEPS
System Application Note.
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3. Kit Setup
Perform the following steps to set up the ATAK51005-V1 kit:

1. On the ATSAMC21-XPRO microcontroller board, ensure that the VCC-SEL jumper is set to the 5.0V position.
2. Insert the ATA5291-XPRO LF coil driver/immobilizer board in the EXT3 connector on the ATSAMC21-XPRO

board.
3. Connect the ATAB-LFTX LF antenna module to Ant0 on the ATA5291-XPRO board.
4. Ensure that the J1 jumper on the LF antenna module is set to the inductor only ( ) position.

Note:  For use of the antenna on the Ant1-7 connectors, ensure that the jumper on the LF antenna module is
set to the LCR position.

Figure 3-1. ATAK51005-V1 Kit Setup

ATA5291-XPRO Board
ATSAMC21-XPRO Board

ATA5831-XPRO Board

ATAB5702A Fob Board

ATAB-LFTX LF Antenna Module

UHF SMA Whip Antenna

5. Insert the ATA5831-XPRO RF transceiver board in the EXT1 connector on the ATSAMC21-XPRO board.
6. Connect the UHF SMA whip antenna to the ATA5831-XPRO board at the ANT2 SMA connector.
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7. Connect the 12V DC power supply to the power socket (J11) on the ATA5291-XPRO board using the DC plug
adapter cable.

Note:  Always ensure that the adapter cable and the USB cable are unplugged prior to inserting or removing any
boards within the system.
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4. CARS Kit PC Evaluation Utility
This section describes the programming and configuration settings for using the CARS kit PC evaluation utility.

Note:  The latest version of the utility is available for download at www.microchip.com/developmenttools/
ProductDetails/ATAK51005-V1.

4.1 Programming Kit Software
Program all the individual boards that comprise the kit prior to use. For more details, refer to 6.  Programming
Instructions.

4.2 Determining the ATSAMC21-XPRO Virtual COM Port Number
The system software consists of a CARS kit PC evaluation utility, which runs on a host PC and communicates with
the ATSAMC21-XPRO board via the virtual COM port. Install the USB driver (Windows 10 and later) to support the
ATSAMC21-XPRO virtual COM port via a USB connection (see 7.  XPRO USB Driver Installation).

Perform the following steps for determining the ATSAMC21-XPRO virtual COM port number:

1. Connect the micro-USB plug to the USB connector on the ATSAMC21-XPRO board.
2. Connect the other end of the USB cable to an open USB port on the PC. Open the Windows Device Manager

on the PC.
3. Expand the “Ports (COM & LPT)” menu, then note the COM port assigned to the “EDBG Virtual COM Port”. In

this example, COM17 is used while connecting the CARS kit evaluation utility program to the ATSAMC21-
XPRO board.
Figure 4-1. Virtual COM Port Assignment
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Note:  Always ensure that the adapter cable and the USB cable are unplugged prior to inserting or removing any
boards within the system.

4.3 COM Port and Baud Rate Settings
Navigate to the folder containing the downloaded ATAK51005-V1 software files and open the
CARS_PC_Application.exe file. Perform the following steps for the COM port and baud rate settings.

COM Port Settings
In the Car Access System PC Application window, navigate to COM > PORTs > COM17.
Figure 4-2. COM Port Selection

Baud Rate Settings
In the Car Access System PC Application window, navigate to COM > BAUD Rate > 115200.
Figure 4-3. Baud Rate selection

The CARS utility is now ready for use.

4.4 Initial Configuration of the CARS Kit PC Evaluation Utility
Perform the following steps for configuring the CARS kit:

1. In the Car Access System PC Application window, navigate to View > System Configuration.
2. Click on the refresh icon to update the system’s firmware version and other variables. The system software

version loads correctly if the connection is valid (COM port is open).
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Figure 4-4. System Configuration Window

3. Place the ATAB5702A fob board in close proximity (<10 cm) to the LF antenna module, as shown in the
following figure.
Figure 4-5. Fob Placement

4. Click the Learn button in the System Configuration window.
5. The fob UID in the “Learned Fobs” section indicates the successful completion of the learn procedure.
6. If the learn procedure is unsuccessful, repeat step 4 a couple of times. If it still fails, try moving the ATAB5702A

fob board position slightly on the LF antenna module and repeat step 4.
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Notes: 
• The learn procedure is required for the system to function properly, during which, the fob and the base station

exchange the UID and secret keys. The fob UID value is stored in the ATSAMC21-XPRO non-volatile memory
upon completion of this procedure.

• Do not click the Clear button in the System Configuration window as doing so erases all stored UID values.
Without the stored values, the system car access functions, PEPS authentication and RKE messaging do not
operate.
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5. System Operation
The system includes the following features:

• Immobilizer functionality:
– Supports AOIP
– Support for AES-128 encryption
– Passive fob authentication supporting unidirectional authentication (UA)
– Support for base station to transponder key learn sequence used during the learning procedure
– Support for several utility immobilizer commands (such as communication or transponder data

management)
• RKE functionality:

– Support for unidirectional AES-based rolling code protocol
– Use of multiple channel UHF messaging provides robustness against the effects of multipath or in-band

interference
• PEPS wake-up functions:

– Selectable LF driver coil
– Selectable LF driver current (ICOIL = 50 mA to 1000 mA)
– LF driver polling support
– Configurable preamble and header settings for LF wake-up via source code updates
– Unidirectional UHF data return channel included

5.1 Immobilizer Operation
The immobilizer functionality is tested using the base station hardware (ATSAMC21-XPRO/ATA5291-XPRO/LF
antenna module) and the ATAB5702A fob board. The CARS PC application displays the UID, challenge, response
and result of the authentication in the Immobilizer Status window each time the authentication command is executed.
Perform the following steps to test the immobilizer using the CARS PC application running on the host PC:

1. If not done so already, follow the procedure detailed in 4.  CARS Kit PC Evaluation Utility.
2. Navigate to View > Immobilizer. The Immobilizer Status window shows the following data fields:

Figure 5-1. Immobilizer Status Window

– “Immobilizer UID” – Displays the unique ID value received from the fob
– “Immobilizer Challenge” – Displays the most current challenge data sent to the fob
– “Immobilizer Response” – Displays the most current response data received from the fob
– “Immobilizer Result” – Displays the authentication status
– “Log file” – Selecting this check box creates a new record line in a comma-separated variable (CSV)

document for each received message when it is selected.

 ATAN0219
System Operation

© 2020 Microchip Technology Inc.  User Guide DS50003051A-page 13

Microchip Confidential: For Release Only Under Non-Disclosure Agreement (NDA)



3. Place the fob near the LF antenna module within a short distance (<10 cm).
4. Click the Read UID button to execute the ReadUID command. The ReadUID command is sent to the fob and

the fob responds by sending its UID.
Note:  This command works even for fobs not learned by the system.

5. Click the Start Authentication button to execute fob authentication. The green shield icon ( ) indicates the
immobilizer status upon successful execution of the start authentication command.
Note:  The Immobilizer Challenge and the Immobilizer Response values are different each time a new
authentication sequence is executed because the Immobilizer Challenge is a random number. The UID value
is fixed every time.

6. To test passive operation, remove the battery from the fob and repeat steps 3 through 5.

5.2 Remote Keyless Entry Operation
The RKE functionality is tested using the base station hardware (ATSAMC21-XPRO/ATA5831-XPRO) and the
ATAB5702A fob board. The RKE functionality can be observed using the RKE Message Status window. On the fob,
all three buttons provide RKE command messages. Each button also has two types of press actions – short press
and long press, with each type handled differently. The following table shows how these are currently configured.

Table 5-1. Fob Push Buttons Functionality

Button Action S1 S2 S3

Short press Lock Unlock driver door Open trunk

Long press Remote start Unlock all doors Close trunk

Except for a long press of S1, all of the other buttons transmit the RKE command messages using FSK modulation at
9.6 kbps. To carry out a long-range remote start function, a long press of S1 changes to ASK modulation at 1 kbps.
The remote start function command reduces the transmitted data rate. The decrease in data rate enhances the RF
sensitivity of the RF transceiver board, which increases the range. The transmitting and receiving devices are
seamlessly changed, demonstrating their power and flexibility.

For high-quality performance, even in the presence of noise, each button press sends three RKE messages
sequentially on three different UHF channels, referred to as Time and Frequency Domain Redundancy. Thus, it
increases the probability of successful reception of at least one of the messages.

Note:  For more details on the RF protocol, refer to the AVR411: Secure Rolling Code Algorithm for Wireless Link
Application Note. For more details on time and frequency domain redundancy, refer to the ATAN0014 RF System
Architecture Considerations Application Note.

5.2.1 RKE Operation
Once one or more fobs are paired with the system, the RKE can be tested using the CARS PC application running on
the host PC as follows:

1. If not done so already, follow the procedure detailed in 4.  CARS Kit PC Evaluation Utility.
2. Navigate to View > RKE Messaging. The RKE Message Status window shows the following data fields:

 ATAN0219
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Figure 5-2. RKE Message Status Window

– “RF Message S/N” – Displays the UID returned by the fob. The same UID value for a given fob displays
in the learned fobs section of the System Configuration window.

– “Log file” – Selecting this check box creates a new record line in a CSV document for each received
message when it is selected.

– “RF Message Counter” – Displays the rolling code message counter value sent to the vehicle. This value
is incremented for every key push. All RKE commands increment the counter value. The counter is
checked against a window of valid counts on the vehicle side to prevent recording and replaying of past
RKE messages from being accepted as valid, which is commonly referred to as Replay Attack.

– “RF Message Command” – Displays the most recent RKE command received from the fob.
– “RF Message MAC” – Displays the received 4-byte (32-bit) Message Authentication Code (MAC).
– “RF Message Result” – Displays the result of the comparison between the expected MAC (computed

using AES-128) and the received MAC.
– “RF Channel” – Displays the RF channel that received the message.
– “RF RSSI” – The signal strength measured at the RF transceiver board displays in three formats. There is

a decimal representation read directly from the RF transceiver device followed by a calculated dBm
value. Finally, there is a bar graph that provides visual representation.

3. Press any of the RKE buttons, as discussed in the 5.2  Remote Keyless Entry Operation, to send the RKE
message.

5.3 PEPS Operation
The PEPS functionality is tested using the base station hardware (ATSAMC21-XPRO/ATA5831-XPRO/ATA5291-
XPRO/LF antenna module) and the ATAB5702A fob board. The PEPS operation is commanded by the CARS PC
application to send LF wake-up messages to the fob, which, then, responds with information via the RF channel.

5.3.1 System Configuration Window Overview
The System Configuration window has the following functions:

• Displays specific software information
• Reports the status of the learned fobs
• Selects the PEPS authentication method
• Selects a PEPS fob to perform testing
• To set the calibration values and provide an interface to read/write user data in each selected fob

In the Car Access System PC Application window, navigate to View > System Configuration to open the System
Configuration window, as shown in the following figure.
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Figure 5-3. System Configuration Window

The System Configuration window contains the following sections and associated data fields:

• “LF Antennas” – This section includes controls used to select the antenna channel and the current and
associated vehicle ID.

– “Antenna Channel” – Selecting any of these radio buttons assigns which antenna channel is used to send
the LF message from the vehicle. The LF antenna module must be connected to the corresponding port on
the ATA5291-XPRO board for this to function properly. Note that the Ant connector number on the
ATA5291-XPRO board starts at Ant0 while the antenna channel displayed on the CARS PC application
starts with Antenna Channel 1. As a result, Antenna Channel 1 on the PC application corresponds with
Ant0 on the board. This offset count continues for all six antenna channels.
Note:  When antenna channel 1 is used, ensure that the J1 jumper on the LF antenna module is set to the
inductor only ( ) position. When channels 2 through 6 are used, ensure the J1 jumper on the LF
antenna module is set to the LCR option.

– “Antenna Current” – This drop-down list determines the amount of current flowing in the LF antenna during
the LF message. This is directly related to the field strength at a given distance from the antenna.
Therefore, any change to this value has a direct impact on the performance of the localization during
PEPS.

– “Vehicle ID” – Sets the wake-up value transmitted with the LF message. Only fobs that are looking for this
value wake up and respond. The vehicle ID is set in the fob during the learn procedure and is user-
definable.

• “Learned Fobs” – This section lists up to four individual fob IDs paired with the system and saved in memory.
– “Learn” – This button performs the initial pairing of any new fobs to the system using the immobilizer LF

field provided by the LF antenna module. For details on the learn procedure, see 4.4  Initial Configuration of
the CARS Kit PC Evaluation Utility .

– “Clear” – This button erases all the saved fob secret keys and configuration data from the system memory.
Note:  The system does not have full functionality until a fob is paired.
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• “PEPS Features” – This section includes configuration settings that affect PEPS messaging functions, including
the type of authentication during polling, as well as, a polling interval.

– “Unilateral and Bilateral Authentication” – Selecting either of these radio buttons has an effect on the type
of communication used during polling only.

– “Polling”– Range checking and the determination of a desired threshold performance can easily be done
with polling. Selecting this check box starts the polling cycle, which repeats at a rate set in milliseconds.
Note:  500 ms is the minimum allowable value.

– “In/Out Threshold” – Used to determine if a fob is inside or outside of the vehicle by comparing the distance
scale result against the in/out threshold value. The boundary value is user-definable and can be specified
by entering a new value (1-599) in this field.

– “Priority Fob” – This drop-down list allows users to specify which fob is given priority when responding to a
PEPS command following the common slot of the anti-collision process.

• “PEPS Fob Actions” – This section allows for selection and communication with an individual fob even with other
PEPS fobs present.

– “Selected Fob” – This drop-down list allows direct access to an individual fob. Selecting “Broadcast” allows
communication with any fob, even unlearned ones. This facilitates accessing a fob ID even if the vehicle ID
for that specific fob is unknown.

– “Fob ID” – This button provides a way to access the current fob ID, the vehicle ID and the battery status.
– “S/W Ver” – This button requests the current fob software version.
– “Low Bat” – This check box is selected by the software if the battery voltage in the current fob is below the

low battery threshold (approximately 2.6V).
– “Fob Vehicle ID” – Displays the vehicle ID stored within the current fob.
– “LF Test” – This tab displays all the details relating to a test LF field measurement. Details such as the

external, internal RSSI values and coil phase clock counts display here. The distance scale value is
determined by the combined result of all post-RSSI processing. In a standard PEPS message, the distance
scale and the coil phase values are sent.

– “Parameter Access” – This tab displays general user memory sections of the fob EEPROM that can be
accessed via the PEPS system link. These are configured into 32 blocks of memory with each block having
16 bytes of data available. The data can be displayed in HEX or ASCII format. To access the memory, the
fob must first be put into a password-protected diagnostic mode by clicking the “Enter Diag” button. Then,
for several seconds, the fob responds to read or write commands.

– “Calibrate Fob” – This button initiates a calibration cycle, which provides reference values as each fob LF
antenna coil axis has slightly different gains due to the antenna coil, capacitor and IC tolerances. This is
typically done at the end-of-line testing by the manufacturer and is necessary to achieve consistent results.
It only needs to be performed once for each fob.

5.3.2 PEPS Message Status Window Overview
The PEPS Message Status window displays the challenge or response information along with localization details for
each fob that is learned to the system. In the Car Access System PC Application window, navigate to View > PEPS
Messaging to open the PEPS Message Status window, as shown in the following figure.
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Figure 5-4. PEPS Message Status Window

The PEPS Message Status window shows the following data fields:

• “Serial Number” – Displays the received fob ID. This must correspond to the value in the Learned Fobs section
of the System Configuration window.

• “LF Challenge” – Displays the 4-byte LF challenge data that was sent to the fob. This challenge data is sent
during bilateral and unilateral authentication.

• “LF Encrypted Challenge” – Displays the 4-byte LF encrypted data sent to the fob during bilateral authentication
only.

• “RF MAC” – Displays the received RF MAC (message authentication code) value from the fob.
• “Localization” – Displays the current localization status of the current fob (for example, inside or outside the

vehicle). This is determined by comparing the distance scale value against the In/Out Threshold value displayed
in the System Configuration window.
Note:  The fob section is highlighted in blue if the fob is found “inside” and pink if the fob is found “outside.” This
allows for an easy determination from a distance while the range of the system is being tested.

• “Distance Scale” – Indicates the RSSI scale value received.
• “Coil Phase Signature” – Displays a three-digit binary code, where:
•Table 5-2. Coil Phase Signature Calculation

Bit
Position

Calculation Using Coil Phase Clock
Count Values

Bit Value (if 90° < Calculated Result
< 270°)

Bit Value
(Otherwise)

1 � − � �����360 ����� � 360 1 0

2 � − � �����360 ����� � 360 1 0

3 � − � �����360 ����� � 360 1 0

Note:  The Z-Y, Z-X, Y-X and 360 coil phase clock count values are found in the “PEPS Fob Actions” section of
the System Configuration window.

• “Battery Low” – This check box is selected by the software if the fob returns a low voltage warning indicating the
battery voltage is below 2.6V (approximately).

• “Log file” – Selecting this check box creates a new record line in a CSV document for each received message
when it is selected.
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5.3.3 Identifying FOBS within LF Range
Identify the available fobs by sending out a broadcast, which returns the Fob# in the selected fob field. Perform the
following steps to identify the available fobs within the LF range:

1. If not done already, follow the procedure detailed in 4.  CARS Kit PC Evaluation Utility.
2. In the System Configuration window, choose Broadcast from the Selected Fob drop-down list.
3. Click the Fob ID button to send the broadcast request, as shown in the following figure. The available fobs

respond with their fob IDs and their Fob# assignments. The “Fob Vehicle ID” field displays the returned vehicle
ID.

4. Click the S/W Ver button to send the software version request to the fob. The “S/W Ver” field displays the
returned software version number.
Figure 5-5. Identifying FOBS in Range Test Window

Notes: 
• To use the broadcast function, it is recommended that only one fob be within range, and it must have a

battery inserted in the battery socket.
• Fobs that are not paired with the current system or that have a different vehicle ID, can also be identified

as within range. If the located fob is paired with the system, the selected fob index changes to the
location in the system where the fob is believed to be stored. It is recommended that the fob ID be
verified by checking it against the list of learned fobs.

5.3.4 Fob Calibration Overview
In a PEPS system, the learned fobs receive the LF signal and measure the magnetic field strength as an RSSI value.
This value is reported to the vehicle and determines the fob’s position with respect to the transmitting LF antenna. To
ensure RSSI accuracy, the fobs must be calibrated, including normalization and compensation, along all the three LF
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antenna coil axes (X, Y and Z-axis).Typically, this calibration is performed during the final test using high precision
equipment at the fob’s manufacturing facility. However, with the help of the CARS PC application, the end-of-line
calibration sequence is approximated by clicking the Calibrate Fob button in the System Configuration window.

The normalization procedure is used to establish a relationship between a known magnetic flux density and a
measured RSSI value. Ideally, an Helmholtz coil is used to perform this task but, considering the constraints of the
kit, this is not feasible. Instead, the RSSI value for each fob’s LF antenna coil axis (X, Y and Z) is measured at a fixed
distance (50 cm) from the transmitting LF antenna. Arbitrarily using the x-axis as the reference, the difference in
measurements of the other two axes are stored in the EEPROM as the Normalization Constants. On the other hand,
the compensation procedure accounts for any non-ideal influences; for example, magnetic flux disturbances due to
adjacent ferrous bodies, temperature, aging effects and so on. The compensation procedure is based on the
following:

• “Ref. RSSI” – Denotes the internal RSSI values measured with reference conditions (end-of-line) [1]
• “Int. RSSI” – Denotes the current internal RSSI measured with no external LF signal present [2]
• “Ext. RSSI” – Denotes the current external RSSI measured with external LF signal present [3]

The actual RSSI amplitude is, then, calculated by adding the error term [1] – [2] to the values measured at [3]. The
normalization and compensation procedures ensure that a constant RSSI is reported, regardless of the fob
orientation, and ensures accuracy over a large set of influences.

5.3.5 Fob Calibration Process
Perform the following calibration steps for each fob separately:

1. If not done already, follow the procedure detailed in 4.  CARS Kit PC Evaluation Utility.
2. In the System Configuration window, choose the fob to be calibrated in the “Selected Fob” drop-down list, as

shown in the following figure.
3. Click the Fob ID button followed by the Calibrate Fob button.
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Figure 5-6. FOB Calibration

4. Click the Next button within the Fob EOL Configuration window.
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Figure 5-7. FOB EOL Configuration Window

5. Position the LF antenna module and the fob (as shown in the following figure) to align the X-axis of the fob
with the LF antenna module axis, then click the Measure button. This measures the current X-axis RSSI signal
amplitude and updates the result to the “Peak RSSI” field for the X-axis. Click the Measure button several
times to ensure the peak value is stable.

6. Click the Next button.
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Figure 5-8. X-Axis Peak RSSI

7. Position the fob (as shown in the following figure) to align the Y-axis, then click the Measure button. This
measures the current Y-axis RSSI signal amplitude and updates the result to the “Peak RSSI” field for the Y-
axis. Click the Measure button several times to ensure the peak value is stable.

8. Click the Next button.
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Figure 5-9. Y-Axis Peak RSSI

9. Position the fob (as shown in the following figure) to align the Z-axis, then click the Measure button. This
measures the current Z-axis RSSI signal amplitude and updates the result to the “Peak RSSI” field for the Z-
axis. Click the Measure button several times to ensure the peak value is stable.

10. Click the Next button.
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Figure 5-10. Z-Axis Peak RSSI

11. Click the Measure button (as shown in the following figure) to have the fob perform an internal RSSI
measurement and display the results in the “Measured Int. RSSI” field. This measurement is performed by an
internal current source, which drives each of the fob’s 3-axis LF antenna coil circuits.

12. Click the Next button.
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Figure 5-11. Internal RSSI Measurement

13. Click the Configure button to store the compensation constants into the fob EEPROM (indicated by a blinking
LED on the ATAB5702A fob board). Before closing the Fob EOL Configuration window, wait until the LEDs
stop blinking.
Note:  If there is only a slight difference in the Int. RSSI values, select the “No change” check box.
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Figure 5-12. Slight Difference in Internal RSSI

Notes: 
• If there is a significant difference between the "Measured Int. RSSI" and the "EEPROM Int. RSSI" fields,

select the “Update EEPROM” check box. This can occur when the fob's components age over time or if a
change in the circuit has occurred (for example, evaluating a different 3D coil).

• Selecting the “Update EEPROM” check box updates the RSSI values currently stored in the EEPROM
with the newly measured values.
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Figure 5-13. Significant Difference in Internal RSSI Values

14. Click the LF Test button in the System Configuration window to check if the calibration values are stored in the
EEPROM, and to display the RSSI values in the respective fields within the “PEPS Fob Actions” section. The
“Ref. RSSI” values under the “PEPS Fob Actions” section must match the “Measured Int. RSSI” values from
the Fob EOL Configuration window. Repeat the fob calibration if these values do not match.
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Figure 5-14. RSSI Values

5.3.6 PEPS Wake-up Functionality
The PEPS wake-up functionality can be tested using the CARS PC application running on the host PC as follows:

1. If not done already, follow the procedure detailed in 4.  CARS Kit PC Evaluation Utility.
2. If not done already, follow the calibration procedure detailed in 5.3.5  Fob Calibration Process .
3. Select the desired LF antenna channel to send the LF message, as shown in the following figure.

Note:  When Antenna Channel 1 is used, ensure that the J1 jumper on the LF antenna module is set to the
inductor only ( ) position. When Antenna Channels 2 through 6 are used, ensure the J1 jumper on the
LF antenna module is set to the LCR option. Note that the Ant connector number on the ATA5291 XPRO
board starts at Ant0 while the antenna channel displayed on the CARS PC application starts with Antenna
Channel 1. As a result, Antenna Channel 1 on the PC application corresponds with Ant0 on the board. This
offset count continues for all six antenna channels.
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Figure 5-15. LF Antennas and Polling

4. Select the desired LF Antenna Current.
5. Enter the polling interval value in milliseconds (for example, 1000, meaning the LF wake-up signal is

transmitted every one second).
Note:  500 ms is the minimum allowable interval.

6. Select the “Polling” check box to enable polling and ensure that the LEDs on the fob blink each time the new
wake-up signal is received.

7. Type in a new Vehicle ID (for example, 887766), click on any other field within the window and ensure that the
LEDs on the fob no longer blink. This demonstrates that the fob only wakes up for the vehicle it was paired to.

8. Type in the original Vehicle ID: 667788.
9. Deselect the “Polling” check box to disable polling.

5.3.7 PEPS Communication
The PEPS communication functionality can be tested using the CARS PC application running on the host PC as
follows:

1. If not done already, follow the procedure detailed in 4.  CARS Kit PC Evaluation Utility.
2. If not done already, follow the calibration procedure detailed in 5.3.5  Fob Calibration Process .
3. Position the fob at the desired distance from the LF antenna module that will be used for the fob’s in/out

threshold.
4. Navigate to View > PEPS Messaging to open the PEPS Message Status window, as shown in Figure 5-4.
5. Click the PEPS UA button and, after the authentication sequence completes, note the value of the number in

the “Distance Scale” field of the PEPS Message Status window. Enter this value in the “In/Out Threshold” field
of the System Configuration window (see Figure 5-15).

6. Move the fob closer to the LF antenna module.
7. Click the PEPS UA button within the PEPS Message Status window to execute the unilateral authentication

sequence.
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Note:  The “LF Encrypted Challenge” field is not populated as this data is not transmitted to the fob.

Example: The results of a PEPS unilateral authentication sequence display in the following figure. With the
In/Out Threshold as 400.0 and the measured value distance scale as 451.3, the fob is identified as Inside the
vehicle and is highlighted in blue due to the distance scale value being greater than the threshold value.
Figure 5-16. PEPS Bilateral Authentication with Inside Localization

8. Move the fob further away from the LF antenna module, beyond the location used in step 3 but still within the
PEPS operating range.

9. Click the PEPS BA button within the PEPS Message Status window to execute the bilateral authentication
sequence. Confirm that the “LF Encrypted Challenge” field is now populated.
Example: The results of a PEPS bilateral authentication sequence display in the following figure. With the
In/Out Threshold as 400.0 and the measured value distance scale as 282.6, the fob is identified as Outside the
vehicle and is highlighted in pink due to the distance scale value being less than the threshold value.
Figure 5-17. PEPS Bilateral Authentication with Outside Localization
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Notes: 
• Either the PEPS UA or PEPS BA buttons can be used for either inside or outside localization.
• Each time the PEPS UA or PEPS BA button is clicked, a new PEPS wake-up signal is generated. Once the fob

receives the wake-up signal, the LED on the fob blinks and the PEPS Message Status window information is
updated.

• A continuous polling sequence can be achieved by selecting the “Polling” check box in the “PEPS Features”
section of the System Configuration window. This polling feature can be used to dynamically determine the
PEPS fob area coverage in real-time with the PEPS results displaying in the PEPS Message Status window.
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6. Programming Instructions
Specific firmware (Flash) and, in some devices, configuration settings (EEPROM) are required to operate the system.
These are found in the MCU (ATSAMC21-XPRO) and the RF transceiver (ATA5831-XPRO) on the vehicle side. The
fob requires its own PEPS, IMMO and RKE firmware and configuration files. The following list describes exactly what
type of files are needed for each device:

• Vehicle side:
– ATSAMC21-XPRO: PEPS, IMMO and RKE firmware and configuration in Flash
– ATA5831-XPRO: PEPS and RKE configuration in the EEPROM

• Fob side:
– ATAB5702A fob board: PEPS, IMMO and RKE firmware in Flash and configuration in the EEPROM

Note:  All devices within this system are shipped unprogrammed; therefore, the programming procedure is described
in the following sections. Programming is also required when the revised ATAK51005-V1 tool package software is
available for download from www.microchip.com/developmenttools/ProductDetails/ATAK51005-V1 or when the
source code has been modified or when a device becomes erratic or unresponsive in behavior.

6.1 Programming the ATA5702 on the ATAB5702A Fob Board
To program the ATA5702 on the ATAB5702A fob board, first connect the programmer (for example, Atmel-ICE or
JTAGICE3) to the ISP header located near the center of the board. The following steps use an Atmel-ICE
programmer and the ISP interface for programming:

1. In Atmel Studio 7, navigate to Tools > Device Programming.
Figure 6-1. Device Programming

2. Select the Tool, Device and Interface, as shown in the following figure, then click Apply.
Figure 6-2. ATA5702 Device Selection

3. Ensure that the ISP frequency is less than 100 kHz. Click Set.
Figure 6-3. ATA5702 ISP Clock Frequency

4. Click the Read button to ensure that the signature matches the selected device.
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Figure 6-4. ATA5702 Signature Verification

5. Select the Fuses tab, then verify that the proper fuse settings exist. If not, change them to match the following
figure, then click the Program button.
Figure 6-5. ATA5702 Fuse Settings

6. Select the Memories tab, then click the Erase now button.
7. Browse to locate the ATA5702_flash.hex file for the flash memory image.
8. Click the Program button, then wait for completion.
9. Browse to locate the ATA5702_eeprom.eep file for the EEPROM memory image.
10. Click the Program button, then wait for completion.

Figure 6-6. ATA5702 Memory Settings

Note:  If the EEPROM verification fails (as shown in the following figure), repeat steps 1-10 to ensure the
configuration is correct. If the error still occurs, then the ATA5702 IC version is outdated and the user must contact
their local sales representative for an upgrade.
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Figure 6-7. EEPROM Verification Failure

6.2 Programming the ATA5831 on the ATA5831-XPRO Board
Perform the following steps to program the ATA5831 on the ATA5831-XPRO board:

1. Insert the ATA5831-XPRO board in the EXT1 connector on the ATSAMC21-XPRO board.
2. Connect the micro-USB plug to the USB connector on the ATSAMC21-XPRO board, then connect the other

end of the USB cable to an open USB port on the PC.
3. Connect the programmer (for example, Atmel-ICE or JTAGICE3) to the ISP header located near the edge of

the board.
4. Place a jumper on the Enable position of the Enable | Disable Programming header, the two pins closest to the

EXT connector, as shown in the following figure.

Figure 6-8. Jumper Placement on the ATA5831-XPRO Board for EEPROM Programming

Jumper on Enable Position 

Note:  For better clarity, the ATSAMC21-XPRO board is not shown.

The following steps use an Atmel-ICE programmer and the ISP interface for programming:

1. In Atmel Studio 7, navigate to Tools > Device Programming.
2. Select the Tool, Device and Interface, as shown in the following figure, then click Apply.

Figure 6-9. ATA5831 Device Selection

3. Ensure that the ISP frequency is less than 100 kHz. Click Set.
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Figure 6-10. ATA5831 ISP Clock Frequency

4. Click the Read button to ensure that the signature matches the selected device.
Figure 6-11. ATA5831 Signature Verification

5. Select the Fuses tab and verify that the proper fuse settings exist. If not, change them to match the following
figure, then click the Program button.
Figure 6-12. ATA5831 Fuse Settings

6. Select the Memories tab, then click the Erase now button.
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Figure 6-13. ATA5831 Memory Settings

7. Browse to locate the ATA5831_eeprom.eep file for the EEPROM memory image.
8. Click the Program button, then wait for completion.
9. Place the jumper on the Disable position of the Enable | Disable Programming header, the two pins closest to

the ANT2 connector.
Figure 6-14. Jumper Placement on the ATA5831-XPRO Board to Disable Programming Mode

Jumper on Disable Position

Note:  For better clarity, the ATSAMC21-XPRO board is not shown.

6.3 Programming the SAMC21J18A on the ATSAMC21-XPRO Board
To program the SAMC21J18A on the ATSAMC21-XPRO board, ensure that the USB connection from the computer
to the ATSAMC21-XPRO board is in place. The following steps use the embedded debugger (EDBG) on the board
for programming:

1. In Atmel Studio 7, navigate to Tools > Device Programming.
2. Select the Tool, Device and Interface, as shown in the following figure, then click Apply.
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Figure 6-15. SAMC21J18A Device Selection

3. Click the Read button to ensure that the signature matches the selected device.
Figure 6-16. SAMC21J18A Signature Verification

4. Select the Fuses tab, then verify the proper fuse settings. The default fuse values are used except for the
User Word 0.NVMCTRL EEPROM SIZE, which must be set to 4096 bytes. Click the Program button.
Figure 6-17. SAMC21J18A Fuse Settings

5. Select the Memories tab, then click the Erase now button.
Figure 6-18. SAMC21J18A Memory Settings

6. Browse to locate the ATAK51005-V1.hex file for the flash memory image.
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7. Click the Program button, then wait for completion.
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7. XPRO USB Driver Installation
The necessary USB drivers to interface with the ATSAMC21-XPRO are included with the Atmel Studio integrated
software development environment (www.microchip.com/mplab/avr-support/atmel-studio-7). Download and install this
software development utility to get the USB drivers needed for the CARS kit evaluation utility.
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The Microchip Website

Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner and under normal

conditions.
• There are dishonest and possibly illegal methods being used in attempts to breach the code protection features

of the Microchip devices. We believe that these methods require using the Microchip products in a manner
outside the operating specifications contained in Microchip’s Data Sheets. Attempts to breach these code
protection features, most likely, cannot be accomplished without violating Microchip’s intellectual property rights.

• Microchip is willing to work with any customer who is concerned about the integrity of its code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code

protection does not mean that we are guaranteeing the product is “unbreakable.” Code protection is constantly
evolving. We at Microchip are committed to continuously improving the code protection features of our products.
Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act.
If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue
for relief under that Act.
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Legal Notice

Information contained in this publication is provided for the sole purpose of designing with and using Microchip
products. Information regarding device applications and the like is provided only for your convenience and may be
superseded by updates. It is your responsibility to ensure that your application meets with your specifications.

THIS INFORMATION IS PROVIDED BY MICROCHIP “AS IS”. MICROCHIP MAKES NO REPRESENTATIONS OR
WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR
OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR PURPOSE
OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL OR
CONSEQUENTIAL LOSS, DAMAGE, COST OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP'S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR ITS USE
WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO MICROCHIP FOR
THE INFORMATION. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk,
and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or
expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual
property rights unless otherwise stated.
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Quality Management System
For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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